summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 00:30:22 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:21:19 +0100
commitb85957b011afc163b7e9930e83adbfb922ddfae8 (patch)
tree224b28c7c4028c7ed033a29efebdde9545501248 /meta-yocto
parentd31d5e5b34c889809af408aed7d4f353d0133750 (diff)
downloadpoky-b85957b011afc163b7e9930e83adbfb922ddfae8.tar.gz
local.conf.sample: Cleanup and improve
local.conf is the first thing anyone new to the project sees. Over time it has built up a ton cruft and isn't even accurate in places. This patch: * Moves things to local.conf.sample.extended if a new user is unlikely to need to immediately care about the options * Reorders the file to be more intuitive to a new user * Moves certain default values to default-distrovars.inc in cases where most users wouldn't want to change the value * Adds large blocks of text to explain what an option does. There have been too many cases of a user not realising what some of these settings do and how they can use them to their advantage (like DL_DIR for example). (From OE-Core rev: a0ccb33ac5a2231c979c3369159f763dff1e0a2e) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/conf/local.conf.sample367
-rw-r--r--meta-yocto/conf/local.conf.sample.extended104
2 files changed, 287 insertions, 184 deletions
diff --git a/meta-yocto/conf/local.conf.sample b/meta-yocto/conf/local.conf.sample
index 80ee7b2615..644d548f20 100644
--- a/meta-yocto/conf/local.conf.sample
+++ b/meta-yocto/conf/local.conf.sample
@@ -1,230 +1,229 @@
1# CONF_VERSION is increased each time build/conf/ changes incompatibly 1#
2CONF_VERSION = "1" 2# This file is your local configuration file and is where all local user settings
3 3# are placed. The comments in this file give some guide to the options a new user
4# Uncomment and change to cache the files Poky downloads in an alternative 4# to the system might want to change but pretty much any configuration option can
5# location, default is ${TOPDIR}/downloads 5# be set in this file. More adventurous users can look at local.conf.extended
6#DL_DIR ?= "${TOPDIR}/downloads" 6# which contains other examples of configuration which can be placed in this file
7# Uncomment and change to cache Poky's built staging output in an alternative 7# but new users likely don't need any of them initially.
8# location, default is ${TOPDIR}/sstate-cache 8#
9#SSTATE_DIR ?= "${TOPDIR}/sstate-cache" 9# Lines starting with the '#' character are commented out and in some cases the
10# default values are provided as comments to show people example syntax. Enabling
11# the option is a question of removing the # character and making any change to the
12# variable as required.
10 13
11# Uncomment and set to allow bitbake to execute multiple tasks at once. 14#
12# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would 15# Parallelism Options
13# be appropriate. 16#
14# BB_NUMBER_THREADS = "4" 17# These two options control how much parallelism BitBake should use. The first
15# Also, make can be passed flags so it run parallel threads e.g.: 18# option determines how many tasks bitbake should run in parallel:
19#
20#BB_NUMBER_THREADS = "4"
21#
22# The second option controls how many processes make should run in parallel when
23# running compile tasks:
24#
16# PARALLEL_MAKE = "-j 4" 25# PARALLEL_MAKE = "-j 4"
26#
27# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
28# be appropriate for example.
17 29
18# Set a default machine to target unless a machine is selected from the 30#
19# lists below. 31# Machine Selection
20MACHINE ??= "qemux86" 32#
21 33# You need to select a specific machine to target the build with. There are a selection
22# Supported emulation machines 34# emulated machines available which can boot and run in the QEMU emulator:
35#
23#MACHINE ?= "qemuarm" 36#MACHINE ?= "qemuarm"
24#MACHINE ?= "qemumips" 37#MACHINE ?= "qemumips"
25#MACHINE ?= "qemuppc" 38#MACHINE ?= "qemuppc"
26#MACHINE ?= "qemux86" 39#MACHINE ?= "qemux86"
27#MACHINE ?= "qemux86-64" 40#MACHINE ?= "qemux86-64"
28 41#
29# Supported target hardware for demonstration purposes 42# There are also the following hardware board target machines included for
43# demonstration purposes:
44#
30#MACHINE ?= "atom-pc" 45#MACHINE ?= "atom-pc"
31#MACHINE ?= "beagleboard" 46#MACHINE ?= "beagleboard"
32#MACHINE ?= "emenlow" 47#MACHINE ?= "emenlow"
33#MACHINE ?= "mpc8315e-rdb" 48#MACHINE ?= "mpc8315e-rdb"
34#MACHINE ?= "routerstationpro" 49#MACHINE ?= "routerstationpro"
50#
51# This sets the default machine to be qemux86 if no other machine is selected:
52MACHINE ??= "qemux86"
35 53
36DISTRO ?= "poky"
37# For bleeding edge / experimental / unstable package versions
38# DISTRO ?= "poky-bleeding"
39
40# BBMASK is a regular expression that can be used to tell BitBake to ignore
41# certain recipes.
42#BBMASK = ""
43
44# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
45# (Some of these are automatically added to certain image types)
46# "dbg-pkgs" - add -dbg packages for all installed packages
47# (adds symbol information for debugging/profiling)
48# "dev-pkgs" - add -dev packages for all installed packages
49# (useful if you want to develop against libs in the image)
50# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
51# "tools-debug" - add debugging tools (gdb, strace)
52# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
53# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
54# "debug-tweaks" - make an image for suitable of development
55# e.g. ssh root access has a blank password
56# There are other application targets too, see meta/classes/core-image.bbclass
57# and meta/recipes-core/tasks/task-core.bb for more details.
58# The -sdk image includes these features by default now.
59EXTRA_IMAGE_FEATURES = "debug-tweaks"
60
61# A list of packaging systems used in generated images
62# The first package type listed will be used for rootfs generation
63# include 'package_deb' for debs
64# include 'package_ipk' for ipks
65# include 'package_rpm' for rpms
66#PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
67PACKAGE_CLASSES ?= "package_rpm package_ipk"
68
69# mklibs library size optimization is more useful to smaller images,
70# and less useful for bigger images. Also mklibs library optimization
71# can break the ABI compatibility, so should not be applied to the
72# images which are to be extended or upgraded later.
73#This enabled mklibs library size optimization just for the specified image.
74#MKLIBS_OPTIMIZED_IMAGES ?= "core-image-minimal"
75#This enable mklibs library size optimization will be for all the images.
76#MKLIBS_OPTIMIZED_IMAGES ?= "all"
77
78# A list of additional classes to use when building the system
79# include 'image-mklibs' to reduce shared library files size for an image
80# include 'image-prelink' in order to prelink the filesystem image
81# include 'image-swab' to perform host system intrusion detection
82# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
83USER_CLASSES ?= "image-mklibs image-prelink"
84
85# POKYMODE controls the characteristics of the generated packages/images by
86# telling poky which type of toolchain to use.
87# 54#
88# Options include several different EABI combinations and a compatibility 55# Where to place downloads
89# mode for the OABI mode poky previously used.
90# 56#
91# The default is "eabi" 57# During a first build the system will download many differernt source code tarballs
92# Use "oabi" for machines with kernels < 2.6.18 on ARM for example. 58# from various upstream projects. This can take a while, particularly if your network
93# Use "external-MODE" to use the precompiled external toolchains where MODE 59# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
94# is the type of external toolchain to use e.g. eabi. 60# can preserve this directory to speed up this part of subsequent builds. This directory
95# POKYMODE = "external-eabi" 61# is safe to share between multiple builds on the same machine too.
96 62#
97# Uncomment this to specify where BitBake should create its temporary files. 63# The default is a downloads directory under TOPDIR which is the build directory.
98# Note that a full build of everything in OpenEmbedded will take GigaBytes of hard 64#
99# disk space, so make sure to free enough space. The default TMPDIR is 65#DL_DIR ?= "${TOPDIR}/downloads"
100# <build directory>/tmp
101#TMPDIR = "${COREBASE}/build/tmp"
102 66
103# The following are used to control options related to debugging.
104# 67#
105# Uncomment this to change the optimization to make debugging easer, at the 68# Where to place shared-state files
106# possible cost of performance. 69#
107# DEBUG_BUILD = "1" 70# BitBake has the capability to accelerate builds based on previously built output.
71# This is done using "shared state" files which can be through of as cache objects
72# and this option determines where those files are placed.
108# 73#
109# Uncomment this to disable the stripping of the installed binaries 74# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
110# INHIBIT_PACKAGE_STRIP = "1" 75# from these files if no chages were made to the configuration. If changes were made
76# to the configuration, only shared state files where the state was still valid would
77# be used (done using checksums).
111# 78#
112# Uncomment this to disable the split of the debug information into -dbg files 79# The default is a sstate-cache directory under TOPDIR.
113# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
114# 80#
115# When splitting debug information, the following controls the results of the 81#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
116# file splitting. 82
117# 83#
118# .debug (default): 84# Where to place the build output
119# When splitting the debug information will be placed into
120# a .debug directory in the same dirname of the binary produced:
121# /bin/foo -> /bin/.debug/foo
122# 85#
123# debug-file-directory: 86# This option specifies where the bulk of the building work should be done and
124# When splitting the debug information will be placed into 87# where BitBake should place its temporary files and output. Keep in mind that
125# a central debug-file-directory, /usr/lib/debug: 88# this includes the extraction and complation of many applications and the toolchain
126# /bin/foo -> /usr/lib/debug/bin/foo.debug 89# which can use Gigabytes of hard disk space.
127# 90#
128# Any source code referenced in the debug symbols will be copied 91# The default is a tmp directory under TOPDIR.
129# and made available within the /usr/src/debug directory
130# 92#
131PACKAGE_DEBUG_SPLIT_STYLE = '.debug' 93#TMPDIR = "${TOPDIR}/tmp"
132# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
133 94
134# Uncomment these to build a package such that you can use gprof to profile it. 95#
135# NOTE: This will only work with 'linux' targets, not 96# Default policy config
136# 'linux-uclibc', as uClibc doesn't provide the necessary 97#
137# object files. Also, don't build glibc itself with these 98# The distribution setting controls which policy settings are used as defaults.
138# flags, or it'll fail to build. 99# The default value is fine for general Yocto project use, at least initially.
139# 100# Ultimately when creating custom policy, people will likely end up subclassing
140# PROFILE_OPTIMIZATION = "-pg" 101# these defaults.
141# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}" 102#
142# LDFLAGS =+ "-pg" 103DISTRO ?= "poky"
104# As an exable of a subclass there is a "bleeding" egde policy configuration
105# where many versions are set to the absolute latest code from the upstream
106# source control systems. This is just mentioned here an an example, its not
107# useful to most new users.
108# DISTRO ?= "poky-bleeding"
143 109
144# Uncomment this if you want BitBake to emit the log if a build fails. 110#
145BBINCLUDELOGS = "yes" 111# Package Management configuration
112#
113# This variable lists which packaging formats to enable. Multiple package backends
114# can be enabled at once and the first item listed in the variable will be used
115# to generate the root filesystems.
116# Options are:
117# - 'package_deb' for debian style deb files
118# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
119# - 'package_rpm' for rpm style packages
120# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
121# We default to rpm:
122PACKAGE_CLASSES ?= "package_rpm"
146 123
147# The architecture to build SDK items for, by setting this you can build SDK 124#
148# packages for architectures other than the host i.e. building i686 packages 125# SDK/ADT target architecture
149# on an x86_64 host. 126#
127# This variable specified the architecture to build SDK/ADT items for and means
128# you can build the SDK packages for architectures other than the machine you are
129# running the build on (i.e. building i686 packages on an x86_64 host._
150# Supported values are i686 and x86_64 130# Supported values are i686 and x86_64
151#SDKMACHINE ?= "i686" 131#SDKMACHINE ?= "i686"
152 132
153# The build system can check data caches for prebuilt data objects before 133#
154# it builds the data itself. This can be a filesystem directory, or a remote url 134# Extra image configuration defaults
155# such as http or ftp. These would contain the sstate-cache results from previous 135#
156# builds (possibly from other machines). This variable works like fetcher 136# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
157# MIRRORS/PREMIRRORS and points to the cache locations to check for the shared objects. 137# images. Some of these options are added to certain image types automatically. The
158#SSTATE_MIRRORS ?= "\ 138# variable can contain the following options:
159#file://.* http://someserver.tld/share/sstate/ \n \ 139# "dbg-pkgs" - add -dbg packages for all installed packages
160#file://.* file:///some/local/dir/sstate/" 140# (adds symbol information for debugging/profiling)
141# "dev-pkgs" - add -dev packages for all installed packages
142# (useful if you want to develop against libs in the image)
143# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
144# "tools-debug" - add debugging tools (gdb, strace)
145# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
146# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
147# "debug-tweaks" - make an image for suitable of development
148# e.g. ssh root access has a blank password
149# There are other application targets that can be uses here too, see
150# meta/classes/core-image.bbclass and meta/recipes-core/tasks/task-core.bb for more details.
151# We default to enabling the debugging tweaks.
152EXTRA_IMAGE_FEATURES = "debug-tweaks"
161 153
162# Set IMAGETEST to qemu if you want to build testcases and start 154#
163# testing in qemu after do_rootfs. 155# Additional image features
164#IMAGETEST = "qemu" 156#
157# The following is a list of additional classes to use when building images which
158# enable extra features. Some available options which can be included in this variable
159# are:
160# - 'image-mklibs' to reduce shared library files size for an image
161# - 'image-prelink' in order to prelink the filesystem image
162# - 'image-swab' to perform host system intrusion detection
163# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
164# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
165USER_CLASSES ?= "image-mklibs image-prelink"
165 166
166# By default test cases in sanity suite will be ran. If you want to run other 167#
167# test suite or specific test case(e.g. bat or boot test case under sanity suite), 168# Runtime testing of images
168# list them like following. 169#
170# The build system can test booting virtual machine images under qemu (an emulator)
171# after any root filesystems are created and run tests against those images. To
172# enable this uncomment this line
173#IMAGETEST = "qemu"
174#
175# This variable controls which tests are run against virtual images if enabled
176# above. The following would enable bat, oot test case under sanity suite and
177# toolchain tests
169#TEST_SCEN = "sanity bat sanity:boot toolchain" 178#TEST_SCEN = "sanity bat sanity:boot toolchain"
170 179#
171#Because of the QEMU booting slowness issue(see bug #646 and #618), autobuilder 180# Because of the QEMU booting slowness issue(see bug #646 and #618), autobuilder
172#may suffer a timeout issue when running sanity test. We introduce variable 181# may suffer a timeout issue when running sanity test. We introduce variable
173#TEST_SERIALIZE here to reduce the time on sanity test. It is by default set 182# TEST_SERIALIZE here to reduce the time on sanity test. It is by default set
174#to 1. Poky will start image and run cases in the same image without reboot 183# to 1. This will start image and run cases in the same image without reboot
175#or kill. If it is set to 0, the image will be copied and tested for each 184# or kill. If it is set to 0, the image will be copied and tested for each
176#case, which will take much time. 185# case, which will take longer but be more precise.
177#TEST_SERIALIZE = "1" 186#TEST_SERIALIZE = "1"
178 187
179# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale 188#
180# packages at build time using qemu-native. Disabling it (by setting it to 0) 189# Interactive shell configuration
181# will save some build time at the expense of breaking i18n on devices with 190#
182# less than 128MB RAM. 191# Under certain circumstances the system may need input from you and to do this it
183ENABLE_BINARY_LOCALE_GENERATION = "1" 192# can launch an interactive shell. It needs to do this since the build is
184 193# multithreaded and needs to be able to handle the case where more than one parallel
185# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not 194# process may require the user's attention. The default is to use xterm.
186# wish to perform the time-consuming step of generating all LIBC locales. 195#
187# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set 196# Examples of the occasions this may happen are when resolving patches which cannot
188# appropriate values for IMAGE_LINGUAS and LIMIT_BUILT_LOCALES 197# be applied, to use the devshell or the kernel menuconfig
189# WARNING: this may break localisation! 198#
190#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
191# See message above as to whether setting these is required
192#IMAGE_LINGUAS ?= "en-gb"
193#LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
194
195# This value is currently used by pseudo to determine if the recipe should
196# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
197#
198# Pseudo will attempt to determine if a 32-bit wrapper is necessary, but
199# it doesn't always guess properly. If you have 32-bit executables on
200# your 64-bit build system, you likely want to set this to "0",
201# otherwise you could end up with incorrect file attributes on the
202# target filesystem.
203#
204# Default to not build 32 bit libs on 64 bit systems, comment this
205# out if that is desired
206NO32LIBS = "1"
207
208# If you do not use (or have installed) xterm you will need to 199# If you do not use (or have installed) xterm you will need to
209# uncomment these variables and set them to the terminal you wish to use 200# uncomment these variables and set them to the terminal you wish to use
210# when resolving patches which cannot be applied 201#
211# Supported shell prefixes for *_TERMCMD and *_TERMCMDRUN ARE: 202# Supported shell prefixes for *_TERMCMD and *_TERMCMDRUN are:
212# GNOME, SCREEN, XTERM and KONSOLE 203# GNOME, SCREEN, XTERM and KONSOLE
213# Note: currently, Konsole support only works for KDE 3.x due to the way 204# Note: currently, Konsole support only works for KDE 3.x due to the way
214# newer Konsole versions behave 205# newer Konsole versions behave
215#TERMCMD = "${XTERM_TERMCMD}" 206#TERMCMD = "${XTERM_TERMCMD}"
216#TERMCMDRUN = "${XTERM_TERMCMDRUN}" 207#TERMCMDRUN = "${XTERM_TERMCMDRUN}"
217# Alternatively, if you prefer you can disable patch resolution: 208# You can disable interactive patch resolution (tasks will just fail instead) with:
218#PATCHRESOLVE = "noop" 209#PATCHRESOLVE = "noop"
219 210
220# The network based PR service host and port 211#
221#PRSERV_HOST = "localhost" 212# Shared-state files from other locations
222#PRSERV_PORT = "8585" 213#
223 214# As mentioned above, shared state files are prebuilt cache data objects which can
224# Uncomment this if your host distribution provides the help2man tool. 215# used to accelerate build time. This variable can be used to configure the system
225#ASSUME_PROVIDED += "help2man-native" 216# to search other mirror locations for these objects before it builds the data itself.
217#
218# This can be a filesystem directory, or a remote url such as http or ftp. These
219# would contain the sstate-cache results from previous builds (possibly from other
220# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
221# cache locations to check for the shared objects.
222#SSTATE_MIRRORS ?= "\
223#file://.* http://someserver.tld/share/sstate/ \n \
224#file://.* file:///some/local/dir/sstate/"
226 225
227# Uncomment the following lines to enable multilib builds 226# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
228#require conf/multilib.conf 227# track the version of this file when it was generated. This can safely be ignored if
229#MULTILIBS = "multilib:lib32" 228# this doesn't mean anything to you.
230#DEFAULTTUNE_virtclass-multilib-lib32 = "x86" 229CONF_VERSION = "1"
diff --git a/meta-yocto/conf/local.conf.sample.extended b/meta-yocto/conf/local.conf.sample.extended
index 277ee2a8ec..a42774cfac 100644
--- a/meta-yocto/conf/local.conf.sample.extended
+++ b/meta-yocto/conf/local.conf.sample.extended
@@ -1,3 +1,7 @@
1# BBMASK is a regular expression that can be used to tell BitBake to ignore
2# certain recipes.
3#BBMASK = ""
4
1# eglibc configurability is used to reduce minimal images's size. 5# eglibc configurability is used to reduce minimal images's size.
2# the all supported eglibc options are listed in DISTRO_FEATURES_LIBC 6# the all supported eglibc options are listed in DISTRO_FEATURES_LIBC
3# and disabled by default. Uncomment and copy the DISTRO_FEATURES_LIBC 7# and disabled by default. Uncomment and copy the DISTRO_FEATURES_LIBC
@@ -10,3 +14,103 @@
10# libc-posix-wchar-io" 14# libc-posix-wchar-io"
11 15
12#DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci ${DISTRO_FEATURES_LIBC}" 16#DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci ${DISTRO_FEATURES_LIBC}"
17
18# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale
19# packages at build time using qemu-native. Disabling it (by setting it to 0)
20# will save some build time at the expense of breaking i18n on devices with
21# less than 128MB RAM.
22#ENABLE_BINARY_LOCALE_GENERATION = "1"
23
24# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
25# wish to perform the time-consuming step of generating all LIBC locales.
26# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
27# appropriate values for IMAGE_LINGUAS and LIMIT_BUILT_LOCALES
28# WARNING: this may break localisation!
29#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
30# See message above as to whether setting these is required
31#IMAGE_LINGUAS ?= "en-gb"
32#LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
33
34# The following are used to control options related to debugging.
35#
36# Uncomment this to change the optimization to make debugging easer, at the
37# possible cost of performance.
38# DEBUG_BUILD = "1"
39#
40# Uncomment this to disable the stripping of the installed binaries
41# INHIBIT_PACKAGE_STRIP = "1"
42#
43# Uncomment this to disable the split of the debug information into -dbg files
44# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
45#
46# When splitting debug information, the following controls the results of the
47# file splitting.
48#
49# .debug (default):
50# When splitting the debug information will be placed into
51# a .debug directory in the same dirname of the binary produced:
52# /bin/foo -> /bin/.debug/foo
53#
54# debug-file-directory:
55# When splitting the debug information will be placed into
56# a central debug-file-directory, /usr/lib/debug:
57# /bin/foo -> /usr/lib/debug/bin/foo.debug
58#
59# Any source code referenced in the debug symbols will be copied
60# and made available within the /usr/src/debug directory
61#
62#PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
63# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
64
65# Uncomment these to build a package such that you can use gprof to profile it.
66# NOTE: This will only work with 'linux' targets, not
67# 'linux-uclibc', as uClibc doesn't provide the necessary
68# object files. Also, don't build glibc itself with these
69# flags, or it'll fail to build.
70#
71# PROFILE_OPTIMIZATION = "-pg"
72# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
73# LDFLAGS =+ "-pg"
74
75# TCMODE controls the characteristics of the generated packages/images by
76# telling poky which toolchain 'profile' to use.
77#
78# The default is "default"
79# Use "external-MODE" to use the precompiled external toolchains where MODE
80# is the type of external toolchain to use e.g. eabi. You need to ensure
81# the toolchain you want to use is included in an an appropriate layer
82# TCMODE = "external-eabi"
83
84# mklibs library size optimization is more useful to smaller images,
85# and less useful for bigger images. Also mklibs library optimization
86# can break the ABI compatibility, so should not be applied to the
87# images which are to be extended or upgraded later.
88#This enabled mklibs library size optimization just for the specified image.
89#MKLIBS_OPTIMIZED_IMAGES ?= "core-image-minimal"
90#This enable mklibs library size optimization will be for all the images.
91#MKLIBS_OPTIMIZED_IMAGES ?= "all"
92
93# Uncomment this if your host distribution provides the help2man tool.
94#ASSUME_PROVIDED += "help2man-native"
95
96# This value is currently used by pseudo to determine if the recipe should
97# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
98#
99# Pseudo will attempt to determine if a 32-bit wrapper is necessary, but
100# it doesn't always guess properly. If you have 32-bit executables on
101# your 64-bit build system, you likely want to set this to "0",
102# otherwise you could end up with incorrect file attributes on the
103# target filesystem.
104#
105# Default is to not build 32 bit libs on 64 bit systems, uncomment this
106# if you need the 32 bits libs
107#NO32LIBS = "0"
108
109# Uncomment the following lines to enable multilib builds
110#require conf/multilib.conf
111#MULTILIBS = "multilib:lib32"
112#DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
113
114# The network based PR service host and port
115#PRSERV_HOST = "localhost"
116#PRSERV_PORT = "8585"