summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-29 13:55:51 -0700
committerSaul Wold <sgw@linux.intel.com>2011-08-18 22:20:52 -0700
commit915f1e0773d8783f1e38fab345e582096e6f609d (patch)
tree9137027fbde50a8efa227e2220233c1240395465 /meta-yocto
parente744900fa58d90bcccf7a1af1841863419ffcda3 (diff)
downloadpoky-915f1e0773d8783f1e38fab345e582096e6f609d.tar.gz
meta-yocto: add linux-yocto-rt support for all meta-yocto machines
Provide the necessary info in the linux-yocto-rt_3.0.bbappend to support building the RT kernel for each of the meta-yocto example BSPs. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 0000000000..a575105902
--- /dev/null
+++ b/meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,25 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# atom-pc support
4COMPATIBLE_MACHINE_atom-pc = "atom-pc"
5KMACHINE_atom-pc = "atom-pc"
6KBRANCH_atom-pc = "yocto/standard/preempt-rt/base"
7SRCREV_machine_pn-linux-yocto-rt_atom-pc = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f"
8
9# mpc8315e-rdb support
10COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
11KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
12KBRANCH_mpc8315e-rdb = "yocto/standard/preempt-rt/base"
13SRCREV_machine_pn-linux-yocto-rt_mpc8315e-rdb = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f"
14
15# beagleboard support - 3.0 support has not yet been completed, build failure
16#COMPATIBLE_MACHINE_beagleboard = "beagleboard"
17#KMACHINE_beagleboard = "beagleboard"
18#KBRANCH_beagleboard = "yocto/standard/preempt-rt/base"
19#SRCREV_machine_pn-linux-yocto-rt_beagleboard =
20
21# routerstationpro support - preempt-rt kernel build failure
22#COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
23#KMACHINE_routerstationpro = "routerstationpro"
24#KBRANCH_routerstationpro = "yocto/standard/preempt-rt/base"
25#SRCREV_machine_pn-linux-yocto-rt_routerstationpro = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f"