summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-03-23 13:12:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-23 18:08:40 +0000
commitac56e2ed37d592f9af84a14074367b7d137818f8 (patch)
tree6c48d9f851649885fb0c76adb599cd37a542ed16 /meta-yocto
parent0233e6b1a7f72aa392a68cd9c8a6748f59857b50 (diff)
downloadpoky-ac56e2ed37d592f9af84a14074367b7d137818f8.tar.gz
linux-libc-headers-yocto: move to meta-yocto
linux-libc-headers-yocto is not directly required in meta, so we can safely move it to meta-yocto. Machines including meta-yocto that are using linux-yocto that need headers which are completely up to date with the linux-yocto git tree can use this as their preferred linux-libc-headers. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
new file mode 100644
index 0000000000..756b596913
--- /dev/null
+++ b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -0,0 +1,64 @@
1require recipes-kernel/linux-libc-headers/linux-libc-headers.inc
2include recipes-kernel/linux/linux-yocto.inc
3
4B = "${S}"
5
6INHIBIT_DEFAULT_DEPS = "1"
7DEPENDS += "unifdef-native"
8PROVIDES = "linux-libc-headers"
9RPROVIDES_${PN}-dev = "linux-libc-headers-dev"
10RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg"
11SRCREV = "21ab5dca134a6bf1316aa59f69f9ee9e091d5702"
12KBRANCH ?= "standard/base"
13KMETA ?= "meta"
14PV = "3.2+git-${SRCPV}"
15PR = "r5"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
18
19# force this to empty to prevent installation failures, we aren't
20# building a device tree as part of kern headers
21KERNEL_DEVICETREE = ""
22
23set_arch() {
24 case ${TARGET_ARCH} in
25 arm*) ARCH=arm ;;
26 i*86*) ARCH=i386 ;;
27 ia64*) ARCH=ia64 ;;
28 mips*) ARCH=mips ;;
29 powerpc*) ARCH=powerpc ;;
30 x86_64*) ARCH=x86_64 ;;
31 esac
32}
33
34do_configure() {
35 set_arch
36 oe_runmake allnoconfig ARCH=$ARCH
37}
38
39do_install() {
40 set_arch
41 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
42
43 # The ..install.cmd conflicts between various configure runs
44 find ${D}${includedir} -name ..install.cmd | xargs rm -f
45}
46
47# The following tasks are not required when we just want
48# headers. So we override and stub them out.
49do_kernel_configme() {
50}
51
52do_patch () {
53}
54
55do_compile () {
56}
57
58do_validate_branches () {
59}
60
61do_kernel_configcheck () {
62}
63
64BBCLASSEXTEND = "nativesdk"