summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-05 09:18:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-05 11:24:34 +0000
commita6e61c02a7f824e9e6043a91e65c117d585fab97 (patch)
tree9624edaebdb7d3c69483d59cecbeec3748f56724 /meta-yocto
parent22106230a87566dff6140cb677426d4da31d6f59 (diff)
downloadpoky-a6e61c02a7f824e9e6043a91e65c117d585fab97.tar.gz
conf/local.conf.sample: fix typos/grammar/formatting
(From OE-Core rev: 6f81b3695f6f1e19906e6173c6c7e3ee4f86a11b) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/conf/local.conf.sample35
1 files changed, 18 insertions, 17 deletions
diff --git a/meta-yocto/conf/local.conf.sample b/meta-yocto/conf/local.conf.sample
index 12b38e8131..38507e3b3a 100644
--- a/meta-yocto/conf/local.conf.sample
+++ b/meta-yocto/conf/local.conf.sample
@@ -4,7 +4,7 @@
4# to the system might want to change but pretty much any configuration option can 4# to the system might want to change but pretty much any configuration option can
5# be set in this file. More adventurous users can look at local.conf.extended 5# be set in this file. More adventurous users can look at local.conf.extended
6# which contains other examples of configuration which can be placed in this file 6# which contains other examples of configuration which can be placed in this file
7# but new users likely don't need any of them initially. 7# but new users likely won't need any of them initially.
8# 8#
9# Lines starting with the '#' character are commented out and in some cases the 9# Lines starting with the '#' character are commented out and in some cases the
10# default values are provided as comments to show people example syntax. Enabling 10# default values are provided as comments to show people example syntax. Enabling
@@ -22,16 +22,16 @@
22# The second option controls how many processes make should run in parallel when 22# The second option controls how many processes make should run in parallel when
23# running compile tasks: 23# running compile tasks:
24# 24#
25# PARALLEL_MAKE = "-j 4" 25#PARALLEL_MAKE = "-j 4"
26# 26#
27# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would 27# For a quad-core machine, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
28# be appropriate for example. 28# be appropriate for example.
29 29
30# 30#
31# Machine Selection 31# Machine Selection
32# 32#
33# You need to select a specific machine to target the build with. There are a selection 33# You need to select a specific machine to target the build with. There are a selection
34# emulated machines available which can boot and run in the QEMU emulator: 34# of emulated machines available which can boot and run in the QEMU emulator:
35# 35#
36#MACHINE ?= "qemuarm" 36#MACHINE ?= "qemuarm"
37#MACHINE ?= "qemumips" 37#MACHINE ?= "qemumips"
@@ -67,7 +67,7 @@ MACHINE ??= "qemux86"
67# Where to place shared-state files 67# Where to place shared-state files
68# 68#
69# BitBake has the capability to accelerate builds based on previously built output. 69# BitBake has the capability to accelerate builds based on previously built output.
70# This is done using "shared state" files which can be through of as cache objects 70# This is done using "shared state" files which can be thought of as cache objects
71# and this option determines where those files are placed. 71# and this option determines where those files are placed.
72# 72#
73# You can wipe out TMPDIR leaving this directory intact and the build would regenerate 73# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
@@ -143,10 +143,10 @@ PACKAGE_CLASSES ?= "package_rpm"
143# "tools-debug" - add debugging tools (gdb, strace) 143# "tools-debug" - add debugging tools (gdb, strace)
144# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only)) 144# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
145# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.) 145# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
146# "debug-tweaks" - make an image for suitable of development 146# "debug-tweaks" - make an image suitable for development
147# e.g. ssh root access has a blank password 147# e.g. ssh root access has a blank password
148# There are other application targets that can be uses here too, see 148# There are other application targets that can be used here too, see
149# meta/classes/core-image.bbclass and meta/recipes-core/tasks/task-core.bb for more details. 149# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
150# We default to enabling the debugging tweaks. 150# We default to enabling the debugging tweaks.
151EXTRA_IMAGE_FEATURES = "debug-tweaks" 151EXTRA_IMAGE_FEATURES = "debug-tweaks"
152 152
@@ -173,16 +173,17 @@ USER_CLASSES ?= "buildstats image-mklibs image-prelink"
173#IMAGETEST = "qemu" 173#IMAGETEST = "qemu"
174# 174#
175# This variable controls which tests are run against virtual images if enabled 175# This variable controls which tests are run against virtual images if enabled
176# above. The following would enable bat, oot test case under sanity suite and 176# above. The following would enable bat, boot the test case under the sanity suite
177# toolchain tests 177# and perform toolchain tests
178#TEST_SCEN = "sanity bat sanity:boot toolchain" 178#TEST_SCEN = "sanity bat sanity:boot toolchain"
179# 179#
180# Because of the QEMU booting slowness issue(see bug #646 and #618), autobuilder 180# Because of the QEMU booting slowness issue (see bug #646 and #618), the
181# may suffer a timeout issue when running sanity test. We introduce variable 181# autobuilder may suffer a timeout issue when running sanity tests. We introduce
182# TEST_SERIALIZE here to reduce the time on sanity test. It is by default set 182# the variable TEST_SERIALIZE here to reduce the time taken by the sanity tests.
183# to 1. This will start image and run cases in the same image without reboot 183# It is set to 1 by default, which will boot the image and run cases in the same
184# or kill. If it is set to 0, the image will be copied and tested for each 184# image without rebooting or killing the machine instance. If it is set to 0, the
185# case, which will take longer but be more precise. 185# image will be copied and tested for each case, which will take longer but be
186# more precise.
186#TEST_SERIALIZE = "1" 187#TEST_SERIALIZE = "1"
187 188
188# 189#
@@ -197,7 +198,7 @@ USER_CLASSES ?= "buildstats image-mklibs image-prelink"
197# Examples of the occasions this may happen are when resolving patches which cannot 198# Examples of the occasions this may happen are when resolving patches which cannot
198# be applied, to use the devshell or the kernel menuconfig 199# be applied, to use the devshell or the kernel menuconfig
199# 200#
200# Supported values are auto, gnome, xfce, rxvt, xcreen, konsole (3.x only), none 201# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
201# Note: currently, Konsole support only works for KDE 3.x due to the way 202# Note: currently, Konsole support only works for KDE 3.x due to the way
202# newer Konsole versions behave 203# newer Konsole versions behave
203#OE_TERMINAL = "auto" 204#OE_TERMINAL = "auto"