summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-03 23:53:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-03 23:53:32 +0000
commitb0dec83e8c17d884323d58bb8d56c7ab6afa7ead (patch)
tree194d268995c1f8f6e660ee9ed8bfbe89967ab221 /meta-yocto
parentdabd5deb4e50189fba9ccc60a219a5c6a05c8db1 (diff)
downloadpoky-b0dec83e8c17d884323d58bb8d56c7ab6afa7ead.tar.gz
meta-yocto: Move files inappropriate to OE-Core from meta
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/conf/bblayers.conf.sample8
-rw-r--r--meta-yocto/conf/distro/poky-bleeding.conf8
-rw-r--r--meta-yocto/conf/distro/poky-lsb.conf9
-rw-r--r--meta-yocto/conf/distro/poky.conf167
-rw-r--r--meta-yocto/conf/local.conf.sample219
-rw-r--r--meta-yocto/conf/machine/atom-pc.conf46
-rw-r--r--meta-yocto/conf/machine/beagleboard.conf37
-rw-r--r--meta-yocto/conf/machine/mpc8315e-rdb.conf20
-rw-r--r--meta-yocto/conf/machine/routerstationpro.conf24
-rw-r--r--meta-yocto/conf/site.conf.sample40
10 files changed, 578 insertions, 0 deletions
diff --git a/meta-yocto/conf/bblayers.conf.sample b/meta-yocto/conf/bblayers.conf.sample
new file mode 100644
index 0000000000..b2f37c0c81
--- /dev/null
+++ b/meta-yocto/conf/bblayers.conf.sample
@@ -0,0 +1,8 @@
1# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
2# changes incompatibly
3LCONF_VERSION = "4"
4
5BBFILES ?= ""
6BBLAYERS = " \
7 ##POKYBASE##/meta \
8 "
diff --git a/meta-yocto/conf/distro/poky-bleeding.conf b/meta-yocto/conf/distro/poky-bleeding.conf
new file mode 100644
index 0000000000..328acfeb75
--- /dev/null
+++ b/meta-yocto/conf/distro/poky-bleeding.conf
@@ -0,0 +1,8 @@
1PREFERRED_VERSION_glib-2.0 ?= "2.17.4"
2PREFERRED_VERSION_glib-2.0-native ?= "2.17.4"
3PREFERRED_VERSION_atk ?= "1.22.0"
4PREFERRED_VERSION_pango ?= "1.21.2"
5PREFERRED_VERSION_gtk+ ?= "2.13.3"
6
7require conf/distro/include/poky-floating-revisions.inc
8require conf/distro/poky.conf
diff --git a/meta-yocto/conf/distro/poky-lsb.conf b/meta-yocto/conf/distro/poky-lsb.conf
new file mode 100644
index 0000000000..749c85886a
--- /dev/null
+++ b/meta-yocto/conf/distro/poky-lsb.conf
@@ -0,0 +1,9 @@
1require conf/distro/poky.conf
2
3DISTRO = "poky-lsb"
4DISTROOVERRIDES = "poky:poky-lsb"
5
6DISTRO_FEATURES += "pam"
7PREFERRED_PROVIDER_virtual/libx11 = "libx11"
8
9
diff --git a/meta-yocto/conf/distro/poky.conf b/meta-yocto/conf/distro/poky.conf
new file mode 100644
index 0000000000..71e40de6f2
--- /dev/null
+++ b/meta-yocto/conf/distro/poky.conf
@@ -0,0 +1,167 @@
1#@TYPE: Distribution#@NAME: Poky
2#@DESCRIPTION: Distribution configuration for the Yocto Project build by Poky
3
4DISTRO = "poky"
5DISTRO_NAME = "Yocto (Built by Poky 4.0)"
6DISTRO_VERSION = "0.9+snapshot-${DATE}"
7SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
8
9MAINTAINER = "Poky <poky@yoctoproject.org>"
10
11USER_CLASSES ?= ""
12
13PACKAGE_CLASSES ?= "package_ipk"
14INHERIT_INSANE ?= "insane"
15INHERIT += "${PACKAGE_CLASSES} ${USER_CLASSES} debian devshell ${INHERIT_INSANE} sstate license"
16# For some reason, this doesn't work
17# TARGET_OS ?= "linux"
18# TARGET_VENDOR ?= "-poky"
19# Set by POKYMODE instead
20TARGET_OS = "linux"
21TARGET_FPU_arm ?= "soft"
22TARGET_FPU_armeb ?= "soft"
23TARGET_FPU_nokia800 = "hard"
24
25TARGET_LINK_HASH_STYLE ?= "${@['-Wl,--hash-style=gnu',''][bb.data.getVar('TARGET_ARCH', d, True) in ['mips', 'mipsel', 'mips64', 'mips64el']]}"
26
27QA_LOGFILE = "${TMPDIR}/qa.log"
28
29IMAGE_ROOTFS_SIZE_ext2 ?= "131072"
30
31#IPK_FEED_URIS += " \
32# upgrades##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/ \
33#upgrades-${MACHINE}##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/${MACHINE} \
34# machine##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/machine/${MACHINE} \
35# base##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/base/ \
36# libs##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/libs/ \
37# console##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/console \
38# devel##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/devel"
39
40#RPM_FEED_URIS += " \
41# upgrades##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/ \
42#upgrades-${MACHINE}##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/upgrades/${MACHINE} \
43# machine##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/machine/${MACHINE} \
44# base##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/base/ \
45# libs##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/libs/ \
46# console##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/console \
47# devel##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/devel"
48
49OEINCLUDELOGS = "yes"
50KERNEL_CONSOLE = "ttyS0"
51#DEBUG_OPTIMIZATION = "-O -g3"
52#DEBUG_BUILD = "1"
53#INHIBIT_PACKAGE_STRIP = "1"
54
55# Default to TARGETOS values for EABI on arm
56GLIBCTARGETOS = "linux${@['','-gnueabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'armeb']]}"
57UCLIBCTARGETOS = "linux${@['-uclibc','-uclibcgnueabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'armeb']]}"
58
59POKYMODE ?= "default"
60require conf/distro/include/poky-${POKYMODE}.inc
61
62POKYLIBC ?= "eglibc"
63require conf/distro/include/poky-${POKYLIBC}.inc
64
65SDK_NAME = "${DISTRO}-${POKYLIBC}-${SDK_ARCH}-${TARGET_ARCH}"
66SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"
67
68CACHE = "${TMPDIR}/cache/${POKYMODE}-${POKYLIBC}${@['', '/' + str(bb.data.getVar('MACHINE', d, 1))][bool(bb.data.getVar('MACHINE', d, 1))]}${@['', '/' + str(bb.data.getVar('SDKMACHINE', d, 1))][bool(bb.data.getVar('SDKMACHINE', d, 1))]}"
69
70#
71# Preferred providers:
72#
73
74# Virtuals:
75PREFERRED_PROVIDER_virtual/db ?= "db"
76PREFERRED_PROVIDER_virtual/db-native ?= "db-native"
77PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86"
78PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
79PREFERRED_PROVIDER_virtual/libgl ?= "mesa-xlib"
80PREFERRED_PROVIDER_virtual/update-alternatives ?= "update-alternatives-cworth"
81PREFERRED_PROVIDER_virtual/update-alternatives-native ?= "opkg-native"
82PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
83PREFERRED_PROVIDER_xf86-video-intel ?= "xf86-video-intel"
84
85VIRTUAL-RUNTIME_update-alternatives ?= "update-alternatives-cworth"
86
87# Others:
88PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers"
89PREFERRED_PROVIDER_linux-libc-headers-nativesdk ?= "linux-libc-headers-nativesdk"
90PREFERRED_PROVIDER_libgcc ?= "libgcc"
91PREFERRED_PROVIDER_libgcc-nativesdk ?= "libgcc-nativesdk"
92PREFERRED_PROVIDER_dbus-glib ?= "dbus-glib"
93PREFERRED_PROVIDER_dbus-glib-native ?= "dbus-glib-native"
94PREFERRED_PROVIDER_gconf ?= "gconf-dbus"
95PREFERRED_PROVIDER_matchbox-panel ?= "matchbox-panel-2"
96PREFERRED_PROVIDER_opkg ?= "opkg"
97PREFERRED_PROVIDER_opkg-native ?= "opkg-native"
98PREFERRED_PROVIDER_opkg-nativesdk ?= "opkg-nativesdk"
99
100PREFERRED_PROVIDER_gdk-pixbuf ?= "gdk-pixbuf"
101
102require conf/distro/include/poky-fixed-revisions.inc
103require conf/distro/include/preferred-xorg-versions.inc
104
105PCMCIA_MANAGER ?= "pcmciautils"
106
107#IMAGE_LINGUAS ?= "en-gb en-us"
108#LIMIT_BUILT_LOCALES ?= "en_GB en_US"
109IMAGE_LINGUAS ?= "en-us en-gb"
110LIMIT_BUILT_LOCALES ?= "POSIX en_US en_GB"
111ENABLE_BINARY_LOCALE_GENERATION ?= "1"
112LOCALE_UTF8_ONLY = "0"
113
114DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci"
115
116POKY_EXTRA_RDEPENDS = "task-poky-boot"
117POKY_EXTRA_RDEPENDS_qemuarm = "qemu-config"
118POKY_EXTRA_RDEPENDS_qemuarmv6 = "qemu-config"
119POKY_EXTRA_RDEPENDS_qemuarmv7 = "qemu-config"
120POKY_EXTRA_RDEPENDS_qemux86 = "qemu-config"
121POKY_EXTRA_RDEPENDS_qemux86-64 = "qemu-config"
122
123DISTRO_EXTRA_RDEPENDS += "${POKY_EXTRA_RDEPENDS}"
124DISTRO_EXTRA_RRECOMMENDS += "kernel-module-af-packet"
125
126IMAGE_FEATURES ?= ""
127
128EXTRAOPKGCONFIG = "poky-feed-config-opkg"
129
130# This is a list of packages that are used by poky to build the distribution, they are not
131# directly part of the distribution.
132HOSTTOOLS_WHITELIST_GPLv3 ?= ""
133WHITELIST_GPLv3 ?= "less gnome-common"
134LGPLv2_WHITELIST_GPLv3 ?= "libassuan gnutls libtasn1 libidn"
135
136# This is a list of packages that require a commercial license to ship
137# product. If shipped as part of an image these packages may have
138# implications so they are disabled by default
139COMMERCIAL_LICENSE ?= "lame gst-fluendo-mp3 libmad mpeg2dec ffmpeg qmmp"
140COMMERCIAL_AUDIO_PLUGINS ?= ""
141# COMMERCIAL_AUDIO_PLUGINS ?= "gst-plugins-ugly-mad gst-plugins-ugly-mpegaudioparse"
142COMMERCIAL_VIDEO_PLUGINS ?= ""
143# COMMERCIAL_VIDEO_PLUGINS ?= "gst-plugins-ugly-mpeg2dec gst-plugins-ugly-mpegstream gst-plugins-bad-mpegvideoparse"
144COMMERCIAL_QT ?= ""
145# COMMERCIAL_QT ?= "qmmp"
146# Set of common licenses used for license.bbclass
147COMMON_LICENSE_DIR ??= "${POKYBASE}/meta/files/common-licenses"
148
149BB_GENERATE_MIRROR_TARBALLS ??= "0"
150
151require conf/distro/include/world-broken.inc
152
153PREMIRRORS ?= "\
154bzr://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
155cvs://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
156git://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
157hg://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
158osc://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
159p4://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
160svk://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
161svn://.*/.* http://autobuilder.yoctoproject.org/sources/ \n"
162
163MIRRORS =+ "\
164ftp://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
165http://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
166https://.*/.* http://autobuilder.yoctoproject.org/sources/ \n"
167
diff --git a/meta-yocto/conf/local.conf.sample b/meta-yocto/conf/local.conf.sample
new file mode 100644
index 0000000000..434c6841bf
--- /dev/null
+++ b/meta-yocto/conf/local.conf.sample
@@ -0,0 +1,219 @@
1# CONF_VERSION is increased each time build/conf/ changes incompatibly
2CONF_VERSION = "1"
3
4# Uncomment and change to cache the files Poky downloads in an alternative
5# location, default it ${TOPDIR}/downloads
6#DL_DIR ?= "${TOPDIR}/downloads"
7# Uncomment and change to cache Poky's built staging output in an alternative
8# location, default ${TOPDIR}/sstate-cache
9#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
10
11# Uncomment and set to allow bitbake to execute multiple tasks at once.
12# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
13# be appropriate.
14# BB_NUMBER_THREADS = "4"
15# Also, make can be passed flags so it run parallel threads e.g.:
16# PARALLEL_MAKE = "-j 4"
17
18# Set a default machine to target unless a machine is selected from the
19# lists below.
20MACHINE ??= "qemux86"
21
22# Supported emulation machines
23#MACHINE ?= "qemuarm"
24#MACHINE ?= "qemumips"
25#MACHINE ?= "qemuppc"
26#MACHINE ?= "qemux86"
27#MACHINE ?= "qemux86-64"
28
29# Supported target hardware for demonstration purposes
30#MACHINE ?= "atom-pc"
31#MACHINE ?= "beagleboard"
32#MACHINE ?= "emenlow"
33#MACHINE ?= "mpc8315e-rdb"
34#MACHINE ?= "routerstationpro"
35
36DISTRO ?= "poky"
37# For bleeding edge / experimental / unstable package versions
38# DISTRO ?= "poky-bleeding"
39
40BBMASK = ""
41
42# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
43# (Some of these are automatically added to certain image types)
44# "dbg-pkgs" - add -dbg packages for all installed packages
45# (adds symbol information for debugging/profiling)
46# "dev-pkgs" - add -dev packages for all installed packages
47# (useful if you want to develop against libs in the image)
48# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
49# "tools-debug" - add debugging tools (gdb, strace)
50# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
51# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
52# "debug-tweaks" - make an image for suitable of development
53# e.g. ssh root access has a blank password
54# There are other application targets too, see meta/classes/poky-image.bbclass
55# and meta/packages/tasks/task-poky.bb for more details.
56
57EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
58
59# The default IMAGE_FEATURES above are too large for the mx31phy and
60# c700/c750 machines which have limited space. The code below limits
61# the default features for those machines.
62EXTRA_IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
63EXTRA_IMAGE_FEATURES_mx31phy = "debug-tweaks"
64EXTRA_IMAGE_FEATURES_mx31ads = "tools-testapps debug-tweaks"
65
66# A list of packaging systems used in generated images
67# The first package type listed will be used for rootfs generation
68# include 'package_deb' for debs
69# include 'package_ipk' for ipks
70# include 'package_rpm' for rpms
71#PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
72PACKAGE_CLASSES ?= "package_rpm package_ipk"
73
74# mklibs library size optimization is more useful to smaller images,
75# and less useful for bigger images. Also mklibs library optimization can break the ABI compatibility, so should not be applied to the images which are tobe
76# extended or upgraded later.
77#This enabled mklibs library size optimization just for the specified image.
78#MKLIBS_OPTIMIZED_IMAGES ?= "poky-image-minimal"
79#This enable mklibs library size optimization will be for all the images.
80#MKLIBS_OPTIMIZED_IMAGES ?= "all"
81
82# A list of additional classes to use when building the system
83# include 'image-mklibs' to reduce shared library files size for an image
84# include 'image-prelink' in order to prelink the filesystem image
85# include 'image-swab' to perform host system intrusion detection
86# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
87USER_CLASSES ?= "image-mklibs image-prelink"
88
89# POKYMODE controls the characteristics of the generated packages/images by
90# telling poky which type of toolchain to use.
91#
92# Options include several different EABI combinations and a compatibility
93# mode for the OABI mode poky previously used.
94#
95# The default is "eabi"
96# Use "oabi" for machines with kernels < 2.6.18 on ARM for example.
97# Use "external-MODE" to use the precompiled external toolchains where MODE
98# is the type of external toolchain to use e.g. eabi.
99# POKYMODE = "external-eabi"
100
101# Uncomment this to specify where BitBake should create its temporary files.
102# Note that a full build of everything in OpenEmbedded will take GigaBytes of hard
103# disk space, so make sure to free enough space. The default TMPDIR is
104# <build directory>/tmp
105#TMPDIR = "${POKYBASE}/build/tmp"
106
107# The following are used to control options related to debugging.
108#
109# Uncomment this to change the optimization to make debugging easer, at the
110# possible cost of performance.
111# DEBUG_BUILD = "1"
112#
113# Uncomment this to disable the stripping of the installed binaries
114# INHIBIT_PACKAGE_STRIP = "1"
115#
116# Uncomment this to disable the split of the debug information into -dbg files
117# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
118#
119# When splitting debug information, the following controls the results of the
120# file splitting.
121#
122# .debug (default):
123# When splitting the debug information will be placed into
124# a .debug directory in the same dirname of the binary produced:
125# /bin/foo -> /bin/.debug/foo
126#
127# debug-file-directory:
128# When splitting the debug information will be placed into
129# a central debug-file-directory, /usr/lib/debug:
130# /bin/foo -> /usr/lib/debug/bin/foo.debug
131#
132# Any source code referenced in the debug symbols will be copied
133# and made available within the /usr/src/debug directory
134#
135PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
136# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
137
138# Uncomment these to build a package such that you can use gprof to profile it.
139# NOTE: This will only work with 'linux' targets, not
140# 'linux-uclibc', as uClibc doesn't provide the necessary
141# object files. Also, don't build glibc itself with these
142# flags, or it'll fail to build.
143#
144# PROFILE_OPTIMIZATION = "-pg"
145# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
146# LDFLAGS =+ "-pg"
147
148# Uncomment this if you want BitBake to emit debugging output
149# BBDEBUG = "yes"
150# Uncomment this if you want BitBake to emit the log if a build fails.
151BBINCLUDELOGS = "yes"
152
153# Set this if you wish to make pkgconfig libraries from your system available
154# for native builds. Combined with extra ASSUME_PROVIDEDs this can allow
155# native builds of applications like oprofileui-native (unsupported feature).
156#EXTRA_NATIVE_PKGCONFIG_PATH = ":/usr/lib/pkgconfig"
157#ASSUME_PROVIDED += "gtk+-native libglade-native"
158
159ENABLE_BINARY_LOCALE_GENERATION = "1"
160
161# The architecture to build SDK items for, by setting this you can build SDK
162# packages for architectures other than the host i.e. building i686 packages
163# on an x86_64 host.
164# Supported values are i686 and x86_64
165#SDKMACHINE ?= "i686"
166
167# Poky can try and fetch packaged-staging packages from a http, https or ftp
168# mirror. Set this variable to the root of a pstage directory on a server.
169#SSTATE_MIRRORS ?= "\
170#file://.* http://someserver.tld/share/sstate/ \n \
171#file://.* file:///some/local/dir/sstate/"
172
173# Set IMAGETEST to qemu if you want to build testcases and start
174# testing in qemu after do_rootfs.
175#IMAGETEST = "qemu"
176
177# By default test cases in sanity suite will be ran. If you want to run other
178# test suite or specific test case(e.g. bat or boot test case under sanity suite),
179# list them like following.
180#TEST_SCEN = "sanity bat sanity:boot"
181
182#Because of the QEMU booting slowness issue(see bug #646 and #618), autobuilder
183#may suffer a timeout issue when running sanity test. We introduce variable
184#TEST_SERIALIZE here to reduce the time on sanity test. It is by default set
185#to 1. Poky will start image and run cases in the same image without reboot
186#or kill. If it is set to 0, the image will be copied and tested for each
187#case, which will take much time.
188#TEST_SERIALIZE = "1"
189
190# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
191# wish to perform the time-consuming step of generating all LIBC locales.
192# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
193# appropriate values for IMAGE_LINGUAS and LIMIT_BUILT_LOCALES
194# WARNING: this may break localisation!
195#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
196# See message above as to whether setting these is required
197#IMAGE_LINGUAS ?= "en-gb"
198#LIMIT_BUILT_LOCALES ?= "POSIX en_GB"
199
200# This value is currently used by PSEUDO to determine if the recipe should
201# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
202#
203# PSEUDO will attempt to determine if a 32-bit wrapper is necessary, but
204# it doesn't always guess properly. If you have 32-bit executables on
205# your 64-bit build system, you likely want to set this to "0",
206# otherwise you could end up with incorrect file attributes on the
207# target filesystem.
208#
209# Default to not build 32 bit libs on 64 bit systems, comment this
210# out if that is desired
211NO32LIBS = "1"
212
213# If you do not use (or have installed) gnome-terminal you will need to
214# uncomment these variables and set them to the terminal you wish to use
215# when resolving patches which cannot be applied
216# Supported shell prefixes for *_TERMCMD and *_TERMCMDRUN ARE:
217# GNOME, SCREEN, XTERM and KONSOLE
218#TERMCMD = "${KONSOLE_TERMCMD}"
219#TERMCMDRUN = "${KONSOLE_TERMCMDRUN}"
diff --git a/meta-yocto/conf/machine/atom-pc.conf b/meta-yocto/conf/machine/atom-pc.conf
new file mode 100644
index 0000000000..b94deb20e5
--- /dev/null
+++ b/meta-yocto/conf/machine/atom-pc.conf
@@ -0,0 +1,46 @@
1#@TYPE: Machine
2#@NAME: Atom-PC
3
4#@DESCRIPTION: Machine configuration for Intel Atom based PCs. Currently supported machines are the Asus eee901, Acer Aspire One, Toshiba NB305, and Intel BlackSand development board.
5
6TARGET_ARCH = "i586"
7
8include conf/machine/include/tune-atom.inc
9
10MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 wifi \
11 acpi"
12
13KERNEL_IMAGETYPE = "bzImage"
14
15PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-stable"
16#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
17PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
18PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
19PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
20PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
21XSERVER ?= "xserver-xf86-dri-lite \
22 xf86-input-mouse \
23 xf86-input-keyboard \
24 xf86-input-evdev \
25 xf86-input-synaptics \
26 xf86-video-intel \
27 mesa-dri-driver-i915"
28
29#MACHINE_EXTRA_RDEPENDS = "rt2860"
30
31MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
32
33GUI_MACHINE_CLASS = "bigscreen"
34
35IMAGE_ROOTFS_SIZE_ext3 = "500000"
36
37IMAGE_FSTYPES ?= "ext3 cpio.gz"
38
39APPEND += "usbcore.autosuspend=1"
40
41GLIBC_ADDONS = "nptl"
42GLIBC_EXTRA_OECONF = "--with-tls"
43
44EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
45
46ROOTLESS_X = "1"
diff --git a/meta-yocto/conf/machine/beagleboard.conf b/meta-yocto/conf/machine/beagleboard.conf
new file mode 100644
index 0000000000..b1f73504bf
--- /dev/null
+++ b/meta-yocto/conf/machine/beagleboard.conf
@@ -0,0 +1,37 @@
1#@TYPE: Machine
2#@NAME: Beagleboard machine
3#@DESCRIPTION: Machine configuration for the http://beagleboard.org/ board
4TARGET_ARCH = "arm"
5
6PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
7XSERVER = "xserver-kdrive-fbdev"
8
9# Only has DVI connector for external screen
10GUI_MACHINE_CLASS = "bigscreen"
11
12#Ship all kernel modules till the board support has matured enough
13MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
14
15# Allow for MMC booting (required by the NAND-less Beagleboard XM)
16EXTRA_IMAGEDEPENDS += "u-boot x-load"
17
18#include conf/machine/include/tune-arm1136jf-s.inc
19include conf/machine/include/tune-cortexa8.inc
20
21IMAGE_FSTYPES += "tar.bz2 jffs2"
22EXTRA_IMAGECMD_jffs2 = "-lnp "
23
24# Guesswork
25SERIAL_CONSOLE = "115200 ttyO2"
26
27PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
28#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
29
30KERNEL_IMAGETYPE = "uImage"
31
32UBOOT_ENTRYPOINT = "0x80008000"
33UBOOT_LOADADDRESS = "0x80008000"
34
35
36# and sdio
37MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat alsa"
diff --git a/meta-yocto/conf/machine/mpc8315e-rdb.conf b/meta-yocto/conf/machine/mpc8315e-rdb.conf
new file mode 100644
index 0000000000..34b75bbc8a
--- /dev/null
+++ b/meta-yocto/conf/machine/mpc8315e-rdb.conf
@@ -0,0 +1,20 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4TARGET_ARCH = "powerpc"
5TARGET_FPU = "spe"
6
7require conf/machine/include/tune-ppc603e.inc
8
9KERNEL_IMAGETYPE = "uImage"
10
11SERIAL_CONSOLE = "115200 ttyS0"
12
13MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
14
15PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
16#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
17
18UBOOT_ENTRYPOINT = "0x00000000"
19
20KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/mpc8315erdb.dts"
diff --git a/meta-yocto/conf/machine/routerstationpro.conf b/meta-yocto/conf/machine/routerstationpro.conf
new file mode 100644
index 0000000000..d464842134
--- /dev/null
+++ b/meta-yocto/conf/machine/routerstationpro.conf
@@ -0,0 +1,24 @@
1#@TYPE: Machine
2#@NAME: mti_malta32_be MIPS
3#@DESCRIPTION: mti_malta32_be
4
5TARGET_ARCH = "mips"
6
7require conf/machine/include/tune-mips32.inc
8
9MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 \
10 serial usbgadget"
11
12KERNEL_IMAGETYPE = "vmlinux"
13KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
14
15PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
16#PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
17
18SERIAL_CONSOLE = "115200 ttyS0"
19
20MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
21
22IMAGE_ROOTFS_SIZE_ext3 = "2000000"
23IMAGE_FSTYPES ?= "jffs2 tar.bz2"
24
diff --git a/meta-yocto/conf/site.conf.sample b/meta-yocto/conf/site.conf.sample
new file mode 100644
index 0000000000..42042042f7
--- /dev/null
+++ b/meta-yocto/conf/site.conf.sample
@@ -0,0 +1,40 @@
1#
2# local.conf covers user settings, site.conf covers site specific information
3# such as proxy server addresses and optionally any shared download location
4#
5# SITE_CONF_VERSION is increased each time build/conf/site.conf
6# changes incompatibly
7SCONF_VERSION = "1"
8
9# Uncomment to cause CVS to use the proxy host specified
10#CVS_PROXY_HOST = "proxy.example.com"
11#CVS_PROXY_PORT = "81"
12
13# For svn, you need to create ~/.subversion/servers containing:
14#[global]
15#http-proxy-host = proxy.example.com
16#http-proxy-port = 81
17#
18
19# Uncomment to cause git to use the proxy host specificed
20# although this only works for http
21#GIT_PROXY_HOST = "proxy.example.com"
22#GIT_PROXY_PORT = "81"
23#export GIT_PROXY_COMMAND = "${POKYBASE}/scripts/poky-git-proxy-command"
24
25# GIT_PROXY_IGNORE_* lines define hosts which do not require a proxy to access
26#GIT_CORE_CONFIG = "Yes"
27#GIT_PROXY_IGNORE_1 = "host.server.com"
28#GIT_PROXY_IGNORE_2 = "another.server.com"
29
30# If SOCKS is available run the following command to comple a simple transport
31# gcc scripts/poky-git-proxy-socks.c -o poky-git-proxy-socks
32# and then share that binary somewhere in PATH, then use the following settings
33#GIT_PROXY_HOST = "proxy.example.com"
34#GIT_PROXY_PORT = "81"
35#export GIT_PROXY_COMMAND = "${POKYBASE}/scripts/poky-git-proxy-socks-command"
36
37
38# Uncomment this to use a shared download directory
39#DL_DIR = "/some/shared/download/directory/"
40