summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-08-26 14:18:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-02 05:52:13 -0700
commite14a30b3c32be5072ff1adb0fcf1e8f185f90cbe (patch)
tree0fe8f1bf01da1b16c040ce8d80d29e5c958f68a4 /meta-yocto
parent17b97774c2069015f6eec6736cace3271ab6b82a (diff)
downloadpoky-e14a30b3c32be5072ff1adb0fcf1e8f185f90cbe.tar.gz
local.conf.sample.extended: update the sample for archiver.bbclass
Update archiver.bbclass' sample, make it easier to understand. [YOCTO #2619] (From meta-yocto rev: 7a4b496ed5247398b04dc2b81d2f691e3aadd573) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/conf/local.conf.sample.extended50
1 files changed, 27 insertions, 23 deletions
diff --git a/meta-yocto/conf/local.conf.sample.extended b/meta-yocto/conf/local.conf.sample.extended
index 36f1294dea..de4691194a 100644
--- a/meta-yocto/conf/local.conf.sample.extended
+++ b/meta-yocto/conf/local.conf.sample.extended
@@ -182,32 +182,36 @@
182# when the disk space reduces 50M (or the amount of inode reduces 5k). 182# when the disk space reduces 50M (or the amount of inode reduces 5k).
183#BB_DISKMON_WARNINTERVAL = "50M,5K" 183#BB_DISKMON_WARNINTERVAL = "50M,5K"
184 184
185# Archiving source code configuration 185# Archiving source code, configure what kind of sources will be archived
186# 186# and the output format. The output files will be put in
187# The following variables control which files to archive and the type to archive to generate. 187# ${DEPLOY_DIR}/sources/.
188# There are three basic class defintions of common operations that might be desired and these 188#
189# can be enabled by uncommenting one of the following lines: 189# You can add the following 3 lines to the conf file to get a quick
190# 190# usage:
191# INHERIT += "archive-original-source" 191#ARCHIVER_MODE ?= "original"
192# INHERIT += "archive-patched-source" 192#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
193#INHERIT =+ "archive-configured-source" 193#INHERIT += "${ARCHIVER_CLASS}"
194# 194#
195# Type of archive: 195# Detailed configuration:
196# SOURCE_ARCHIVE_PACKAGE_TYPE = 'srpm' 196# What kind of sources will be archived, the ARCHIVER_MODE could be:
197#SOURCE_ARCHIVE_PACKAGE_TYPE ?= 'tar' 197# original: the ${S} after do_unpack
198# 198# patched : the ${S} after do_patch
199# Whether to include WORKDIR/temp, .bb and .inc files: 199# configured: the ${S} after do_configure
200# 'logs_with_scripts' include WORKDIR/temp directory and .bb and .inc files
201# 'logs' only include WORKDIR/temp
202# ARCHIVER_MODE[log_type] = "logs logs_with_scripts"
203# There are three basic class defintions of common operations
204# that might be desired and these can be enabled by
205# uncommenting five of the following lines:
206# ARCHIVER_MODE[filter] ?= "yes no"
207# Filter packages according to license
208#ARCHIVER_MODE ?= "original" 200#ARCHIVER_MODE ?= "original"
201#
202# The output format type, tar or srpm, the default is "tar".
209#ARCHIVER_MODE[type] ?= "tar" 203#ARCHIVER_MODE[type] ?= "tar"
204#
205# Whether include the log file under ${T} and the recipe (.bb and .inc),
206# the default is "logs_with_scripts".
210#ARCHIVER_MODE[log_type] ?= "logs_with_scripts" 207#ARCHIVER_MODE[log_type] ?= "logs_with_scripts"
208#
209# license filter:
210# yes: Only the COPYLEFT_LICENSE_INCLUDE recipe will be archived
211# no: All kinds lof license will be archived
212# The default is "no"
211#ARCHIVER_MODE[filter] ?= "no" 213#ARCHIVER_MODE[filter] ?= "no"
214#
215# Put the following two lines in the conf file with intact.
212#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}" 216#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
213#INHERIT += "${ARCHIVER_CLASS}" 217#INHERIT += "${ARCHIVER_CLASS}"