summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-12 23:17:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-12 23:18:39 +0000
commitba8506ee342a1a579ceb309f3f50285eaad84f25 (patch)
tree18c996cbd656cc9ca14acecbd4df9ca04cf740f4 /meta-yocto
parent2b38832f976cbd169d5ac6e2a5fd3ab38d614fc7 (diff)
downloadpoky-ba8506ee342a1a579ceb309f3f50285eaad84f25.tar.gz
local.conf.extended: Bring into sync with OE-Core
(From meta-yocto rev: 8a3bcfa1204811c5a26d5485e0b2ef3b389e74ec) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/conf/local.conf.sample.extended68
1 files changed, 37 insertions, 31 deletions
diff --git a/meta-yocto/conf/local.conf.sample.extended b/meta-yocto/conf/local.conf.sample.extended
index 628f14dbb0..9585432bc6 100644
--- a/meta-yocto/conf/local.conf.sample.extended
+++ b/meta-yocto/conf/local.conf.sample.extended
@@ -15,7 +15,7 @@
15 15
16#DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci ${DISTRO_FEATURES_LIBC}" 16#DISTRO_FEATURES = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost wifi nfs zeroconf pci ${DISTRO_FEATURES_LIBC}"
17 17
18# If you want to get an image based on directfb without x11, Please copy this variable to build/conf/local.conf 18# If you want to get an image based on gtk+directfb without x11, Please copy this variable to build/conf/local.conf
19#DISTRO_FEATURES = "alsa argp bluetooth ext2 irda largefile pcmcia usbgadget usbhost wifi xattr nfs zeroconf pci 3g directfb ${DISTRO_FEATURES_LIBC}" 19#DISTRO_FEATURES = "alsa argp bluetooth ext2 irda largefile pcmcia usbgadget usbhost wifi xattr nfs zeroconf pci 3g directfb ${DISTRO_FEATURES_LIBC}"
20 20
21# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale 21# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale
@@ -78,11 +78,21 @@
78# TCMODE controls the characteristics of the generated packages/images by 78# TCMODE controls the characteristics of the generated packages/images by
79# telling poky which toolchain 'profile' to use. 79# telling poky which toolchain 'profile' to use.
80# 80#
81# The default is "default" 81# The default is "default" which uses the internal toolchain. With
82# Use "external-MODE" to use the precompiled external toolchains where MODE 82# additional layers, it is possible to set this to use a precompiled
83# is the type of external toolchain to use e.g. eabi. You need to ensure 83# external toolchain. One example is the Sourcery G++ Toolchain, support
84# the toolchain you want to use is included in an appropriate layer 84# for which is now in the separate meta-sourcery layer:
85# TCMODE ?= "external-eabi" 85#
86# http://github.com/MentorEmbedded/meta-sourcery/
87#
88# meta-sourcery can be used as a template for adding support for other
89# external toolchains. See the link above for further details.
90#
91# TCMODE points the system to a file in conf/distro/include/tcmode-${TCMODE}.inc,
92# so for meta-sourcery which has conf/distro/include/tcmode-external-sourcery.inc
93# you would set it as follows:
94#
95# TCMODE ?= "external-sourcery"
86 96
87# mklibs library size optimization is more useful to smaller images, 97# mklibs library size optimization is more useful to smaller images,
88# and less useful for bigger images. Also mklibs library optimization 98# and less useful for bigger images. Also mklibs library optimization
@@ -178,37 +188,33 @@
178# when the disk space reduces 50M (or the amount of inode reduces 5k). 188# when the disk space reduces 50M (or the amount of inode reduces 5k).
179#BB_DISKMON_WARNINTERVAL = "50M,5K" 189#BB_DISKMON_WARNINTERVAL = "50M,5K"
180 190
181# Archiving source code, configure what kind of sources will be archived 191# Archiving source code configuration
182# and the output format. The output files will be put in
183# ${DEPLOY_DIR}/sources/.
184# 192#
185# You can add the following 3 lines to the conf file to get a quick 193# The following variables control which files to archive and the type to archive to generate.
186# usage: 194# There are three basic class defintions of common operations that might be desired and these
187#ARCHIVER_MODE ?= "original" 195# can be enabled by uncommenting one of the following lines:
188#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
189#INHERIT += "${ARCHIVER_CLASS}"
190# 196#
191# Detailed configuration: 197# INHERIT += "archive-original-source"
192# What kind of sources will be archived, the ARCHIVER_MODE could be: 198# INHERIT += "archive-patched-source"
193# original: the ${S} after do_unpack 199#INHERIT =+ "archive-configured-source"
194# patched : the ${S} after do_patch
195# configured: the ${S} after do_configure
196#ARCHIVER_MODE ?= "original"
197# 200#
198# The output format type, tar or srpm, the default is "tar". 201# Type of archive:
199#ARCHIVER_MODE[type] ?= "tar" 202# SOURCE_ARCHIVE_PACKAGE_TYPE = 'srpm'
203#SOURCE_ARCHIVE_PACKAGE_TYPE ?= 'tar'
200# 204#
201# Whether include the log file under ${T} and the recipe (.bb and .inc), 205# Whether to include WORKDIR/temp, .bb and .inc files:
202# the default is "logs_with_scripts". 206# 'logs_with_scripts' include WORKDIR/temp directory and .bb and .inc files
207# 'logs' only include WORKDIR/temp
208# ARCHIVER_MODE[log_type] = "logs logs_with_scripts"
209# There are three basic class defintions of common operations
210# that might be desired and these can be enabled by
211# uncommenting five of the following lines:
212# ARCHIVER_MODE[filter] ?= "yes no"
213# Filter packages according to license
214#ARCHIVER_MODE ?= "original"
215#ARCHIVER_MODE[type] ?= "tar"
203#ARCHIVER_MODE[log_type] ?= "logs_with_scripts" 216#ARCHIVER_MODE[log_type] ?= "logs_with_scripts"
204#
205# license filter:
206# yes: Only the COPYLEFT_LICENSE_INCLUDE recipe will be archived
207# no: All kinds lof license will be archived
208# The default is "no"
209#ARCHIVER_MODE[filter] ?= "no" 217#ARCHIVER_MODE[filter] ?= "no"
210#
211# Put the following two lines in the conf file with intact.
212#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}" 218#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
213#INHERIT += "${ARCHIVER_CLASS}" 219#INHERIT += "${ARCHIVER_CLASS}"
214 220