summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-07-11 10:49:50 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-11 17:36:08 +0100
commit8514aa99e812f5f231c4d550a4716b17403d6c70 (patch)
treee90a9b427f812d98b3233d5d97ac8dabde2eb91d /meta-yocto
parentb1a606112b2d88d62f2aff1e1be4912b6755f11c (diff)
downloadpoky-8514aa99e812f5f231c4d550a4716b17403d6c70.tar.gz
linux-yocto-3.0/meta-yocto: perf script fixes
Updating the yocto reference boards to have the perf scripting fixes from 3.2/3.4: cef17a1 perf: add sgidefs.h to for mips builds 3258da3 perf: change --root to --prefix for python install 1f9c25b perf: add 'libperl not found' warning f2b1bf1 perf: use pkg-config instead of python-config 568e05f perf tools: Add support to install perf python extension 7e47f81 Revert "perf: hard-code NO_LIBPERL/NO_LIBPYTHON" (From meta-yocto rev: a3dedc83578b1b9d6010bc1c78e69cdfe387b902) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend6
-rw-r--r--meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend1
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
index fdd9f7df63..274eb822ce 100644
--- a/meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
+++ b/meta-yocto/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -4,13 +4,13 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4COMPATIBLE_MACHINE_atom-pc = "atom-pc" 4COMPATIBLE_MACHINE_atom-pc = "atom-pc"
5KMACHINE_atom-pc = "atom-pc" 5KMACHINE_atom-pc = "atom-pc"
6KBRANCH_atom-pc = "yocto/standard/preempt-rt/base" 6KBRANCH_atom-pc = "yocto/standard/preempt-rt/base"
7SRCREV_machine_pn-linux-yocto-rt_atom-pc = "e67428d9966eecec4c081993dc64ceb5c0e64643" 7SRCREV_machine_pn-linux-yocto-rt_atom-pc = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
8 8
9# mpc8315e-rdb support 9# mpc8315e-rdb support
10COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 10COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
11KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb" 11KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
12KBRANCH_mpc8315e-rdb = "yocto/standard/preempt-rt/base" 12KBRANCH_mpc8315e-rdb = "yocto/standard/preempt-rt/base"
13SRCREV_machine_pn-linux-yocto-rt_mpc8315e-rdb = "e67428d9966eecec4c081993dc64ceb5c0e64643" 13SRCREV_machine_pn-linux-yocto-rt_mpc8315e-rdb = "bbd5bfe49403fdcca294ca4b163d5f7195ea3a8e"
14 14
15# beagleboard support - 3.0 support has not yet been completed, build failure 15# beagleboard support - 3.0 support has not yet been completed, build failure
16#COMPATIBLE_MACHINE_beagleboard = "beagleboard" 16#COMPATIBLE_MACHINE_beagleboard = "beagleboard"
@@ -22,4 +22,4 @@ SRCREV_machine_pn-linux-yocto-rt_mpc8315e-rdb = "e67428d9966eecec4c081993dc64ceb
22COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 22COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
23KMACHINE_routerstationpro = "routerstationpro" 23KMACHINE_routerstationpro = "routerstationpro"
24KBRANCH_routerstationpro = "yocto/standard/preempt-rt/routerstationpro" 24KBRANCH_routerstationpro = "yocto/standard/preempt-rt/routerstationpro"
25SRCREV_machine_pn-linux-yocto-rt_routerstationpro = "94b9545c58bf4dee8321b800b90958d10875fda8" 25SRCREV_machine_pn-linux-yocto-rt_routerstationpro = "634ba79510753eecd27a39a315f690f1c9d46efe"
diff --git a/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend
index 6de9deff72..fc1a7df766 100644
--- a/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend
+++ b/meta-yocto/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -8,6 +8,7 @@ SRCREV_machine_routerstationpro ?= "af74f58ef6ffdc68cc77d314ad31bd6a322309d3"
8SRCREV_machine_mpc8315e-rdb ?= "0c781e306559d5e9816e202a60aa2543f4eea39e" 8SRCREV_machine_mpc8315e-rdb ?= "0c781e306559d5e9816e202a60aa2543f4eea39e"
9SRCREV_machine_beagleboard ?= "567c989c90ce5f2c62f6ef788be763150b65a0fb" 9SRCREV_machine_beagleboard ?= "567c989c90ce5f2c62f6ef788be763150b65a0fb"
10 10
11
11COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 12COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
12COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 13COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
13COMPATIBLE_MACHINE_beagleboard = "beagleboard" 14COMPATIBLE_MACHINE_beagleboard = "beagleboard"