summaryrefslogtreecommitdiffstats
path: root/meta-yocto
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2012-06-26 06:15:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-28 16:32:58 +0100
commit4d48398798c898c5db08294ba64d9bfc7daca19c (patch)
tree4447e2f190982cf3953da86c12fd488a3ce7c3db /meta-yocto
parent7afc6af42aadc96bcca7653a86c2dde5e9416bb1 (diff)
downloadpoky-4d48398798c898c5db08294ba64d9bfc7daca19c.tar.gz
local.conf.sample.extended: Add filtering function to archiver.bbclass
Add the option to filter packages according to license. [YOCTO #2473] (From meta-yocto rev: 156147991dc1ec7f58ac355b8e0f430958de2831) Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto')
-rw-r--r--meta-yocto/conf/local.conf.sample.extended23
1 files changed, 14 insertions, 9 deletions
diff --git a/meta-yocto/conf/local.conf.sample.extended b/meta-yocto/conf/local.conf.sample.extended
index 66b94ad82b..36f1294dea 100644
--- a/meta-yocto/conf/local.conf.sample.extended
+++ b/meta-yocto/conf/local.conf.sample.extended
@@ -184,16 +184,18 @@
184 184
185# Archiving source code configuration 185# Archiving source code configuration
186# 186#
187# The following variables control which files to archive and 187# The following variables control which files to archive and the type to archive to generate.
188# the type to archive to generate. 188# There are three basic class defintions of common operations that might be desired and these
189# The content to archive 189# can be enabled by uncommenting one of the following lines:
190# "original": Copy source code package from downloads if existing. 190#
191# Archive source code after do_unpack if not found in downloads 191# INHERIT += "archive-original-source"
192# "patched": Archive source code package after do_patch 192# INHERIT += "archive-patched-source"
193# "configured": Archive source code package after do_configure 193#INHERIT =+ "archive-configured-source"
194# ARCHIVER_MODE[choices] = "none original patched configured" 194#
195# Type of archive: 195# Type of archive:
196# ARCHIVER_MODE[type] = "tar srpm" 196# SOURCE_ARCHIVE_PACKAGE_TYPE = 'srpm'
197#SOURCE_ARCHIVE_PACKAGE_TYPE ?= 'tar'
198#
197# Whether to include WORKDIR/temp, .bb and .inc files: 199# Whether to include WORKDIR/temp, .bb and .inc files:
198# 'logs_with_scripts' include WORKDIR/temp directory and .bb and .inc files 200# 'logs_with_scripts' include WORKDIR/temp directory and .bb and .inc files
199# 'logs' only include WORKDIR/temp 201# 'logs' only include WORKDIR/temp
@@ -201,8 +203,11 @@
201# There are three basic class defintions of common operations 203# There are three basic class defintions of common operations
202# that might be desired and these can be enabled by 204# that might be desired and these can be enabled by
203# uncommenting five of the following lines: 205# uncommenting five of the following lines:
206# ARCHIVER_MODE[filter] ?= "yes no"
207# Filter packages according to license
204#ARCHIVER_MODE ?= "original" 208#ARCHIVER_MODE ?= "original"
205#ARCHIVER_MODE[type] ?= "tar" 209#ARCHIVER_MODE[type] ?= "tar"
206#ARCHIVER_MODE[log_type] ?= "logs_with_scripts" 210#ARCHIVER_MODE[log_type] ?= "logs_with_scripts"
211#ARCHIVER_MODE[filter] ?= "no"
207#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}" 212#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
208#INHERIT += "${ARCHIVER_CLASS}" 213#INHERIT += "${ARCHIVER_CLASS}"