diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2011-05-18 12:24:32 -0400 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2011-05-19 17:33:50 -0700 |
commit | 7706d5d844db2725f4118207d90e302679eacdfe (patch) | |
tree | b0ba030d4fcb49f7d5ff1bf3ad37ef72c8354b70 /meta-yocto | |
parent | 624263c82d1dabb55862a6532a2df2b8a4b541dc (diff) | |
download | poky-7706d5d844db2725f4118207d90e302679eacdfe.tar.gz |
linux-yocto/meta-yocto: fix gcc 4.6.0 compilation failures
Fixes gcc 4.6.0 compliation issues by importing the upstream change:
Author: Michal Marek <mmarek@suse.cz>
Date: Mon May 2 12:13:01 2011 +0000
kbuild: Fix passing -Wno-* options to gcc 4.4+
Starting with 4.4, gcc will happily accept -Wno-<anything> in the
cc-option test and complain later when compiling a file that has some
other warning. This rather unexpected behavior is intentional as per
http://gcc.gnu.org/PR28322, so work around it by testing for support of
the opposite option (without the no-). Introduce a new Makefile function
cc-disable-warning that does this and update two uses of cc-option in
the toplevel Makefile.
Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
Signed-off-by: Michal Marek <mmarek@suse.cz>
Tested-by: Stephen Rothwell <sfr@canb.auug.org.au>
Integrated-by: Bruce Ashfield <bruce.ashfield@windriver.com>
:100644 100644 0ef00bd... 1d8e7e9... M Documentation/kbuild/makefiles.txt
:100644 100644 7bd863e0.. 74bac80... M Makefile
:100644 100644 ed2773e... ba25c44... M scripts/Kbuild.include
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-yocto')
-rw-r--r-- | meta-yocto/recipes-kernel/linux/linux-yocto_git.bbappend | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-yocto/recipes-kernel/linux/linux-yocto_git.bbappend b/meta-yocto/recipes-kernel/linux/linux-yocto_git.bbappend index 052831d5a1..e053fe96d3 100644 --- a/meta-yocto/recipes-kernel/linux/linux-yocto_git.bbappend +++ b/meta-yocto/recipes-kernel/linux/linux-yocto_git.bbappend | |||
@@ -3,11 +3,11 @@ KMACHINE_routerstationpro = "yocto/standard/routerstationpro" | |||
3 | KMACHINE_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb" | 3 | KMACHINE_mpc8315e-rdb = "yocto/standard/fsl-mpc8315e-rdb" |
4 | KMACHINE_beagleboard = "yocto/standard/beagleboard" | 4 | KMACHINE_beagleboard = "yocto/standard/beagleboard" |
5 | 5 | ||
6 | SRCREV_machine_emenlow = "c3bbcb676f929c4fc0511a6e66494b8770d015a1" | 6 | SRCREV_machine_emenlow = "5d0d346c0e4b2d837cd98dccbf043f1988e2058a" |
7 | SRCREV_machine_atom-pc = "b906f358fd404a1e74a961f25079274e0d933ee1" | 7 | SRCREV_machine_atom-pc = "79d6188d99bdf63da9a0ba27c010792266e337f9" |
8 | SRCREV_machine_routerstationpro = "95ca94d2e71ca2db6822a37a7f575fa79c3d05d0" | 8 | SRCREV_machine_routerstationpro = "d6aadb767fdcbb9886c430e90b92f49cd3a9ddcc" |
9 | SRCREV_machine_mpc8315e-rdb = "53c800c244e73d81d2832f6da306eeae3b09e5dc" | 9 | SRCREV_machine_mpc8315e-rdb = "e5c67f6a64b8b7393ca3a9c80b3ac197be0a8d5f" |
10 | SRCREV_machine_beagleboard = "b906f358fd404a1e74a961f25079274e0d933ee1" | 10 | SRCREV_machine_beagleboard = "e53debfc6896bb89174ebb74154ed9b3bc72b59c" |
11 | 11 | ||
12 | COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" | 12 | COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" |
13 | COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" | 13 | COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" |