diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2012-06-21 14:07:44 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-06-26 15:34:39 +0100 |
commit | 26e6b0a143ebfb5a5defa1b958f359472fb9108f (patch) | |
tree | 7b2e2635dc5e7095b776a710669bda1a09e44530 /meta-yocto/recipes-kernel/linux-libc-headers | |
parent | 58fcd84206c79878b76870079e1008ff5b74d07d (diff) | |
download | poky-26e6b0a143ebfb5a5defa1b958f359472fb9108f.tar.gz |
linux-libc-headers-yocto: update to v3.4 and remove unecessary code
Updating the linux-libc-headers-yocto recipe to 3.4. There are blocks
of code and definitions that are handled by the included libc-headers.inc,
so we shouldn't be repeating them in this recipe.
(From meta-yocto rev: ad8456e013907c444d972ad945b8d6e96be1d4f0)
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto/recipes-kernel/linux-libc-headers')
-rw-r--r-- | meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb | 32 |
1 files changed, 7 insertions, 25 deletions
diff --git a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb index 831e4522bb..b4222f14bb 100644 --- a/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb +++ b/meta-yocto/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb | |||
@@ -3,18 +3,17 @@ include recipes-kernel/linux/linux-yocto.inc | |||
3 | 3 | ||
4 | B = "${S}" | 4 | B = "${S}" |
5 | 5 | ||
6 | INHIBIT_DEFAULT_DEPS = "1" | ||
7 | DEPENDS += "unifdef-native" | ||
8 | PROVIDES = "linux-libc-headers" | 6 | PROVIDES = "linux-libc-headers" |
9 | RPROVIDES_${PN}-dev = "linux-libc-headers-dev" | 7 | RPROVIDES_${PN}-dev = "linux-libc-headers-dev" |
10 | RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg" | 8 | RPROVIDES_${PN}-dbg = "linux-libc-headers-dbg" |
11 | SRCREV = "21ab5dca134a6bf1316aa59f69f9ee9e091d5702" | ||
12 | KBRANCH ?= "standard/base" | ||
13 | KMETA ?= "meta" | ||
14 | PV = "3.2+git-${SRCPV}" | ||
15 | PR = "r5" | ||
16 | 9 | ||
17 | SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.2;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" | 10 | KBRANCH = "standard/base" |
11 | SRCREV = "a1cdb60720c452c3965eaec3ec2cd10f06261cc5" | ||
12 | |||
13 | PV = "3.4+git-${SRCPV}" | ||
14 | PR = "r6" | ||
15 | |||
16 | SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" | ||
18 | 17 | ||
19 | # force this to empty to prevent installation failures, we aren't | 18 | # force this to empty to prevent installation failures, we aren't |
20 | # building a device tree as part of kern headers | 19 | # building a device tree as part of kern headers |
@@ -22,17 +21,6 @@ KERNEL_DEVICETREE = "" | |||
22 | 21 | ||
23 | inherit kernel-arch | 22 | inherit kernel-arch |
24 | 23 | ||
25 | do_configure() { | ||
26 | oe_runmake allnoconfig | ||
27 | } | ||
28 | |||
29 | do_install() { | ||
30 | oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} | ||
31 | |||
32 | # The ..install.cmd conflicts between various configure runs | ||
33 | find ${D}${includedir} -name ..install.cmd | xargs rm -f | ||
34 | } | ||
35 | |||
36 | # The following tasks are not required when we just want | 24 | # The following tasks are not required when we just want |
37 | # headers. So we override and stub them out. | 25 | # headers. So we override and stub them out. |
38 | do_kernel_configme() { | 26 | do_kernel_configme() { |
@@ -41,12 +29,6 @@ do_kernel_configme() { | |||
41 | do_patch () { | 29 | do_patch () { |
42 | } | 30 | } |
43 | 31 | ||
44 | do_compile () { | ||
45 | } | ||
46 | |||
47 | do_validate_branches () { | ||
48 | } | ||
49 | |||
50 | do_kernel_configcheck () { | 32 | do_kernel_configcheck () { |
51 | } | 33 | } |
52 | 34 | ||