diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2011-06-10 18:43:52 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-06-15 11:49:42 +0100 |
commit | e1f6ebba3ab2fc8a469c1d96fc6d4c4b8f16845c (patch) | |
tree | 5c30e881ad924116def8b61e306c0f4510dc3591 /meta-yocto/recipes-core | |
parent | d96a8c9f25c8356fdf21b96a47007ed8c1b43bcd (diff) | |
download | poky-e1f6ebba3ab2fc8a469c1d96fc6d4c4b8f16845c.tar.gz |
meta-yocto: use FILESEXTRAPATHS_prepend := in all bbappends
Using FILESEXTRAPATHS is cleaner than the old FILESPATH-based method, and
as meta-intel layers are using FILESEXTRAPATHS their formfactor bbappends
will now work. In addition I have used FILESEXTRAPATHS_prepend which is
not absolutely necessary, but provides a good working example in case it
is copied by other layers that are intended to be used on top of it.
Fixes [YOCTO #1156]
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto/recipes-core')
-rw-r--r-- | meta-yocto/recipes-core/netbase/netbase_4.45.bbappend | 4 | ||||
-rw-r--r-- | meta-yocto/recipes-core/uclibc/uclibc_git.bbappend | 4 |
2 files changed, 2 insertions, 6 deletions
diff --git a/meta-yocto/recipes-core/netbase/netbase_4.45.bbappend b/meta-yocto/recipes-core/netbase/netbase_4.45.bbappend index 4b8d0e656b..72d991c7e5 100644 --- a/meta-yocto/recipes-core/netbase/netbase_4.45.bbappend +++ b/meta-yocto/recipes-core/netbase/netbase_4.45.bbappend | |||
@@ -1,3 +1 @@ | |||
1 | THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |
2 | FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:" | ||
3 | |||
diff --git a/meta-yocto/recipes-core/uclibc/uclibc_git.bbappend b/meta-yocto/recipes-core/uclibc/uclibc_git.bbappend index 4b8d0e656b..72d991c7e5 100644 --- a/meta-yocto/recipes-core/uclibc/uclibc_git.bbappend +++ b/meta-yocto/recipes-core/uclibc/uclibc_git.bbappend | |||
@@ -1,3 +1 @@ | |||
1 | THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |
2 | FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:" | ||
3 | |||