diff options
author | Paul Gortmaker <paul.gortmaker@windriver.com> | 2015-01-20 17:03:02 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-01-23 11:31:59 +0000 |
commit | 07bfa681958a852980f151e14becf069287952cd (patch) | |
tree | 0d1612ed22de76e5726f9a67a993dbb4df71f52f /meta-yocto/conf/distro/poky.conf | |
parent | d67593245fa11c7cf433f4897b0d9ecb80c685de (diff) | |
download | poky-07bfa681958a852980f151e14becf069287952cd.tar.gz |
poky.conf: change case of Poky for DISTRO<->SANITY mismatch
Using anything build appliance based will emit the warning:
WARNING: Host distribution "poky-1.7" has not been validated with
this version of the build system; you may possibly experience
unexpected failures. It is recommended that you use a tested distribution.
The chain of events leading to this is:
1) At image creation time:
meta-yocto/conf/distro/poky.conf:
DISTRO = "poky"
meta/recipes-extended/lsb/lsb_4.1.bb:
echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release
2) At deployment/usage time of the created image:
meta/lib/oe/lsb.py:
output, err = bb.process.run(['lsb_release', '-ir'], stderr=PIPE)
meta-yocto/conf/distro/poky.conf:
SANITY_TESTED_DISTROS ?= " \
Poky-1.6 \n \
Poky-1.7 \n \
[...]
meta/classes/sanity.bbclass:
distro = oe.lsb.distro_identifier()
tested_distros = sanity_data.getVar('SANITY_TESTED_DISTROS', True)
and hence the lsb.distro gets the lower case "poky" which fails to
match the upper case "Poky" used in SANITY_TESTED_DISTROS.
(From meta-yocto rev: 3373b04f8a61e5daa5d24501c0c7d8f947afb3f8)
Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto/conf/distro/poky.conf')
-rw-r--r-- | meta-yocto/conf/distro/poky.conf | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-yocto/conf/distro/poky.conf b/meta-yocto/conf/distro/poky.conf index 48a8cf5b77..d3aed52431 100644 --- a/meta-yocto/conf/distro/poky.conf +++ b/meta-yocto/conf/distro/poky.conf | |||
@@ -74,8 +74,8 @@ CONNECTIVITY_CHECK_URIS ?= " \ | |||
74 | http://bugzilla.yoctoproject.org/report.cgi" | 74 | http://bugzilla.yoctoproject.org/report.cgi" |
75 | 75 | ||
76 | SANITY_TESTED_DISTROS ?= " \ | 76 | SANITY_TESTED_DISTROS ?= " \ |
77 | Poky-1.6 \n \ | 77 | poky-1.6 \n \ |
78 | Poky-1.7 \n \ | 78 | poky-1.7 \n \ |
79 | Ubuntu-12.04 \n \ | 79 | Ubuntu-12.04 \n \ |
80 | Ubuntu-14.04 \n \ | 80 | Ubuntu-14.04 \n \ |
81 | Ubuntu-14.10 \n \ | 81 | Ubuntu-14.10 \n \ |