summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2018-03-28 18:12:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-30 00:31:39 +0100
commitafd8490dcbd2755f1ed924ea6357ab922ed1f481 (patch)
treee60eb05b962d08c2359399d4fd894bab4b55e9e4 /meta-yocto-bsp
parent08a58319059478a73ef4785abf4169e108aaaee8 (diff)
downloadpoky-afd8490dcbd2755f1ed924ea6357ab922ed1f481.tar.gz
meta-yocto-bsp: introduce v4.14&v4.15 kernel for non-x86 BSPs
Also set the default kernel of these BSPs to v4.15. (From meta-yocto rev: 4c35cdf84b24104c341b986dd3e04323aca894c4) Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone-yocto.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/edgerouter.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.14.bbappend13
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.15.bbappend13
5 files changed, 29 insertions, 3 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
index 990c967416..8d0f62bf67 100644
--- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
+++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -23,7 +23,7 @@ do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do
23SERIAL_CONSOLE = "115200 ttyO0" 23SERIAL_CONSOLE = "115200 ttyO0"
24 24
25PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 25PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
26PREFERRED_VERSION_linux-yocto ?= "4.12%" 26PREFERRED_VERSION_linux-yocto ?= "4.15%"
27 27
28KERNEL_IMAGETYPE = "zImage" 28KERNEL_IMAGETYPE = "zImage"
29KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb" 29KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb"
diff --git a/meta-yocto-bsp/conf/machine/edgerouter.conf b/meta-yocto-bsp/conf/machine/edgerouter.conf
index ab5a6fc404..acfd69c2bc 100644
--- a/meta-yocto-bsp/conf/machine/edgerouter.conf
+++ b/meta-yocto-bsp/conf/machine/edgerouter.conf
@@ -11,7 +11,7 @@ KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment" 11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment"
12 12
13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
14PREFERRED_VERSION_linux-yocto ?= "4.12%" 14PREFERRED_VERSION_linux-yocto ?= "4.15%"
15 15
16SERIAL_CONSOLE = "115200 ttyS0" 16SERIAL_CONSOLE = "115200 ttyS0"
17USE_VT ?= "0" 17USE_VT ?= "0"
diff --git a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
index 371a3db3d0..04c54f2710 100644
--- a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
+++ b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
@@ -14,7 +14,7 @@ SERIAL_CONSOLE = "115200 ttyS0"
14 14
15MACHINE_FEATURES = "keyboard pci ext2 ext3 serial" 15MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"
16 16
17PREFERRED_VERSION_linux-yocto ?= "4.12%" 17PREFERRED_VERSION_linux-yocto ?= "4.15%"
18PREFERRED_PROVIDER_virtual/kernel = "linux-yocto" 18PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
19 19
20PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" 20PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.14.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.14.bbappend
index 3f73eea118..5130707dd7 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.14.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.14.bbappend
@@ -1,14 +1,27 @@
1KBRANCH_genericx86 = "v4.14/standard/base" 1KBRANCH_genericx86 = "v4.14/standard/base"
2KBRANCH_genericx86-64 = "v4.14/standard/base" 2KBRANCH_genericx86-64 = "v4.14/standard/base"
3KBRANCH_edgerouter = "v4.14/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v4.14/standard/beaglebone"
5KBRANCH_mpc8315e-rdb = "v4.14/standard/fsl-mpc8315e-rdb"
3 6
4KMACHINE_genericx86 ?= "common-pc" 7KMACHINE_genericx86 ?= "common-pc"
5KMACHINE_genericx86-64 ?= "common-pc-64" 8KMACHINE_genericx86-64 ?= "common-pc-64"
9KMACHINE_beaglebone-yocto ?= "beaglebone"
6 10
7SRCREV_machine_genericx86 ?= "1d50ce210b0536eb9a66d1e56ae215f92176444a" 11SRCREV_machine_genericx86 ?= "1d50ce210b0536eb9a66d1e56ae215f92176444a"
8SRCREV_machine_genericx86-64 ?= "1d50ce210b0536eb9a66d1e56ae215f92176444a" 12SRCREV_machine_genericx86-64 ?= "1d50ce210b0536eb9a66d1e56ae215f92176444a"
13SRCREV_machine_edgerouter ?= "f2dc94f77d19ab65a832bad6f42662c509d2ef9e"
14SRCREV_machine_beaglebone-yocto ?= "6c1a02d4a9c227eca356911715a52cf92457ec16"
15SRCREV_machine_mpc8315e-rdb ?= "7e9a0b017be7b685e094638f4bdaa33a7df8f7c0"
9 16
10COMPATIBLE_MACHINE_genericx86 = "genericx86" 17COMPATIBLE_MACHINE_genericx86 = "genericx86"
11COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
19COMPATIBLE_MACHINE_edgerouter = "edgerouter"
20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
12 22
13LINUX_VERSION_genericx86 = "4.14.30" 23LINUX_VERSION_genericx86 = "4.14.30"
14LINUX_VERSION_genericx86-64 = "4.14.30" 24LINUX_VERSION_genericx86-64 = "4.14.30"
25LINUX_VERSION_edgerouter = "4.14.30"
26LINUX_VERSION_beaglebone-yocto = "4.14.30"
27LINUX_VERSION_mpc8315e-rdb = "4.14.30"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.15.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.15.bbappend
index 9ae1735469..c0c6ad92da 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.15.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.15.bbappend
@@ -1,14 +1,27 @@
1KBRANCH_genericx86 = "v4.15/standard/base" 1KBRANCH_genericx86 = "v4.15/standard/base"
2KBRANCH_genericx86-64 = "v4.15/standard/base" 2KBRANCH_genericx86-64 = "v4.15/standard/base"
3KBRANCH_edgerouter = "v4.15/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v4.15/standard/beaglebone"
5KBRANCH_mpc8315e-rdb = "v4.15/standard/fsl-mpc8315e-rdb"
3 6
4KMACHINE_genericx86 ?= "common-pc" 7KMACHINE_genericx86 ?= "common-pc"
5KMACHINE_genericx86-64 ?= "common-pc-64" 8KMACHINE_genericx86-64 ?= "common-pc-64"
9KMACHINE_beaglebone-yocto ?= "beaglebone"
6 10
7SRCREV_machine_genericx86 ?= "f73fd8783a3e7529902366ba75aafb81c19ec3c9" 11SRCREV_machine_genericx86 ?= "f73fd8783a3e7529902366ba75aafb81c19ec3c9"
8SRCREV_machine_genericx86-64 ?= "f73fd8783a3e7529902366ba75aafb81c19ec3c9" 12SRCREV_machine_genericx86-64 ?= "f73fd8783a3e7529902366ba75aafb81c19ec3c9"
13SRCREV_machine_edgerouter ?= "f73fd8783a3e7529902366ba75aafb81c19ec3c9"
14SRCREV_machine_beaglebone-yocto ?= "f73fd8783a3e7529902366ba75aafb81c19ec3c9"
15SRCREV_machine_mpc8315e-rdb ?= "cc2711c4f3b83b5cd78358e7c949fdbb6076e25b"
9 16
10COMPATIBLE_MACHINE_genericx86 = "genericx86" 17COMPATIBLE_MACHINE_genericx86 = "genericx86"
11COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
19COMPATIBLE_MACHINE_edgerouter = "edgerouter"
20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
12 22
13LINUX_VERSION_genericx86 = "4.15.13" 23LINUX_VERSION_genericx86 = "4.15.13"
14LINUX_VERSION_genericx86-64 = "4.15.13" 24LINUX_VERSION_genericx86-64 = "4.15.13"
25LINUX_VERSION_edgerouter = "4.15.13"
26LINUX_VERSION_beaglebone-yocto = "4.15.13"
27LINUX_VERSION_mpc8315e-rdb = "4.15.13"