diff options
author | Kevin Hao <kexin.hao@windriver.com> | 2024-01-20 21:42:53 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-01-22 13:45:33 +0000 |
commit | 640927625e490e0ae974ddd26252b1e354b4bf3c (patch) | |
tree | ab0dfb0aba7fc3b89cf9738e2d777c0952384791 /meta-yocto-bsp | |
parent | e0ee1b3160f682435de2a700ae5a78a4e8015dfe (diff) | |
download | poky-640927625e490e0ae974ddd26252b1e354b4bf3c.tar.gz |
yocto-bsp: Bump the default kernel to v6.6
Create the bbappend for v6.6 and bump the default kernel to v6.6 for
all the machines.
In the v6.6 kernel the dtb files for beaglebone have been moved to a
vendor specific directory, so we also need to adjust the corresponding
variables for its DTB generation.
(From meta-yocto rev: 58ac51b7a44fbb165311c7226ae8b15cd004114d)
Signed-off-by: Kevin Hao <kexin.hao@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
3 files changed, 24 insertions, 4 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf index 06a49f45f7..459c83f5c2 100644 --- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf +++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf | |||
@@ -20,10 +20,11 @@ do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do | |||
20 | SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyO0 115200;ttyAMA0" | 20 | SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyO0 115200;ttyAMA0" |
21 | 21 | ||
22 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | 22 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" |
23 | PREFERRED_VERSION_linux-yocto ?= "6.1%" | 23 | PREFERRED_VERSION_linux-yocto ?= "6.6%" |
24 | 24 | ||
25 | KERNEL_IMAGETYPE = "zImage" | 25 | KERNEL_IMAGETYPE = "zImage" |
26 | KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb" | 26 | DTB_FILES = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb" |
27 | KERNEL_DEVICETREE = '${@' '.join('ti/omap/%s' % d for d in '${DTB_FILES}'.split())}' | ||
27 | 28 | ||
28 | PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot" | 29 | PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot" |
29 | 30 | ||
@@ -33,7 +34,7 @@ UBOOT_MACHINE = "am335x_evm_defconfig" | |||
33 | 34 | ||
34 | MACHINE_FEATURES = "usbgadget usbhost vfat alsa" | 35 | MACHINE_FEATURES = "usbgadget usbhost vfat alsa" |
35 | 36 | ||
36 | IMAGE_BOOT_FILES ?= "u-boot.${UBOOT_SUFFIX} ${SPL_BINARY} ${KERNEL_IMAGETYPE} ${KERNEL_DEVICETREE}" | 37 | IMAGE_BOOT_FILES ?= "u-boot.${UBOOT_SUFFIX} ${SPL_BINARY} ${KERNEL_IMAGETYPE} ${DTB_FILES}" |
37 | 38 | ||
38 | # support runqemu | 39 | # support runqemu |
39 | EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native" | 40 | EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native" |
diff --git a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc index 24d427a360..50a233dd8f 100644 --- a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc +++ b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc | |||
@@ -2,7 +2,7 @@ include conf/machine/include/x86/x86-base.inc | |||
2 | require conf/machine/include/x86/qemuboot-x86.inc | 2 | require conf/machine/include/x86/qemuboot-x86.inc |
3 | MACHINE_FEATURES += "wifi efi pcbios" | 3 | MACHINE_FEATURES += "wifi efi pcbios" |
4 | 4 | ||
5 | PREFERRED_VERSION_linux-yocto ?= "6.1%" | 5 | PREFERRED_VERSION_linux-yocto ?= "6.6%" |
6 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | 6 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" |
7 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" | 7 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" |
8 | XSERVER ?= "${XSERVER_X86_BASE} \ | 8 | XSERVER ?= "${XSERVER_X86_BASE} \ |
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_6.6.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_6.6.bbappend new file mode 100644 index 0000000000..49eed162d9 --- /dev/null +++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_6.6.bbappend | |||
@@ -0,0 +1,19 @@ | |||
1 | KBRANCH:genericx86 = "v6.6/standard/base" | ||
2 | KBRANCH:genericx86-64 = "v6.6/standard/base" | ||
3 | KBRANCH:beaglebone-yocto = "v6.6/standard/beaglebone" | ||
4 | |||
5 | KMACHINE:genericx86 ?= "common-pc" | ||
6 | KMACHINE:genericx86-64 ?= "common-pc-64" | ||
7 | KMACHINE:beaglebone-yocto ?= "beaglebone" | ||
8 | |||
9 | SRCREV_machine:genericx86 ?= "195b2994f955071be3dd16ff61127dbc6b2e0069" | ||
10 | SRCREV_machine:genericx86-64 ?= "195b2994f955071be3dd16ff61127dbc6b2e0069" | ||
11 | SRCREV_machine:beaglebone-yocto ?= "195b2994f955071be3dd16ff61127dbc6b2e0069" | ||
12 | |||
13 | COMPATIBLE_MACHINE:genericx86 = "genericx86" | ||
14 | COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64" | ||
15 | COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto" | ||
16 | |||
17 | LINUX_VERSION:genericx86 = "6.6.12" | ||
18 | LINUX_VERSION:genericx86-64 = "6.6.12" | ||
19 | LINUX_VERSION:beaglebone-yocto = "6.6.12" | ||