summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-25 22:29:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-29 23:38:21 +0100
commit9826f87cb466a85cba736529831175437dcc621a (patch)
treecbcabea97ff4d1225102495cd629888bbc384468 /meta-yocto-bsp
parentd41af446febd516f14f26db53e6572d9eae35b1e (diff)
downloadpoky-9826f87cb466a85cba736529831175437dcc621a.tar.gz
meta-poky/meta-yocto-bsp: Convert to new override syntax
This converts the two layers to the new override syntax. This was done using <oe-core>/scripts/contrib/convert-overrides.py <this-layer> with no manual fixes. (From meta-yocto rev: 387eab70f343966267c2a68746aea1bbb8525191) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone-yocto.conf4
-rw-r--r--meta-yocto-bsp/conf/machine/include/genericx86-common.inc2
-rw-r--r--meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend2
-rw-r--r--meta-yocto-bsp/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb2
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend22
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend38
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend38
8 files changed, 55 insertions, 55 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
index 04cbd3b5b7..65c79fd34d 100644
--- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
+++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -15,9 +15,9 @@ DEFAULTTUNE ?= "cortexa8hf-neon"
15include conf/machine/include/tune-cortexa8.inc 15include conf/machine/include/tune-cortexa8.inc
16 16
17IMAGE_FSTYPES += "tar.bz2 jffs2 wic wic.bmap" 17IMAGE_FSTYPES += "tar.bz2 jffs2 wic wic.bmap"
18EXTRA_IMAGECMD_jffs2 = "-lnp " 18EXTRA_IMAGECMD:jffs2 = "-lnp "
19WKS_FILE ?= "beaglebone-yocto.wks" 19WKS_FILE ?= "beaglebone-yocto.wks"
20IMAGE_INSTALL_append = " kernel-devicetree kernel-image-zimage" 20IMAGE_INSTALL:append = " kernel-devicetree kernel-image-zimage"
21do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot virtual/bootloader:do_deploy" 21do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot virtual/bootloader:do_deploy"
22 22
23SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyO0 115200;ttyAMA0" 23SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyO0 115200;ttyAMA0"
diff --git a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
index 1de069011d..59d96d1417 100644
--- a/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
+++ b/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
@@ -18,7 +18,7 @@ MACHINE_EXTRA_RRECOMMENDS += "kernel-modules linux-firmware"
18 18
19GLIBC_ADDONS = "nptl" 19GLIBC_ADDONS = "nptl"
20 20
21EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi" 21EXTRA_OECONF:append:pn-matchbox-panel-2 = " --with-battery=acpi"
22 22
23IMAGE_FSTYPES += "wic wic.bmap" 23IMAGE_FSTYPES += "wic wic.bmap"
24WKS_FILE ?= "genericx86.wks.in" 24WKS_FILE ?= "genericx86.wks.in"
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend
index 72d991c7e5..4fc41d0580 100644
--- a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -1 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/meta-yocto-bsp/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb b/meta-yocto-bsp/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb
index 8f10bd239c..1fe1212419 100644
--- a/meta-yocto-bsp/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb
+++ b/meta-yocto-bsp/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb
@@ -12,7 +12,7 @@ do_install(){
12 install -m 644 ${WORKDIR}/gma500-gfx-check.conf ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.conf 12 install -m 644 ${WORKDIR}/gma500-gfx-check.conf ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.conf
13} 13}
14 14
15FILES_${PN}="${sysconfdir}/modprobe.d/gma500-gfx-check.conf \ 15FILES:${PN}="${sysconfdir}/modprobe.d/gma500-gfx-check.conf \
16 ${sysconfdir}/modprobe.d/gma500-gfx-check.sh" 16 ${sysconfdir}/modprobe.d/gma500-gfx-check.sh"
17 17
18COMPATIBLE_MACHINE = "genericx86" 18COMPATIBLE_MACHINE = "genericx86"
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
index 72d991c7e5..4fc41d0580 100644
--- a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -1 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
index 6e5a129dd4..a90958f546 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,13 +1,13 @@
1KBRANCH_genericx86 = "standard/base" 1KBRANCH:genericx86 = "standard/base"
2KBRANCH_genericx86-64 = "standard/base" 2KBRANCH:genericx86-64 = "standard/base"
3KBRANCH_edgerouter = "standard/edgerouter" 3KBRANCH:edgerouter = "standard/edgerouter"
4KBRANCH_beaglebone-yocto = "standard/beaglebone" 4KBRANCH:beaglebone-yocto = "standard/beaglebone"
5 5
6KMACHINE_genericx86 ?= "common-pc" 6KMACHINE:genericx86 ?= "common-pc"
7KMACHINE_genericx86-64 ?= "common-pc-64" 7KMACHINE:genericx86-64 ?= "common-pc-64"
8KMACHINE_beaglebone-yocto ?= "beaglebone" 8KMACHINE:beaglebone-yocto ?= "beaglebone"
9 9
10COMPATIBLE_MACHINE_genericx86 = "genericx86" 10COMPATIBLE_MACHINE:genericx86 = "genericx86"
11COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 11COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64"
12COMPATIBLE_MACHINE_edgerouter = "edgerouter" 12COMPATIBLE_MACHINE:edgerouter = "edgerouter"
13COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" 13COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend
index f8362b6635..0b017fc79d 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.10.bbappend
@@ -1,23 +1,23 @@
1KBRANCH_genericx86 = "v5.10/standard/base" 1KBRANCH:genericx86 = "v5.10/standard/base"
2KBRANCH_genericx86-64 = "v5.10/standard/base" 2KBRANCH:genericx86-64 = "v5.10/standard/base"
3KBRANCH_edgerouter = "v5.10/standard/edgerouter" 3KBRANCH:edgerouter = "v5.10/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.10/standard/beaglebone" 4KBRANCH:beaglebone-yocto = "v5.10/standard/beaglebone"
5 5
6KMACHINE_genericx86 ?= "common-pc" 6KMACHINE:genericx86 ?= "common-pc"
7KMACHINE_genericx86-64 ?= "common-pc-64" 7KMACHINE:genericx86-64 ?= "common-pc-64"
8KMACHINE_beaglebone-yocto ?= "beaglebone" 8KMACHINE:beaglebone-yocto ?= "beaglebone"
9 9
10SRCREV_machine_genericx86 ?= "ab49d2db98bdee2c8c6e17fb59ded9e5292b0f41" 10SRCREV_machine:genericx86 ?= "ab49d2db98bdee2c8c6e17fb59ded9e5292b0f41"
11SRCREV_machine_genericx86-64 ?= "ab49d2db98bdee2c8c6e17fb59ded9e5292b0f41" 11SRCREV_machine:genericx86-64 ?= "ab49d2db98bdee2c8c6e17fb59ded9e5292b0f41"
12SRCREV_machine_edgerouter ?= "274d63799465eebfd201b3e8251f16d29e93a978" 12SRCREV_machine:edgerouter ?= "274d63799465eebfd201b3e8251f16d29e93a978"
13SRCREV_machine_beaglebone-yocto ?= "ab49d2db98bdee2c8c6e17fb59ded9e5292b0f41" 13SRCREV_machine:beaglebone-yocto ?= "ab49d2db98bdee2c8c6e17fb59ded9e5292b0f41"
14 14
15COMPATIBLE_MACHINE_genericx86 = "genericx86" 15COMPATIBLE_MACHINE:genericx86 = "genericx86"
16COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 16COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64"
17COMPATIBLE_MACHINE_edgerouter = "edgerouter" 17COMPATIBLE_MACHINE:edgerouter = "edgerouter"
18COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" 18COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto"
19 19
20LINUX_VERSION_genericx86 = "5.10.43" 20LINUX_VERSION:genericx86 = "5.10.43"
21LINUX_VERSION_genericx86-64 = "5.10.43" 21LINUX_VERSION:genericx86-64 = "5.10.43"
22LINUX_VERSION_edgerouter = "5.10.43" 22LINUX_VERSION:edgerouter = "5.10.43"
23LINUX_VERSION_beaglebone-yocto = "5.10.43" 23LINUX_VERSION:beaglebone-yocto = "5.10.43"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend
index 35147d2da8..290aa323eb 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.4.bbappend
@@ -1,23 +1,23 @@
1KBRANCH_genericx86 = "v5.4/standard/base" 1KBRANCH:genericx86 = "v5.4/standard/base"
2KBRANCH_genericx86-64 = "v5.4/standard/base" 2KBRANCH:genericx86-64 = "v5.4/standard/base"
3KBRANCH_edgerouter = "v5.4/standard/edgerouter" 3KBRANCH:edgerouter = "v5.4/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.4/standard/beaglebone" 4KBRANCH:beaglebone-yocto = "v5.4/standard/beaglebone"
5 5
6KMACHINE_genericx86 ?= "common-pc" 6KMACHINE:genericx86 ?= "common-pc"
7KMACHINE_genericx86-64 ?= "common-pc-64" 7KMACHINE:genericx86-64 ?= "common-pc-64"
8KMACHINE_beaglebone-yocto ?= "beaglebone" 8KMACHINE:beaglebone-yocto ?= "beaglebone"
9 9
10SRCREV_machine_genericx86 ?= "31db2b47ac7d8508080fbb7344399b501216de66" 10SRCREV_machine:genericx86 ?= "31db2b47ac7d8508080fbb7344399b501216de66"
11SRCREV_machine_genericx86-64 ?= "31db2b47ac7d8508080fbb7344399b501216de66" 11SRCREV_machine:genericx86-64 ?= "31db2b47ac7d8508080fbb7344399b501216de66"
12SRCREV_machine_edgerouter ?= "706efec4c1e270ec5dda92275898cd465dfdc7dd" 12SRCREV_machine:edgerouter ?= "706efec4c1e270ec5dda92275898cd465dfdc7dd"
13SRCREV_machine_beaglebone-yocto ?= "706efec4c1e270ec5dda92275898cd465dfdc7dd" 13SRCREV_machine:beaglebone-yocto ?= "706efec4c1e270ec5dda92275898cd465dfdc7dd"
14 14
15COMPATIBLE_MACHINE_genericx86 = "genericx86" 15COMPATIBLE_MACHINE:genericx86 = "genericx86"
16COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 16COMPATIBLE_MACHINE:genericx86-64 = "genericx86-64"
17COMPATIBLE_MACHINE_edgerouter = "edgerouter" 17COMPATIBLE_MACHINE:edgerouter = "edgerouter"
18COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" 18COMPATIBLE_MACHINE:beaglebone-yocto = "beaglebone-yocto"
19 19
20LINUX_VERSION_genericx86 = "5.4.94" 20LINUX_VERSION:genericx86 = "5.4.94"
21LINUX_VERSION_genericx86-64 = "5.4.94" 21LINUX_VERSION:genericx86-64 = "5.4.94"
22LINUX_VERSION_edgerouter = "5.4.58" 22LINUX_VERSION:edgerouter = "5.4.58"
23LINUX_VERSION_beaglebone-yocto = "5.4.58" 23LINUX_VERSION:beaglebone-yocto = "5.4.58"