diff options
author | Maciej Pijanowski <maciej.pijanowski@3mdeb.com> | 2018-08-13 19:57:13 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-15 21:45:58 +0100 |
commit | 38125456ffa6112941a3608fcba9ed2032353740 (patch) | |
tree | e4034b54abe53289e16a0cb642075cc12b577d20 /meta-yocto-bsp | |
parent | b6660c301c34ab469e156e6cf5d0abe44d55c580 (diff) | |
download | poky-38125456ffa6112941a3608fcba9ed2032353740.tar.gz |
machine configs: replace deprecated "SERIAL_CONSOLE"
SERIAL_CONSOLE was already deprecated in 2013, yet still some
machine configuration files were using it. This patch replaces
it with SERIAL_CONSOLES, which is the successor.
The default value in systemd-serialgetty.bb can also be safely
transitioned from SERIAL_CONSOLE to SERIAL_CONSOLES, as this
recipe already uses SERIAL_CONSOLES within do_install().
The documentation seems to be already up do date.
beaglebone-yocto.conf in the bsp-guide already uses
SERIAL_CONSOLES. The ref-manual redirects from SERIAL_CONSOLE
to SERIAL_CONSOLES.
[YOCTO #12653]
(From meta-yocto rev: a0c5332aefe75cf314e78284f578b17c51b8ab27)
Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r-- | meta-yocto-bsp/conf/machine/beaglebone-yocto.conf | 2 | ||||
-rw-r--r-- | meta-yocto-bsp/conf/machine/edgerouter.conf | 2 | ||||
-rw-r--r-- | meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf | 4 |
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf index faa4f1bd36..5cc2923903 100644 --- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf +++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf | |||
@@ -20,7 +20,7 @@ WKS_FILE ?= "beaglebone-yocto.wks" | |||
20 | IMAGE_INSTALL_append = " kernel-devicetree kernel-image-zimage" | 20 | IMAGE_INSTALL_append = " kernel-devicetree kernel-image-zimage" |
21 | do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot" | 21 | do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot" |
22 | 22 | ||
23 | SERIAL_CONSOLE = "115200 ttyO0" | 23 | SERIAL_CONSOLES = "115200;ttyO0" |
24 | 24 | ||
25 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | 25 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" |
26 | PREFERRED_VERSION_linux-yocto ?= "4.15%" | 26 | PREFERRED_VERSION_linux-yocto ?= "4.15%" |
diff --git a/meta-yocto-bsp/conf/machine/edgerouter.conf b/meta-yocto-bsp/conf/machine/edgerouter.conf index 61f2145fd5..a3eeebf2f6 100644 --- a/meta-yocto-bsp/conf/machine/edgerouter.conf +++ b/meta-yocto-bsp/conf/machine/edgerouter.conf | |||
@@ -13,7 +13,7 @@ KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment" | |||
13 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | 13 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" |
14 | PREFERRED_VERSION_linux-yocto ?= "4.15%" | 14 | PREFERRED_VERSION_linux-yocto ?= "4.15%" |
15 | 15 | ||
16 | SERIAL_CONSOLE = "115200 ttyS0" | 16 | SERIAL_CONSOLES = "115200;ttyS0" |
17 | USE_VT ?= "0" | 17 | USE_VT ?= "0" |
18 | 18 | ||
19 | MACHINE_EXTRA_RRECOMMENDS = "kernel-modules" | 19 | MACHINE_EXTRA_RRECOMMENDS = "kernel-modules" |
diff --git a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf index eae8157eab..441987a78e 100644 --- a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf +++ b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf | |||
@@ -1,5 +1,5 @@ | |||
1 | #@TYPE: Machine | 1 | #@TYPE: Machine |
2 | #@DESCRIPTION: Machine configuration for running | 2 | #@DESCRIPTION: Machine configuration for running |
3 | 3 | ||
4 | TARGET_FPU = "" | 4 | TARGET_FPU = "" |
5 | 5 | ||
@@ -10,7 +10,7 @@ KERNEL_IMAGETYPE = "uImage" | |||
10 | EXTRA_IMAGEDEPENDS += "u-boot" | 10 | EXTRA_IMAGEDEPENDS += "u-boot" |
11 | UBOOT_MACHINE = "MPC8315ERDB_config" | 11 | UBOOT_MACHINE = "MPC8315ERDB_config" |
12 | 12 | ||
13 | SERIAL_CONSOLE = "115200 ttyS0" | 13 | SERIAL_CONSOLES = "115200;ttyS0" |
14 | 14 | ||
15 | MACHINE_FEATURES = "keyboard pci ext2 ext3 serial" | 15 | MACHINE_FEATURES = "keyboard pci ext2 ext3 serial" |
16 | 16 | ||