summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2017-11-09 14:59:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-11 12:14:55 +0000
commit87df4e002f6e5ad5499bbeaf22877bbfc08efdd7 (patch)
treee18f5e6b729850d4674e27c13f373722bba94feb /meta-yocto-bsp
parent0cff8d3c5bd2cddc9a0962257d64eba1efb4b17c (diff)
downloadpoky-87df4e002f6e5ad5499bbeaf22877bbfc08efdd7.tar.gz
beaglebone-yocto: rename beaglebone machine to beaglebone-yocto
The beaglebone BSP provided in this layer is a reference implementation usingonly mainline components available in core Yocto Project layers, whereas Texas Instruments maintain a full-featured BSP in the meta-ti layer. Rename the reference machine to prevent namespace collisions with the version maintained by the SoC vendor. [YOCTO #12326] (From meta-yocto rev: e32882938eca7f50548deab84dab78b4aef31b95) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/README.hardware6
-rw-r--r--meta-yocto-bsp/conf/layer.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone-yocto.conf (renamed from meta-yocto-bsp/conf/machine/beaglebone.conf)6
-rw-r--r--meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beaglebone-yocto/machconfig (renamed from meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beaglebone/machconfig)0
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beaglebone-yocto/xorg.conf (renamed from meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beaglebone/xorg.conf)0
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.10.bbappend9
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.12.bbappend9
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.4.bbappend9
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.9.bbappend9
-rw-r--r--meta-yocto-bsp/wic/beaglebone-yocto.wks (renamed from meta-yocto-bsp/wic/beaglebone.wks)0
10 files changed, 27 insertions, 23 deletions
diff --git a/meta-yocto-bsp/README.hardware b/meta-yocto-bsp/README.hardware
index 84c5afa909..d8d2a0cac6 100644
--- a/meta-yocto-bsp/README.hardware
+++ b/meta-yocto-bsp/README.hardware
@@ -27,7 +27,7 @@ Hardware Reference Boards
27 27
28The following boards are supported by the meta-yocto-bsp layer: 28The following boards are supported by the meta-yocto-bsp layer:
29 29
30 * Texas Instruments Beaglebone (beaglebone) 30 * Texas Instruments Beaglebone (beaglebone-yocto)
31 * Freescale MPC8315E-RDB (mpc8315e-rdb) 31 * Freescale MPC8315E-RDB (mpc8315e-rdb)
32 * Ubiquiti Networks EdgeRouter Lite (edgerouter) 32 * Ubiquiti Networks EdgeRouter Lite (edgerouter)
33 * General IA platforms (genericx86 and genericx86-64) 33 * General IA platforms (genericx86 and genericx86-64)
@@ -120,7 +120,7 @@ USB Device:
120 dd command to write the image to a USB stick. 120 dd command to write the image to a USB stick.
121 121
122 122
123Texas Instruments Beaglebone (beaglebone) 123Texas Instruments Beaglebone (beaglebone-yocto)
124========================================= 124=========================================
125 125
126The Beaglebone is an ARM Cortex-A8 development board with USB, Ethernet, 2D/3D 126The Beaglebone is an ARM Cortex-A8 development board with USB, Ethernet, 2D/3D
@@ -151,7 +151,7 @@ From a Linux system with access to the image files perform the following steps:
151 151
152 2. Use the "dd" utility to write the image to the SD card. For example: 152 2. Use the "dd" utility to write the image to the SD card. For example:
153 153
154 # dd core-image-minimal-beaglebone.wic of=/dev/sdb 154 # dd core-image-minimal-beaglebone-yocto.wic of=/dev/sdb
155 155
156 3. Insert the SD card into the Beaglebone and boot the board. 156 3. Insert the SD card into the Beaglebone and boot the board.
157 157
diff --git a/meta-yocto-bsp/conf/layer.conf b/meta-yocto-bsp/conf/layer.conf
index 7b565f222a..e10056e046 100644
--- a/meta-yocto-bsp/conf/layer.conf
+++ b/meta-yocto-bsp/conf/layer.conf
@@ -8,5 +8,5 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "yoctobsp" 8BBFILE_COLLECTIONS += "yoctobsp"
9BBFILE_PATTERN_yoctobsp = "^${LAYERDIR}/" 9BBFILE_PATTERN_yoctobsp = "^${LAYERDIR}/"
10BBFILE_PRIORITY_yoctobsp = "5" 10BBFILE_PRIORITY_yoctobsp = "5"
11LAYERVERSION_yoctobsp = "3" 11LAYERVERSION_yoctobsp = "4"
12LAYERSERIES_COMPAT_yoctobsp = "rocko" 12LAYERSERIES_COMPAT_yoctobsp = "rocko"
diff --git a/meta-yocto-bsp/conf/machine/beaglebone.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
index 1bdd4dfb70..990c967416 100644
--- a/meta-yocto-bsp/conf/machine/beaglebone.conf
+++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -1,6 +1,6 @@
1#@TYPE: Machine 1#@TYPE: Machine
2#@NAME: Beaglebone machine 2#@NAME: Beaglebone-yocto machine
3#@DESCRIPTION: Machine configuration for http://beagleboard.org/bone and http://beagleboard.org/black boards 3#@DESCRIPTION: Reference machine configuration for http://beagleboard.org/bone and http://beagleboard.org/black boards
4 4
5PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" 5PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
6XSERVER ?= "xserver-xorg \ 6XSERVER ?= "xserver-xorg \
@@ -16,7 +16,7 @@ include conf/machine/include/tune-cortexa8.inc
16 16
17IMAGE_FSTYPES += "tar.bz2 jffs2 wic wic.bmap" 17IMAGE_FSTYPES += "tar.bz2 jffs2 wic wic.bmap"
18EXTRA_IMAGECMD_jffs2 = "-lnp " 18EXTRA_IMAGECMD_jffs2 = "-lnp "
19WKS_FILE ?= "beaglebone.wks" 19WKS_FILE ?= "beaglebone-yocto.wks"
20IMAGE_INSTALL_append = " kernel-devicetree kernel-image-zimage" 20IMAGE_INSTALL_append = " kernel-devicetree kernel-image-zimage"
21do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot" 21do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"
22 22
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beaglebone/machconfig b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beaglebone-yocto/machconfig
index ffce012270..ffce012270 100644
--- a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beaglebone/machconfig
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/beaglebone-yocto/machconfig
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beaglebone/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beaglebone-yocto/xorg.conf
index 2f40dae157..2f40dae157 100644
--- a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beaglebone/xorg.conf
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beaglebone-yocto/xorg.conf
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.10.bbappend
index e1f359c9e8..346a1c7935 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.10.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.10.bbappend
@@ -4,23 +4,24 @@ KBRANCH_genericx86-64 = "standard/base"
4KMACHINE_genericx86 ?= "common-pc" 4KMACHINE_genericx86 ?= "common-pc"
5KMACHINE_genericx86-64 ?= "common-pc-64" 5KMACHINE_genericx86-64 ?= "common-pc-64"
6KBRANCH_edgerouter = "standard/edgerouter" 6KBRANCH_edgerouter = "standard/edgerouter"
7KBRANCH_beaglebone = "standard/beaglebone" 7KBRANCH_beaglebone-yocto = "standard/beaglebone"
8KMACHINE_beaglebone-yocto = "beaglebone"
8KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 9KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
9 10
10SRCREV_machine_genericx86 ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09" 11SRCREV_machine_genericx86 ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09"
11SRCREV_machine_genericx86-64 ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09" 12SRCREV_machine_genericx86-64 ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09"
12SRCREV_machine_edgerouter ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09" 13SRCREV_machine_edgerouter ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09"
13SRCREV_machine_beaglebone ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09" 14SRCREV_machine_beaglebone-yocto ?= "c1d8c4408b8aedd88eeb6ccc89ce834dd41b3f09"
14SRCREV_machine_mpc8315e-rdb ?= "c388fdfc9a1e06b22ca3533a023f4d67a6fc1e9b" 15SRCREV_machine_mpc8315e-rdb ?= "c388fdfc9a1e06b22ca3533a023f4d67a6fc1e9b"
15 16
16COMPATIBLE_MACHINE_genericx86 = "genericx86" 17COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
18COMPATIBLE_MACHINE_edgerouter = "edgerouter" 19COMPATIBLE_MACHINE_edgerouter = "edgerouter"
19COMPATIBLE_MACHINE_beaglebone = "beaglebone" 20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
20COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
21 22
22LINUX_VERSION_genericx86 = "4.10.17" 23LINUX_VERSION_genericx86 = "4.10.17"
23LINUX_VERSION_genericx86-64 = "4.10.17" 24LINUX_VERSION_genericx86-64 = "4.10.17"
24LINUX_VERSION_edgerouter = "4.10.17" 25LINUX_VERSION_edgerouter = "4.10.17"
25LINUX_VERSION_beaglebone = "4.10.17" 26LINUX_VERSION_beaglebone-yocto = "4.10.17"
26LINUX_VERSION_mpc8315e-rdb = "4.10.17" 27LINUX_VERSION_mpc8315e-rdb = "4.10.17"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.12.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.12.bbappend
index 06ea8f89c3..2609129e3c 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.12.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.12.bbappend
@@ -4,24 +4,25 @@ KBRANCH_genericx86-64 = "standard/base"
4KMACHINE_genericx86 ?= "common-pc" 4KMACHINE_genericx86 ?= "common-pc"
5KMACHINE_genericx86-64 ?= "common-pc-64" 5KMACHINE_genericx86-64 ?= "common-pc-64"
6KBRANCH_edgerouter = "standard/edgerouter" 6KBRANCH_edgerouter = "standard/edgerouter"
7KBRANCH_beaglebone = "standard/beaglebone" 7KBRANCH_beaglebone-yocto = "standard/beaglebone"
8KMACHINE_beaglebone-yocto = "beaglebone"
8KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 9KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
9 10
10SRCREV_machine_genericx86 ?= "16de0149674ed12d983b77a453852ac2e64584b4" 11SRCREV_machine_genericx86 ?= "16de0149674ed12d983b77a453852ac2e64584b4"
11SRCREV_machine_genericx86-64 ?= "16de0149674ed12d983b77a453852ac2e64584b4" 12SRCREV_machine_genericx86-64 ?= "16de0149674ed12d983b77a453852ac2e64584b4"
12SRCREV_machine_edgerouter ?= "16de0149674ed12d983b77a453852ac2e64584b4" 13SRCREV_machine_edgerouter ?= "16de0149674ed12d983b77a453852ac2e64584b4"
13SRCREV_machine_beaglebone ?= "16de0149674ed12d983b77a453852ac2e64584b4" 14SRCREV_machine_beaglebone-yocto ?= "16de0149674ed12d983b77a453852ac2e64584b4"
14SRCREV_machine_mpc8315e-rdb ?= "8c360c7c3eebeb9251ddd8e9cde39908677f5850" 15SRCREV_machine_mpc8315e-rdb ?= "8c360c7c3eebeb9251ddd8e9cde39908677f5850"
15 16
16 17
17COMPATIBLE_MACHINE_genericx86 = "genericx86" 18COMPATIBLE_MACHINE_genericx86 = "genericx86"
18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 19COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
19COMPATIBLE_MACHINE_edgerouter = "edgerouter" 20COMPATIBLE_MACHINE_edgerouter = "edgerouter"
20COMPATIBLE_MACHINE_beaglebone = "beaglebone" 21COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 22COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
22 23
23LINUX_VERSION_genericx86 = "4.12.12" 24LINUX_VERSION_genericx86 = "4.12.12"
24LINUX_VERSION_genericx86-64 = "4.12.12" 25LINUX_VERSION_genericx86-64 = "4.12.12"
25LINUX_VERSION_edgerouter = "4.12.12" 26LINUX_VERSION_edgerouter = "4.12.12"
26LINUX_VERSION_beaglebone = "4.12.12" 27LINUX_VERSION_beaglebone-yocto = "4.12.12"
27LINUX_VERSION_mpc8315e-rdb = "4.12.12" 28LINUX_VERSION_mpc8315e-rdb = "4.12.12"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.4.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.4.bbappend
index 427af4c4cf..5725c879df 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -4,23 +4,24 @@ KBRANCH_genericx86-64 = "standard/base"
4KMACHINE_genericx86 ?= "common-pc" 4KMACHINE_genericx86 ?= "common-pc"
5KMACHINE_genericx86-64 ?= "common-pc-64" 5KMACHINE_genericx86-64 ?= "common-pc-64"
6KBRANCH_edgerouter = "standard/edgerouter" 6KBRANCH_edgerouter = "standard/edgerouter"
7KBRANCH_beaglebone = "standard/beaglebone" 7KBRANCH_beaglebone-yocto = "standard/beaglebone"
8KMACHINE_beaglebone-yocto = "beaglebone"
8KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 9KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
9 10
10SRCREV_machine_genericx86 ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699" 11SRCREV_machine_genericx86 ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699"
11SRCREV_machine_genericx86-64 ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699" 12SRCREV_machine_genericx86-64 ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699"
12SRCREV_machine_edgerouter ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699" 13SRCREV_machine_edgerouter ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699"
13SRCREV_machine_beaglebone ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699" 14SRCREV_machine_beaglebone-yocto ?= "b71c7b786aed26c0a1e4eca66f1d874ec017d699"
14SRCREV_machine_mpc8315e-rdb ?= "b4daa4e9d68862e559d726b0b66b7be605889b9e" 15SRCREV_machine_mpc8315e-rdb ?= "b4daa4e9d68862e559d726b0b66b7be605889b9e"
15 16
16COMPATIBLE_MACHINE_genericx86 = "genericx86" 17COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
18COMPATIBLE_MACHINE_edgerouter = "edgerouter" 19COMPATIBLE_MACHINE_edgerouter = "edgerouter"
19COMPATIBLE_MACHINE_beaglebone = "beaglebone" 20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
20COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
21 22
22LINUX_VERSION_genericx86 = "4.4.87" 23LINUX_VERSION_genericx86 = "4.4.87"
23LINUX_VERSION_genericx86-64 = "4.4.87" 24LINUX_VERSION_genericx86-64 = "4.4.87"
24LINUX_VERSION_edgerouter = "4.4.87" 25LINUX_VERSION_edgerouter = "4.4.87"
25LINUX_VERSION_beaglebone = "4.4.87" 26LINUX_VERSION_beaglebone-yocto = "4.4.87"
26LINUX_VERSION_mpc8315e-rdb = "4.4.87" 27LINUX_VERSION_mpc8315e-rdb = "4.4.87"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.9.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.9.bbappend
index b3b5cd546c..63538de735 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.9.bbappend
@@ -4,23 +4,24 @@ KBRANCH_genericx86-64 = "standard/base"
4KMACHINE_genericx86 ?= "common-pc" 4KMACHINE_genericx86 ?= "common-pc"
5KMACHINE_genericx86-64 ?= "common-pc-64" 5KMACHINE_genericx86-64 ?= "common-pc-64"
6KBRANCH_edgerouter = "standard/edgerouter" 6KBRANCH_edgerouter = "standard/edgerouter"
7KBRANCH_beaglebone = "standard/beaglebone" 7KBRANCH_beaglebone-yocto = "standard/beaglebone"
8KMACHINE_beaglebone-yocto = "beaglebone"
8KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 9KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
9 10
10SRCREV_machine_genericx86 ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404" 11SRCREV_machine_genericx86 ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404"
11SRCREV_machine_genericx86-64 ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404" 12SRCREV_machine_genericx86-64 ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404"
12SRCREV_machine_edgerouter ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404" 13SRCREV_machine_edgerouter ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404"
13SRCREV_machine_beaglebone ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404" 14SRCREV_machine_beaglebone-yocto ?= "480ee599fb8df712c10dcf4b7aa6398b79f7d404"
14SRCREV_machine_mpc8315e-rdb ?= "88a703b15a7564704c3dc5d3c1237e0859897655" 15SRCREV_machine_mpc8315e-rdb ?= "88a703b15a7564704c3dc5d3c1237e0859897655"
15 16
16COMPATIBLE_MACHINE_genericx86 = "genericx86" 17COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
18COMPATIBLE_MACHINE_edgerouter = "edgerouter" 19COMPATIBLE_MACHINE_edgerouter = "edgerouter"
19COMPATIBLE_MACHINE_beaglebone = "beaglebone" 20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
20COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
21 22
22LINUX_VERSION_genericx86 = "4.9.49" 23LINUX_VERSION_genericx86 = "4.9.49"
23LINUX_VERSION_genericx86-64 = "4.9.49" 24LINUX_VERSION_genericx86-64 = "4.9.49"
24LINUX_VERSION_edgerouter = "4.9.49" 25LINUX_VERSION_edgerouter = "4.9.49"
25LINUX_VERSION_beaglebone = "4.9.49" 26LINUX_VERSION_beaglebone-yocto = "4.9.49"
26LINUX_VERSION_mpc8315e-rdb = "4.9.49" 27LINUX_VERSION_mpc8315e-rdb = "4.9.49"
diff --git a/meta-yocto-bsp/wic/beaglebone.wks b/meta-yocto-bsp/wic/beaglebone-yocto.wks
index 967cad78b8..967cad78b8 100644
--- a/meta-yocto-bsp/wic/beaglebone.wks
+++ b/meta-yocto-bsp/wic/beaglebone-yocto.wks