summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2013-08-27 13:16:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-28 00:25:56 +0100
commit6c3a0292df7ae0cb5bf7d8d19346d7b07610a1a3 (patch)
tree2fd015e6aca0bf8be7466444770099501947255f /meta-yocto-bsp
parentda6260f95f4adcca22da9b0d5fb26e93c0a2517f (diff)
downloadpoky-6c3a0292df7ae0cb5bf7d8d19346d7b07610a1a3.tar.gz
meta-yocto-bsp: Add genericx86-64 machine
Duplicate the genericx86 machine, but select x86_64 tunables and use the common-pc-64 linux-yocto KMACHINE and config. This has been boot tested with core-image-sato on a Lenovo x220 (Core-i5) and a Supermicro MBD-X8DTL-iF-O (dual-socket Xeon 5680). (From meta-yocto rev: 9b7db7ded0e6b7f5c0cd3ab7fbb0bce4112407da) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Ross Burton <ross.burton@intel.com> Cc: Tom Zanussi <tom.zanussi@intel.com> Cc: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/genericx86-64.conf34
-rw-r--r--meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig6
-rw-r--r--meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine69
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf0
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend6
5 files changed, 114 insertions, 1 deletions
diff --git a/meta-yocto-bsp/conf/machine/genericx86-64.conf b/meta-yocto-bsp/conf/machine/genericx86-64.conf
new file mode 100644
index 0000000000..7825baef9b
--- /dev/null
+++ b/meta-yocto-bsp/conf/machine/genericx86-64.conf
@@ -0,0 +1,34 @@
1#@TYPE: Machine
2#@NAME: Generic X86_64.
3
4#@DESCRIPTION: Machine configuration for generic X86_64 (64-bit) PCs and servers. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
5
6include conf/machine/include/tune-x86_64.inc
7
8MACHINE_FEATURES = "screen keyboard pci usbhost ext2 ext3 x86 wifi acpi alsa efi pcbios"
9
10KERNEL_IMAGETYPE = "bzImage"
11
12PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
13PREFERRED_VERSION_linux-yocto ?= "3.10%"
14PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
15XSERVER ?= "xserver-xorg \
16 xserver-xorg-extension-glx \
17 xf86-input-mouse \
18 xf86-input-keyboard \
19 xf86-input-evdev \
20 xf86-input-synaptics \
21 xf86-video-fbdev \
22 xf86-video-modesetting \
23 xf86-video-vesa \
24 xf86-video-intel \
25 mesa-driver-i915 \
26 mesa-driver-i965"
27
28MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts linux-firmware v86d"
29
30IMAGE_FSTYPES ?= "ext3 cpio.gz live"
31
32GLIBC_ADDONS = "nptl"
33
34EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
diff --git a/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig
new file mode 100644
index 0000000000..a81a23bf5b
--- /dev/null
+++ b/meta-yocto-bsp/recipes-bsp/formfactor/formfactor/genericx86-64/machconfig
@@ -0,0 +1,6 @@
1HAVE_TOUCHSCREEN=0
2HAVE_KEYBOARD=1
3
4DISPLAY_CAN_ROTATE=0
5DISPLAY_ORIENTATION=0
6DISPLAY_DPI=133
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine
new file mode 100644
index 0000000000..305dc64dec
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc/genericx86-64/uClibc.machine
@@ -0,0 +1,69 @@
1#
2# Automatically generated make config: don't edit
3# Fri Nov 23 15:49:33 2007
4#
5# TARGET_alpha is not set
6# TARGET_arm is not set
7# TARGET_bfin is not set
8# TARGET_cris is not set
9# TARGET_e1 is not set
10# TARGET_frv is not set
11# TARGET_h8300 is not set
12# TARGET_hppa is not set
13# TARGET_i386=y
14# TARGET_i960 is not set
15# TARGET_ia64 is not set
16# TARGET_m68k is not set
17# TARGET_microblaze is not set
18# TARGET_mips is not set
19# TARGET_nios is not set
20# TARGET_nios2 is not set
21# TARGET_powerpc is not set
22# TARGET_sh is not set
23# TARGET_sh64 is not set
24# TARGET_sparc is not set
25# TARGET_v850 is not set
26# TARGET_vax is not set
27TARGET_x86_64=y
28
29#
30# Target Architecture Features and Options
31#
32TARGET_ARCH="x86_64"
33FORCE_OPTIONS_FOR_ARCH=y
34# CONFIG_GENERIC_386 is not set
35# CONFIG_386 is not set
36# CONFIG_486 is not set
37# CONFIG_586 is not set
38# CONFIG_586MMX is not set
39# CONFIG_686 is not set
40# CONFIG_PENTIUMII is not set
41# CONFIG_PENTIUMIII is not set
42# CONFIG_PENTIUM4 is not set
43# CONFIG_K6 is not set
44# CONFIG_K7 is not set
45# CONFIG_ELAN is not set
46# CONFIG_CRUSOE is not set
47# CONFIG_WINCHIPC6 is not set
48# CONFIG_WINCHIP2 is not set
49# CONFIG_CYRIXIII is not set
50# CONFIG_NEHEMIAH is not set
51TARGET_SUBARCH=""
52
53#
54# Using ELF file format
55#
56ARCH_LITTLE_ENDIAN=y
57
58#
59# Using Little Endian
60#
61ARCH_HAS_MMU=y
62ARCH_USE_MMU=y
63UCLIBC_HAS_FLOATS=y
64UCLIBC_HAS_FPU=y
65DO_C99_MATH=y
66KERNEL_HEADERS="/usr/include"
67HAVE_DOT_CONFIG=y
68
69UCLIBC_HAS_FENV=y
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/genericx86-64/xorg.conf
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 5756e4c219..c3968ef9cf 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,19 +1,23 @@
1KBRANCH_genericx86 = "standard/common-pc/base" 1KBRANCH_genericx86 = "standard/common-pc/base"
2KBRANCH_genericx86-64 = "standard/common-pc-64/base"
2KBRANCH_routerstationpro = "standard/routerstationpro" 3KBRANCH_routerstationpro = "standard/routerstationpro"
3KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb" 4KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
4KBRANCH_beagleboard = "standard/beagleboard" 5KBRANCH_beagleboard = "standard/beagleboard"
5 6
6KMACHINE_genericx86 ?= "common-pc" 7KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64"
7 9
8SRCREV_machine_genericx86 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0" 10SRCREV_machine_genericx86 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
11SRCREV_machine_genericx86-64 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
9SRCREV_machine_routerstationpro ?= "3991d03bd450e9363d5b6e97ede0628ba073db79" 12SRCREV_machine_routerstationpro ?= "3991d03bd450e9363d5b6e97ede0628ba073db79"
10SRCREV_machine_mpc8315e-rdb ?= "8d8339af518104db03f9c36b82f4372569e55b0a" 13SRCREV_machine_mpc8315e-rdb ?= "8d8339af518104db03f9c36b82f4372569e55b0a"
11SRCREV_machine_beagleboard ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0" 14SRCREV_machine_beagleboard ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
12 15
16COMPATIBLE_MACHINE_genericx86 = "genericx86"
17COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
13COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" 18COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
14COMPATIBLE_MACHINE_routerstationpro = "routerstationpro" 19COMPATIBLE_MACHINE_routerstationpro = "routerstationpro"
15COMPATIBLE_MACHINE_beagleboard = "beagleboard" 20COMPATIBLE_MACHINE_beagleboard = "beagleboard"
16COMPATIBLE_MACHINE_genericx86 = "genericx86"
17 21
18# routerstationpro has a flash size of 16mb 22# routerstationpro has a flash size of 16mb
19KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216" 23KERNEL_IMAGE_MAXSIZE_routerstationpro = "16777216"