summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-29 22:36:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-02 10:38:55 +0000
commite363c4007602e3578f0ae982785918d5e9d417bf (patch)
treee1509bbcd6ba613cbad6763a187a2c00b393c21a /meta-yocto-bsp
parent18b6b2ae819cbf0ef3858944b4cd02ab74df6607 (diff)
downloadpoky-e363c4007602e3578f0ae982785918d5e9d417bf.tar.gz
conf/machine: Remove mpc8315e-rdb machine
This hardware is old/obsolete and unobtainable. Its proving hard to support with nobody fixing bugs or helping keep the platform running/up to date. Whilst there is value in real hardware testing, this platform ist just too old and obsolete to support. This does leave a gap for the power architecture but at this point there is nobody willing to step up to cover it. The TSC did discuss and agree support for this platform should be removed. It calls into question the support/testing of the architecture by Yocto Project which is being discussed by the TSC and governing board. (From meta-yocto rev: aa691d49ceb6700eb1881b789fe34f8369bcb0ef) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/README.hardware142
-rw-r--r--meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf36
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.19.bbappend4
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend4
-rw-r--r--meta-yocto-bsp/wic/mpc8315e-rdb.wks4
6 files changed, 0 insertions, 192 deletions
diff --git a/meta-yocto-bsp/README.hardware b/meta-yocto-bsp/README.hardware
index d8d2a0cac6..5996be764c 100644
--- a/meta-yocto-bsp/README.hardware
+++ b/meta-yocto-bsp/README.hardware
@@ -28,7 +28,6 @@ Hardware Reference Boards
28The following boards are supported by the meta-yocto-bsp layer: 28The following boards are supported by the meta-yocto-bsp layer:
29 29
30 * Texas Instruments Beaglebone (beaglebone-yocto) 30 * Texas Instruments Beaglebone (beaglebone-yocto)
31 * Freescale MPC8315E-RDB (mpc8315e-rdb)
32 * Ubiquiti Networks EdgeRouter Lite (edgerouter) 31 * Ubiquiti Networks EdgeRouter Lite (edgerouter)
33 * General IA platforms (genericx86 and genericx86-64) 32 * General IA platforms (genericx86 and genericx86-64)
34 33
@@ -155,147 +154,6 @@ From a Linux system with access to the image files perform the following steps:
155 154
156 3. Insert the SD card into the Beaglebone and boot the board. 155 3. Insert the SD card into the Beaglebone and boot the board.
157 156
158Freescale MPC8315E-RDB (mpc8315e-rdb)
159=====================================
160
161The MPC8315 PowerPC reference platform (MPC8315E-RDB) is aimed at hardware and
162software development of network attached storage (NAS) and digital media server
163applications. The MPC8315E-RDB features the PowerQUICC II Pro processor, which
164includes a built-in security accelerator.
165
166(Note: you may find it easier to order MPC8315E-RDBA; this appears to be the
167same board in an enclosure with accessories. In any case it is fully
168compatible with the instructions given here.)
169
170Setup instructions
171------------------
172
173You will need the following:
174* NFS root setup on your workstation
175* TFTP server installed on your workstation
176* Straight-thru 9-conductor serial cable (DB9, M/F) connected from your
177 PC to UART1
178* Ethernet connected to the first ethernet port on the board
179
180--- Preparation ---
181
182Note: if you have altered your board's ethernet MAC address(es) from the
183defaults, or you need to do so because you want multiple boards on the same
184network, then you will need to change the values in the dts file (patch
185linux/arch/powerpc/boot/dts/mpc8315erdb.dts within the kernel source). If
186you have left them at the factory default then you shouldn't need to do
187anything here.
188
189Note: To boot from USB disk you need u-boot that supports 'ext2load usb'
190command. You need to setup TFTP server, load u-boot from there and
191flash it to NOR flash.
192
193Beware! Flashing bootloader is potentially dangerous operation that can
194brick your device if done incorrectly. Please, make sure you understand
195what below commands mean before executing them.
196
197Load the new u-boot.bin from TFTP server to memory address 200000
198=> tftp 200000 u-boot.bin
199
200Disable flash protection
201=> protect off all
202
203Erase the old u-boot from fe000000 to fe06ffff in NOR flash.
204The size is 0x70000 (458752 bytes)
205=> erase fe000000 fe06ffff
206
207Copy the new u-boot from address 200000 to fe000000
208the size is 0x70000. It has to be greater or equal to u-boot.bin size
209=> cp.b 200000 fe000000 70000
210
211Enable flash protection again
212=> protect on all
213
214Reset the board
215=> reset
216
217--- Booting from USB disk ---
218
219 1. Flash partitioned image to the USB disk
220
221 # dd if=core-image-minimal-mpc8315e-rdb.wic of=/dev/sdb
222
223 2. Plug USB disk into the MPC8315 board
224
225 3. Connect the board's first serial port to your workstation and then start up
226 your favourite serial terminal so that you will be able to interact with
227 the serial console. If you don't have a favourite, picocom is suggested:
228
229 $ picocom /dev/ttyUSB0 -b 115200
230
231 4. Power up or reset the board and press a key on the terminal when prompted
232 to get to the U-Boot command line
233
234 5. Optional. Load the u-boot.bin from the USB disk:
235
236 => usb start
237 => ext2load usb 0:1 200000 u-boot.bin
238
239 and flash it to NOR flash as described above.
240
241 6. Load the kernel and dtb from the first partition of the USB disk:
242
243 => usb start
244 => ext2load usb 0:1 1000000 uImage
245 => ext2load usb 0:1 2000000 dtb
246
247 7. Set bootargs and boot up the device
248
249 => setenv bootargs root=/dev/sdb2 rw rootwait console=ttyS0,115200
250 => bootm 1000000 - 2000000
251
252
253--- Booting from NFS root ---
254
255Load the kernel and dtb (device tree blob), and boot the system as follows:
256
257 1. Get the kernel (uImage-mpc8315e-rdb.bin) and dtb (uImage-mpc8315e-rdb.dtb)
258 files from the tmp/deploy directory, and make them available on your TFTP
259 server.
260
261 2. Connect the board's first serial port to your workstation and then start up
262 your favourite serial terminal so that you will be able to interact with
263 the serial console. If you don't have a favourite, picocom is suggested:
264
265 $ picocom /dev/ttyUSB0 -b 115200
266
267 3. Power up or reset the board and press a key on the terminal when prompted
268 to get to the U-Boot command line
269
270 4. Set up the environment in U-Boot:
271
272 => setenv ipaddr <board ip>
273 => setenv serverip <tftp server ip>
274 => setenv bootargs root=/dev/nfs rw nfsroot=<nfsroot ip>:<rootfs path> ip=<board ip>:<server ip>:<gateway ip>:255.255.255.0:mpc8315e:eth0:off console=ttyS0,115200
275
276 5. Download the kernel and dtb, and boot:
277
278 => tftp 1000000 uImage-mpc8315e-rdb.bin
279 => tftp 2000000 uImage-mpc8315e-rdb.dtb
280 => bootm 1000000 - 2000000
281
282--- Booting from JFFS2 root ---
283
284 1. First boot the board with NFS root.
285
286 2. Erase the MTD partition which will be used as root:
287
288 $ flash_eraseall /dev/mtd3
289
290 3. Copy the JFFS2 image to the MTD partition:
291
292 $ flashcp core-image-minimal-mpc8315e-rdb.jffs2 /dev/mtd3
293
294 4. Then reboot the board and set up the environment in U-Boot:
295
296 => setenv bootargs root=/dev/mtdblock3 rootfstype=jffs2 console=ttyS0,115200
297
298
299Ubiquiti Networks EdgeRouter Lite (edgerouter) 157Ubiquiti Networks EdgeRouter Lite (edgerouter)
300============================================== 158==============================================
301 159
diff --git a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
deleted file mode 100644
index 5382796284..0000000000
--- a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
+++ /dev/null
@@ -1,36 +0,0 @@
1#@TYPE: Machine
2#@NAME: Freescale MPC8315E-RDB
3#@DESCRIPTION: Machine configuration for Freescale MPC8315E-RDB
4
5TARGET_FPU = ""
6
7require conf/machine/include/tune-ppce300c3.inc
8
9KERNEL_IMAGETYPE = "uImage"
10
11EXTRA_IMAGEDEPENDS += "u-boot"
12UBOOT_MACHINE = "MPC8315ERDB_config"
13
14SERIAL_CONSOLES = "115200;ttyS0"
15
16MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"
17
18PREFERRED_VERSION_linux-yocto ?= "5.2%"
19PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
20
21PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
22XSERVER ?= "xserver-xorg \
23 xf86-video-fbdev"
24
25UBOOT_ENTRYPOINT = "0x00000000"
26
27KERNEL_DEVICETREE = "mpc8315erdb.dtb"
28
29MACHINE_EXTRA_RRECOMMENDS = "kernel-modules"
30
31IMAGE_FSTYPES ?= "jffs2 tar.bz2"
32JFFS2_ERASEBLOCK = "0x4000"
33
34IMAGE_FSTYPES += "wic wic.bmap"
35WKS_FILE ?= 'mpc8315e-rdb.wks'
36IMAGE_BOOT_FILES ?= "u-boot.bin uImage mpc8315erdb.dtb;dtb"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
index f044dafb4d..6e5a129dd4 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -2,7 +2,6 @@ KBRANCH_genericx86 = "standard/base"
2KBRANCH_genericx86-64 = "standard/base" 2KBRANCH_genericx86-64 = "standard/base"
3KBRANCH_edgerouter = "standard/edgerouter" 3KBRANCH_edgerouter = "standard/edgerouter"
4KBRANCH_beaglebone-yocto = "standard/beaglebone" 4KBRANCH_beaglebone-yocto = "standard/beaglebone"
5KBRANCH_mpc8315e-rdb = "standard/fsl-mpc8315e-rdb"
6 5
7KMACHINE_genericx86 ?= "common-pc" 6KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64" 7KMACHINE_genericx86-64 ?= "common-pc-64"
@@ -12,4 +11,3 @@ COMPATIBLE_MACHINE_genericx86 = "genericx86"
12COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 11COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
13COMPATIBLE_MACHINE_edgerouter = "edgerouter" 12COMPATIBLE_MACHINE_edgerouter = "edgerouter"
14COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" 13COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
15COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.19.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.19.bbappend
index ec269d905c..7b4bd2c4ee 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.19.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_4.19.bbappend
@@ -2,7 +2,6 @@ KBRANCH_genericx86 = "v4.19/standard/base"
2KBRANCH_genericx86-64 = "v4.19/standard/base" 2KBRANCH_genericx86-64 = "v4.19/standard/base"
3KBRANCH_edgerouter = "v4.19/standard/edgerouter" 3KBRANCH_edgerouter = "v4.19/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v4.19/standard/beaglebone" 4KBRANCH_beaglebone-yocto = "v4.19/standard/beaglebone"
5KBRANCH_mpc8315e-rdb = "v4.19/standard/fsl-mpc8315e-rdb"
6 5
7KMACHINE_genericx86 ?= "common-pc" 6KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64" 7KMACHINE_genericx86-64 ?= "common-pc-64"
@@ -12,16 +11,13 @@ SRCREV_machine_genericx86 ?= "5664dc14399edcaad210bbeb6343d84561fb3ea8"
12SRCREV_machine_genericx86-64 ?= "5664dc14399edcaad210bbeb6343d84561fb3ea8" 11SRCREV_machine_genericx86-64 ?= "5664dc14399edcaad210bbeb6343d84561fb3ea8"
13SRCREV_machine_edgerouter ?= "5664dc14399edcaad210bbeb6343d84561fb3ea8" 12SRCREV_machine_edgerouter ?= "5664dc14399edcaad210bbeb6343d84561fb3ea8"
14SRCREV_machine_beaglebone-yocto ?= "5664dc14399edcaad210bbeb6343d84561fb3ea8" 13SRCREV_machine_beaglebone-yocto ?= "5664dc14399edcaad210bbeb6343d84561fb3ea8"
15SRCREV_machine_mpc8315e-rdb ?= "d419f4ca6ba4b097b8ad710a93b89510f5b2998c"
16 14
17COMPATIBLE_MACHINE_genericx86 = "genericx86" 15COMPATIBLE_MACHINE_genericx86 = "genericx86"
18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 16COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
19COMPATIBLE_MACHINE_edgerouter = "edgerouter" 17COMPATIBLE_MACHINE_edgerouter = "edgerouter"
20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" 18COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
22 19
23LINUX_VERSION_genericx86 = "4.19.34" 20LINUX_VERSION_genericx86 = "4.19.34"
24LINUX_VERSION_genericx86-64 = "4.19.34" 21LINUX_VERSION_genericx86-64 = "4.19.34"
25LINUX_VERSION_edgerouter = "4.19.34" 22LINUX_VERSION_edgerouter = "4.19.34"
26LINUX_VERSION_beaglebone-yocto = "4.19.34" 23LINUX_VERSION_beaglebone-yocto = "4.19.34"
27LINUX_VERSION_mpc8315e-rdb = "4.19.34"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend
index f15bccbaf2..9a965321df 100644
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend
@@ -2,7 +2,6 @@ KBRANCH_genericx86 = "v5.2/standard/base"
2KBRANCH_genericx86-64 = "v5.2/standard/base" 2KBRANCH_genericx86-64 = "v5.2/standard/base"
3KBRANCH_edgerouter = "v5.2/standard/edgerouter" 3KBRANCH_edgerouter = "v5.2/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.2/standard/beaglebone" 4KBRANCH_beaglebone-yocto = "v5.2/standard/beaglebone"
5KBRANCH_mpc8315e-rdb = "v5.2/standard/fsl-mpc8315e-rdb"
6 5
7KMACHINE_genericx86 ?= "common-pc" 6KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64" 7KMACHINE_genericx86-64 ?= "common-pc-64"
@@ -12,16 +11,13 @@ SRCREV_machine_genericx86 ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
12SRCREV_machine_genericx86-64 ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94" 11SRCREV_machine_genericx86-64 ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
13SRCREV_machine_edgerouter ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94" 12SRCREV_machine_edgerouter ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
14SRCREV_machine_beaglebone-yocto ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94" 13SRCREV_machine_beaglebone-yocto ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
15SRCREV_machine_mpc8315e-rdb ?= "77f031b182885c177b3a96098ae61271911a7954"
16 14
17COMPATIBLE_MACHINE_genericx86 = "genericx86" 15COMPATIBLE_MACHINE_genericx86 = "genericx86"
18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" 16COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
19COMPATIBLE_MACHINE_edgerouter = "edgerouter" 17COMPATIBLE_MACHINE_edgerouter = "edgerouter"
20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" 18COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
22 19
23LINUX_VERSION_genericx86 = "5.2.17" 20LINUX_VERSION_genericx86 = "5.2.17"
24LINUX_VERSION_genericx86-64 = "5.2.17" 21LINUX_VERSION_genericx86-64 = "5.2.17"
25LINUX_VERSION_edgerouter = "5.2.17" 22LINUX_VERSION_edgerouter = "5.2.17"
26LINUX_VERSION_beaglebone-yocto = "5.2.17" 23LINUX_VERSION_beaglebone-yocto = "5.2.17"
27LINUX_VERSION_mpc8315e-rdb = "5.2.17"
diff --git a/meta-yocto-bsp/wic/mpc8315e-rdb.wks b/meta-yocto-bsp/wic/mpc8315e-rdb.wks
deleted file mode 100644
index d0cb607ffc..0000000000
--- a/meta-yocto-bsp/wic/mpc8315e-rdb.wks
+++ /dev/null
@@ -1,4 +0,0 @@
1# short-description: Create SD card image for MPC8315E-RDB
2# long-description: Create a partitioned SD card image for Freescale MPC8315E-RDB reference hardware.
3part /boot --source bootimg-partition --ondisk sdb --fstype=ext3 --label boot
4part / --source rootfs --ondisk sdb --fstype=ext3 --label root