summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2019-08-30 12:12:48 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-06 08:25:29 +0100
commit49f24df065c313ec85f4d326387895303f89247b (patch)
treeedf7b9c67eb6d44819a5b3e5ce553799e1b0e23b /meta-yocto-bsp
parent3f8d0969d12f42da636929b8e406b0a227eae0e1 (diff)
downloadpoky-49f24df065c313ec85f4d326387895303f89247b.tar.gz
meta-yocto-bsp: Bump to the v5.2 kernel
Boot test for all the supported boards. Also drop the v5.0 bbappend since we no plan to support it anymore. There are some kernel_configcheck warning when building some boards, the patches [1] for them have been sent to kernel-meta for merging. [1] https://lists.yoctoproject.org/pipermail/linux-yocto/2019-August/007908.html (From meta-yocto rev: c6e974e12c1d7fe0d155b6cf1bc0c1f4a6ee69d0) Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp')
-rw-r--r--meta-yocto-bsp/conf/machine/beaglebone-yocto.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/edgerouter.conf2
-rw-r--r--meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf2
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend27
-rw-r--r--meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend27
5 files changed, 30 insertions, 30 deletions
diff --git a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
index 57b799294d..08dd3a5074 100644
--- a/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
+++ b/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -24,7 +24,7 @@ SERIAL_CONSOLES ?= "115200;ttyS0 115200;ttyO0 115200;ttyAMA0"
24SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" 24SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
25 25
26PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 26PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
27PREFERRED_VERSION_linux-yocto ?= "5.0%" 27PREFERRED_VERSION_linux-yocto ?= "5.2%"
28 28
29KERNEL_IMAGETYPE = "zImage" 29KERNEL_IMAGETYPE = "zImage"
30KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb" 30KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb"
diff --git a/meta-yocto-bsp/conf/machine/edgerouter.conf b/meta-yocto-bsp/conf/machine/edgerouter.conf
index 88592dbc85..6331368f87 100644
--- a/meta-yocto-bsp/conf/machine/edgerouter.conf
+++ b/meta-yocto-bsp/conf/machine/edgerouter.conf
@@ -11,7 +11,7 @@ KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment" 11KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment"
12 12
13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 13PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
14PREFERRED_VERSION_linux-yocto ?= "5.0%" 14PREFERRED_VERSION_linux-yocto ?= "5.2%"
15 15
16SERIAL_CONSOLES = "115200;ttyS0" 16SERIAL_CONSOLES = "115200;ttyS0"
17USE_VT ?= "0" 17USE_VT ?= "0"
diff --git a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
index e2dce56738..5382796284 100644
--- a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
+++ b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
@@ -15,7 +15,7 @@ SERIAL_CONSOLES = "115200;ttyS0"
15 15
16MACHINE_FEATURES = "keyboard pci ext2 ext3 serial" 16MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"
17 17
18PREFERRED_VERSION_linux-yocto ?= "5.0%" 18PREFERRED_VERSION_linux-yocto ?= "5.2%"
19PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 19PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
20 20
21PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" 21PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend
deleted file mode 100644
index d7cf1216f4..0000000000
--- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend
+++ /dev/null
@@ -1,27 +0,0 @@
1KBRANCH_genericx86 = "v5.0/standard/base"
2KBRANCH_genericx86-64 = "v5.0/standard/base"
3KBRANCH_edgerouter = "v5.0/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.0/standard/beaglebone"
5KBRANCH_mpc8315e-rdb = "v5.0/standard/fsl-mpc8315e-rdb"
6
7KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64"
9KMACHINE_beaglebone-yocto ?= "beaglebone"
10
11SRCREV_machine_genericx86 ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4"
12SRCREV_machine_genericx86-64 ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4"
13SRCREV_machine_edgerouter ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4"
14SRCREV_machine_beaglebone-yocto ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4"
15SRCREV_machine_mpc8315e-rdb ?= "670ce7e9db627d0c2067cfdb571ddc1f117818d8"
16
17COMPATIBLE_MACHINE_genericx86 = "genericx86"
18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
19COMPATIBLE_MACHINE_edgerouter = "edgerouter"
20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
22
23LINUX_VERSION_genericx86 = "5.0.13"
24LINUX_VERSION_genericx86-64 = "5.0.13"
25LINUX_VERSION_edgerouter = "5.0.13"
26LINUX_VERSION_beaglebone-yocto = "5.0.13"
27LINUX_VERSION_mpc8315e-rdb = "5.0.13"
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend
new file mode 100644
index 0000000000..b7cefd25ca
--- /dev/null
+++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend
@@ -0,0 +1,27 @@
1KBRANCH_genericx86 = "v5.2/standard/base"
2KBRANCH_genericx86-64 = "v5.2/standard/base"
3KBRANCH_edgerouter = "v5.2/standard/edgerouter"
4KBRANCH_beaglebone-yocto = "v5.2/standard/beaglebone"
5KBRANCH_mpc8315e-rdb = "v5.2/standard/fsl-mpc8315e-rdb"
6
7KMACHINE_genericx86 ?= "common-pc"
8KMACHINE_genericx86-64 ?= "common-pc-64"
9KMACHINE_beaglebone-yocto ?= "beaglebone"
10
11SRCREV_machine_genericx86 ?= "77c28ea0e55cabb0b22b47d4eb2cc94b0940dfe6"
12SRCREV_machine_genericx86-64 ?= "35276d20c01a78ee3640a074446b0c15c486c5d0"
13SRCREV_machine_edgerouter ?= "35276d20c01a78ee3640a074446b0c15c486c5d0"
14SRCREV_machine_beaglebone-yocto ?= "77c28ea0e55cabb0b22b47d4eb2cc94b0940dfe6"
15SRCREV_machine_mpc8315e-rdb ?= "cae01d71ef67eaafec75ce24f49b038b705b8711"
16
17COMPATIBLE_MACHINE_genericx86 = "genericx86"
18COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64"
19COMPATIBLE_MACHINE_edgerouter = "edgerouter"
20COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto"
21COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb"
22
23LINUX_VERSION_genericx86 = "5.2.10"
24LINUX_VERSION_genericx86-64 = "5.2.10"
25LINUX_VERSION_edgerouter = "5.2.10"
26LINUX_VERSION_beaglebone-yocto = "5.2.10"
27LINUX_VERSION_mpc8315e-rdb = "5.2.10"