diff options
author | Kevin Hao <kexin.hao@windriver.com> | 2019-08-30 12:12:48 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-09-06 08:25:29 +0100 |
commit | 49f24df065c313ec85f4d326387895303f89247b (patch) | |
tree | edf7b9c67eb6d44819a5b3e5ce553799e1b0e23b /meta-yocto-bsp/recipes-kernel | |
parent | 3f8d0969d12f42da636929b8e406b0a227eae0e1 (diff) | |
download | poky-49f24df065c313ec85f4d326387895303f89247b.tar.gz |
meta-yocto-bsp: Bump to the v5.2 kernel
Boot test for all the supported boards. Also drop the v5.0 bbappend
since we no plan to support it anymore. There are some
kernel_configcheck warning when building some boards, the patches [1]
for them have been sent to kernel-meta for merging.
[1] https://lists.yoctoproject.org/pipermail/linux-yocto/2019-August/007908.html
(From meta-yocto rev: c6e974e12c1d7fe0d155b6cf1bc0c1f4a6ee69d0)
Signed-off-by: Kevin Hao <kexin.hao@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-kernel')
-rw-r--r-- | meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend | 27 | ||||
-rw-r--r-- | meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend | 27 |
2 files changed, 27 insertions, 27 deletions
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend deleted file mode 100644 index d7cf1216f4..0000000000 --- a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.0.bbappend +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | KBRANCH_genericx86 = "v5.0/standard/base" | ||
2 | KBRANCH_genericx86-64 = "v5.0/standard/base" | ||
3 | KBRANCH_edgerouter = "v5.0/standard/edgerouter" | ||
4 | KBRANCH_beaglebone-yocto = "v5.0/standard/beaglebone" | ||
5 | KBRANCH_mpc8315e-rdb = "v5.0/standard/fsl-mpc8315e-rdb" | ||
6 | |||
7 | KMACHINE_genericx86 ?= "common-pc" | ||
8 | KMACHINE_genericx86-64 ?= "common-pc-64" | ||
9 | KMACHINE_beaglebone-yocto ?= "beaglebone" | ||
10 | |||
11 | SRCREV_machine_genericx86 ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4" | ||
12 | SRCREV_machine_genericx86-64 ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4" | ||
13 | SRCREV_machine_edgerouter ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4" | ||
14 | SRCREV_machine_beaglebone-yocto ?= "f990fd0ce123aa6035042efad09b2ddc3e7d48f4" | ||
15 | SRCREV_machine_mpc8315e-rdb ?= "670ce7e9db627d0c2067cfdb571ddc1f117818d8" | ||
16 | |||
17 | COMPATIBLE_MACHINE_genericx86 = "genericx86" | ||
18 | COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" | ||
19 | COMPATIBLE_MACHINE_edgerouter = "edgerouter" | ||
20 | COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" | ||
21 | COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" | ||
22 | |||
23 | LINUX_VERSION_genericx86 = "5.0.13" | ||
24 | LINUX_VERSION_genericx86-64 = "5.0.13" | ||
25 | LINUX_VERSION_edgerouter = "5.0.13" | ||
26 | LINUX_VERSION_beaglebone-yocto = "5.0.13" | ||
27 | LINUX_VERSION_mpc8315e-rdb = "5.0.13" | ||
diff --git a/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend new file mode 100644 index 0000000000..b7cefd25ca --- /dev/null +++ b/meta-yocto-bsp/recipes-kernel/linux/linux-yocto_5.2.bbappend | |||
@@ -0,0 +1,27 @@ | |||
1 | KBRANCH_genericx86 = "v5.2/standard/base" | ||
2 | KBRANCH_genericx86-64 = "v5.2/standard/base" | ||
3 | KBRANCH_edgerouter = "v5.2/standard/edgerouter" | ||
4 | KBRANCH_beaglebone-yocto = "v5.2/standard/beaglebone" | ||
5 | KBRANCH_mpc8315e-rdb = "v5.2/standard/fsl-mpc8315e-rdb" | ||
6 | |||
7 | KMACHINE_genericx86 ?= "common-pc" | ||
8 | KMACHINE_genericx86-64 ?= "common-pc-64" | ||
9 | KMACHINE_beaglebone-yocto ?= "beaglebone" | ||
10 | |||
11 | SRCREV_machine_genericx86 ?= "77c28ea0e55cabb0b22b47d4eb2cc94b0940dfe6" | ||
12 | SRCREV_machine_genericx86-64 ?= "35276d20c01a78ee3640a074446b0c15c486c5d0" | ||
13 | SRCREV_machine_edgerouter ?= "35276d20c01a78ee3640a074446b0c15c486c5d0" | ||
14 | SRCREV_machine_beaglebone-yocto ?= "77c28ea0e55cabb0b22b47d4eb2cc94b0940dfe6" | ||
15 | SRCREV_machine_mpc8315e-rdb ?= "cae01d71ef67eaafec75ce24f49b038b705b8711" | ||
16 | |||
17 | COMPATIBLE_MACHINE_genericx86 = "genericx86" | ||
18 | COMPATIBLE_MACHINE_genericx86-64 = "genericx86-64" | ||
19 | COMPATIBLE_MACHINE_edgerouter = "edgerouter" | ||
20 | COMPATIBLE_MACHINE_beaglebone-yocto = "beaglebone-yocto" | ||
21 | COMPATIBLE_MACHINE_mpc8315e-rdb = "mpc8315e-rdb" | ||
22 | |||
23 | LINUX_VERSION_genericx86 = "5.2.10" | ||
24 | LINUX_VERSION_genericx86-64 = "5.2.10" | ||
25 | LINUX_VERSION_edgerouter = "5.2.10" | ||
26 | LINUX_VERSION_beaglebone-yocto = "5.2.10" | ||
27 | LINUX_VERSION_mpc8315e-rdb = "5.2.10" | ||