summaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-graphics
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 13:25:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 17:32:15 +0100
commit2000698b17011bbde1c3e5bb01a7d6763316db5a (patch)
tree5080d6d280487d6a8341c18ae56706e5157a0823 /meta-yocto-bsp/recipes-graphics
parent9d6630d1749486e38066650e1de5849c9524adbc (diff)
downloadpoky-2000698b17011bbde1c3e5bb01a7d6763316db5a.tar.gz
meta-yocto: Split into distro and bsp components
Now we have settled on best practises and compliance criteria, bring meta-yocto into compliance by separating out the hardware support components into meta-yocto-bsp leaving policy configuration in meta-yocto. Also rename the meta-yocto scripts directory to OE-Core can be a clearly isolated component in poky. (From meta-yocto rev: eac90e27a032ea23d9a4f35c7eef8b1940c80e22) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-graphics')
-rw-r--r--meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend3
-rw-r--r--meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_git.bbappend3
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/atom-pc/xorg.conf26
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf34
-rw-r--r--meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
5 files changed, 67 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend b/meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
new file mode 100644
index 0000000000..7e8e7732db
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
@@ -0,0 +1,3 @@
1# Atom PCs have DRI support so use mesa-dri by default
2DEFAULT_PREFERENCE_atom-pc = "2"
3
diff --git a/meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_git.bbappend b/meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_git.bbappend
new file mode 100644
index 0000000000..61d3891663
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/mesa/mesa-dri_git.bbappend
@@ -0,0 +1,3 @@
1# Atom PCs have DRI support so use mesa-dri by default
2DEFAULT_PREFERENCE_atom-pc = "1"
3
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/atom-pc/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/atom-pc/xorg.conf
new file mode 100644
index 0000000000..e18b911199
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/atom-pc/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Intel Graphics Driver"
3 Driver "intel"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Intel Graphics Driver"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf
new file mode 100644
index 0000000000..0335e6af76
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config/beagleboard/xorg.conf
@@ -0,0 +1,34 @@
1Section "Module"
2 Load "extmod"
3 Load "dbe"
4 Load "glx"
5 Load "freetype"
6 Load "type1"
7 Load "record"
8 Load "dri"
9EndSection
10
11Section "Monitor"
12 Identifier "Builtin Default Monitor"
13EndSection
14
15Section "Device"
16 Identifier "Builtin Default fbdev Device 0"
17 Driver "omapfb"
18EndSection
19
20Section "Screen"
21 Identifier "Builtin Default fbdev Screen 0"
22 Device "Builtin Default fbdev Device 0"
23 Monitor "Builtin Default Monitor"
24EndSection
25
26Section "ServerLayout"
27 Identifier "Builtin Default Layout"
28 Screen "Builtin Default fbdev Screen 0"
29EndSection
30
31Section "ServerFlags"
32 Option "DontZap" "0"
33 Option "AutoAddDevices" "False"
34EndSection
diff --git a/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 0000000000..72d991c7e5
--- /dev/null
+++ b/meta-yocto-bsp/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"