diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-09-05 13:25:58 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-09-05 17:32:15 +0100 |
commit | 2000698b17011bbde1c3e5bb01a7d6763316db5a (patch) | |
tree | 5080d6d280487d6a8341c18ae56706e5157a0823 /meta-yocto-bsp/recipes-core | |
parent | 9d6630d1749486e38066650e1de5849c9524adbc (diff) | |
download | poky-2000698b17011bbde1c3e5bb01a7d6763316db5a.tar.gz |
meta-yocto: Split into distro and bsp components
Now we have settled on best practises and compliance criteria, bring meta-yocto
into compliance by separating out the hardware support components into
meta-yocto-bsp leaving policy configuration in meta-yocto.
Also rename the meta-yocto scripts directory to OE-Core can be a clearly
isolated component in poky.
(From meta-yocto rev: eac90e27a032ea23d9a4f35c7eef8b1940c80e22)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-core')
5 files changed, 100 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-core/netbase/netbase-5.0/beagleboard/interfaces b/meta-yocto-bsp/recipes-core/netbase/netbase-5.0/beagleboard/interfaces new file mode 100644 index 0000000000..b6935c11af --- /dev/null +++ b/meta-yocto-bsp/recipes-core/netbase/netbase-5.0/beagleboard/interfaces | |||
@@ -0,0 +1,27 @@ | |||
1 | # /etc/network/interfaces -- configuration file for ifup(8), ifdown(8) | ||
2 | |||
3 | # The loopback interface | ||
4 | auto lo | ||
5 | iface lo inet loopback | ||
6 | |||
7 | # Wireless interfaces | ||
8 | iface wlan0 inet dhcp | ||
9 | wireless_mode managed | ||
10 | wireless_essid any | ||
11 | wpa-driver wext | ||
12 | wpa-conf /etc/wpa_supplicant.conf | ||
13 | |||
14 | iface atml0 inet dhcp | ||
15 | |||
16 | # Wired or wireless interfaces | ||
17 | auto eth0 | ||
18 | iface eth0 inet dhcp | ||
19 | iface eth1 inet dhcp | ||
20 | |||
21 | # Ethernet/RNDIS gadget (g_ether) or LAN9514 on BeagleBoard xM | ||
22 | auto usb0 | ||
23 | iface usb0 inet dhcp | ||
24 | |||
25 | # Bluetooth networking | ||
26 | iface bnep0 inet dhcp | ||
27 | |||
diff --git a/meta-yocto-bsp/recipes-core/netbase/netbase_5.0.bbappend b/meta-yocto-bsp/recipes-core/netbase/netbase_5.0.bbappend new file mode 100644 index 0000000000..56223033bd --- /dev/null +++ b/meta-yocto-bsp/recipes-core/netbase/netbase_5.0.bbappend | |||
@@ -0,0 +1 @@ | |||
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:" | |||
diff --git a/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend new file mode 100644 index 0000000000..352c1f9f22 --- /dev/null +++ b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | RDEPENDS_${PN}_append_atom-pc = " lttng-ust systemtap" | ||
2 | |||
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc/atom-pc/uClibc.machine b/meta-yocto-bsp/recipes-core/uclibc/uclibc/atom-pc/uClibc.machine new file mode 100644 index 0000000000..5df15f94cb --- /dev/null +++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc/atom-pc/uClibc.machine | |||
@@ -0,0 +1,69 @@ | |||
1 | # | ||
2 | # Automatically generated make config: don't edit | ||
3 | # Fri Nov 23 15:49:33 2007 | ||
4 | # | ||
5 | # TARGET_alpha is not set | ||
6 | # TARGET_arm is not set | ||
7 | # TARGET_bfin is not set | ||
8 | # TARGET_cris is not set | ||
9 | # TARGET_e1 is not set | ||
10 | # TARGET_frv is not set | ||
11 | # TARGET_h8300 is not set | ||
12 | # TARGET_hppa is not set | ||
13 | TARGET_i386=y | ||
14 | # TARGET_i960 is not set | ||
15 | # TARGET_ia64 is not set | ||
16 | # TARGET_m68k is not set | ||
17 | # TARGET_microblaze is not set | ||
18 | # TARGET_mips is not set | ||
19 | # TARGET_nios is not set | ||
20 | # TARGET_nios2 is not set | ||
21 | # TARGET_powerpc is not set | ||
22 | # TARGET_sh is not set | ||
23 | # TARGET_sh64 is not set | ||
24 | # TARGET_sparc is not set | ||
25 | # TARGET_v850 is not set | ||
26 | # TARGET_vax is not set | ||
27 | # TARGET_x86_64 is not set | ||
28 | |||
29 | # | ||
30 | # Target Architecture Features and Options | ||
31 | # | ||
32 | TARGET_ARCH="i386" | ||
33 | FORCE_OPTIONS_FOR_ARCH=y | ||
34 | CONFIG_GENERIC_386=y | ||
35 | # CONFIG_386 is not set | ||
36 | # CONFIG_486 is not set | ||
37 | # CONFIG_586 is not set | ||
38 | # CONFIG_586MMX is not set | ||
39 | # CONFIG_686 is not set | ||
40 | # CONFIG_PENTIUMII is not set | ||
41 | # CONFIG_PENTIUMIII is not set | ||
42 | # CONFIG_PENTIUM4 is not set | ||
43 | # CONFIG_K6 is not set | ||
44 | # CONFIG_K7 is not set | ||
45 | # CONFIG_ELAN is not set | ||
46 | # CONFIG_CRUSOE is not set | ||
47 | # CONFIG_WINCHIPC6 is not set | ||
48 | # CONFIG_WINCHIP2 is not set | ||
49 | # CONFIG_CYRIXIII is not set | ||
50 | # CONFIG_NEHEMIAH is not set | ||
51 | TARGET_SUBARCH="" | ||
52 | |||
53 | # | ||
54 | # Using ELF file format | ||
55 | # | ||
56 | ARCH_LITTLE_ENDIAN=y | ||
57 | |||
58 | # | ||
59 | # Using Little Endian | ||
60 | # | ||
61 | ARCH_HAS_MMU=y | ||
62 | ARCH_USE_MMU=y | ||
63 | UCLIBC_HAS_FLOATS=y | ||
64 | UCLIBC_HAS_FPU=y | ||
65 | DO_C99_MATH=y | ||
66 | KERNEL_HEADERS="/usr/include" | ||
67 | HAVE_DOT_CONFIG=y | ||
68 | |||
69 | UCLIBC_HAS_FENV=y | ||
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend b/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend new file mode 100644 index 0000000000..72d991c7e5 --- /dev/null +++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend | |||
@@ -0,0 +1 @@ | |||
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||