diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-09-05 13:25:58 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-09-05 17:32:15 +0100 |
commit | 2000698b17011bbde1c3e5bb01a7d6763316db5a (patch) | |
tree | 5080d6d280487d6a8341c18ae56706e5157a0823 /meta-yocto-bsp/conf | |
parent | 9d6630d1749486e38066650e1de5849c9524adbc (diff) | |
download | poky-2000698b17011bbde1c3e5bb01a7d6763316db5a.tar.gz |
meta-yocto: Split into distro and bsp components
Now we have settled on best practises and compliance criteria, bring meta-yocto
into compliance by separating out the hardware support components into
meta-yocto-bsp leaving policy configuration in meta-yocto.
Also rename the meta-yocto scripts directory to OE-Core can be a clearly
isolated component in poky.
(From meta-yocto rev: eac90e27a032ea23d9a4f35c7eef8b1940c80e22)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/conf')
-rw-r--r-- | meta-yocto-bsp/conf/layer.conf | 11 | ||||
-rw-r--r-- | meta-yocto-bsp/conf/machine/atom-pc.conf | 39 | ||||
-rw-r--r-- | meta-yocto-bsp/conf/machine/beagleboard.conf | 40 | ||||
-rw-r--r-- | meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf | 31 | ||||
-rw-r--r-- | meta-yocto-bsp/conf/machine/routerstationpro.conf | 26 |
5 files changed, 147 insertions, 0 deletions
diff --git a/meta-yocto-bsp/conf/layer.conf b/meta-yocto-bsp/conf/layer.conf new file mode 100644 index 0000000000..49fb135094 --- /dev/null +++ b/meta-yocto-bsp/conf/layer.conf | |||
@@ -0,0 +1,11 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH := "${BBPATH}:${LAYERDIR}" | ||
3 | |||
4 | # We have a packages directory, add to BBFILES | ||
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "yoctobsp" | ||
9 | BBFILE_PATTERN_yoctobsp := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_yoctobsp = "5" | ||
11 | |||
diff --git a/meta-yocto-bsp/conf/machine/atom-pc.conf b/meta-yocto-bsp/conf/machine/atom-pc.conf new file mode 100644 index 0000000000..46bc71b75d --- /dev/null +++ b/meta-yocto-bsp/conf/machine/atom-pc.conf | |||
@@ -0,0 +1,39 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: Atom-PC | ||
3 | |||
4 | #@DESCRIPTION: Machine configuration for Intel Atom based PCs. Currently supported machines are the Asus eee901, Acer Aspire One, Toshiba NB305, and Intel BlackSand development board. | ||
5 | |||
6 | include conf/machine/include/tune-atom.inc | ||
7 | |||
8 | MACHINE_FEATURES = "screen keyboard pci usbhost ext2 ext3 x86 wifi acpi alsa" | ||
9 | |||
10 | KERNEL_IMAGETYPE = "bzImage" | ||
11 | |||
12 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | ||
13 | PREFERRED_VERSION_linux-yocto ?= "3.0%" | ||
14 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" | ||
15 | XSERVER ?= "xserver-xorg \ | ||
16 | xserver-xorg-extension-dri2 \ | ||
17 | xserver-xorg-extension-glx \ | ||
18 | xserver-xorg-extension-extmod \ | ||
19 | xserver-xorg-extension-dbe \ | ||
20 | xf86-input-mouse \ | ||
21 | xf86-input-keyboard \ | ||
22 | xf86-input-evdev \ | ||
23 | xf86-input-synaptics \ | ||
24 | xf86-video-intel \ | ||
25 | mesa-dri-driver-i915" | ||
26 | |||
27 | #MACHINE_EXTRA_RDEPENDS = "rt2860" | ||
28 | |||
29 | MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts" | ||
30 | |||
31 | IMAGE_FSTYPES ?= "ext3 cpio.gz live" | ||
32 | |||
33 | APPEND += "usbcore.autosuspend=1" | ||
34 | |||
35 | GLIBC_ADDONS = "nptl" | ||
36 | |||
37 | EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi" | ||
38 | |||
39 | ROOTLESS_X = "1" | ||
diff --git a/meta-yocto-bsp/conf/machine/beagleboard.conf b/meta-yocto-bsp/conf/machine/beagleboard.conf new file mode 100644 index 0000000000..aa8fa07be4 --- /dev/null +++ b/meta-yocto-bsp/conf/machine/beagleboard.conf | |||
@@ -0,0 +1,40 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: Beagleboard machine | ||
3 | #@DESCRIPTION: Machine configuration for the http://beagleboard.org/ board | ||
4 | |||
5 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg-lite" | ||
6 | XSERVER ?= "xserver-xorg-lite \ | ||
7 | xf86-input-evdev \ | ||
8 | xf86-input-mouse \ | ||
9 | xf86-video-omapfb \ | ||
10 | xf86-input-keyboard" | ||
11 | |||
12 | # Ship all kernel modules by default | ||
13 | MACHINE_EXTRA_RRECOMMENDS = " kernel-modules" | ||
14 | |||
15 | # Allow for MMC booting (required by the NAND-less Beagleboard XM) | ||
16 | EXTRA_IMAGEDEPENDS += "u-boot x-load" | ||
17 | |||
18 | # Uncomment the following line to enable the hard floating point abi. Note that | ||
19 | # this breaks some binary libraries and 3D (neither of which ship with | ||
20 | # meta-yocto). For maximum compatibility, leave this disabled. | ||
21 | #DEFAULTTUNE ?= "cortexa8hf-neon" | ||
22 | include conf/machine/include/tune-cortexa8.inc | ||
23 | |||
24 | IMAGE_FSTYPES += "tar.bz2 jffs2" | ||
25 | EXTRA_IMAGECMD_jffs2 = "-lnp " | ||
26 | |||
27 | # 2.6.37 and later kernels use OMAP_SERIAL, ttyO2 | ||
28 | # earlier kernels use ttyS2 | ||
29 | SERIAL_CONSOLE = "115200 ttyO2" | ||
30 | |||
31 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | ||
32 | PREFERRED_VERSION_linux-yocto ?= "3.0%" | ||
33 | |||
34 | KERNEL_IMAGETYPE = "uImage" | ||
35 | |||
36 | UBOOT_MACHINE = "omap3_beagle_config" | ||
37 | UBOOT_ENTRYPOINT = "0x80008000" | ||
38 | UBOOT_LOADADDRESS = "0x80008000" | ||
39 | |||
40 | MACHINE_FEATURES = "apm usbgadget usbhost vfat alsa" | ||
diff --git a/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf new file mode 100644 index 0000000000..266f9d4978 --- /dev/null +++ b/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf | |||
@@ -0,0 +1,31 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@DESCRIPTION: Machine configuration for running | ||
3 | |||
4 | TARGET_FPU = "" | ||
5 | |||
6 | require conf/machine/include/tune-ppc603e.inc | ||
7 | |||
8 | KERNEL_IMAGETYPE = "uImage" | ||
9 | |||
10 | EXTRA_IMAGEDEPENDS += "u-boot" | ||
11 | UBOOT_MACHINE_mpc8315e-rdb = "MPC8315ERDB_config" | ||
12 | |||
13 | SERIAL_CONSOLE = "115200 ttyS0" | ||
14 | |||
15 | MACHINE_FEATURES = "keyboard pci ext2 ext3 serial" | ||
16 | |||
17 | PREFERRED_VERSION_linux-yocto ?= "3.4%" | ||
18 | PREFERRED_PROVIDER_virtual/kernel = "linux-yocto" | ||
19 | |||
20 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" | ||
21 | XSERVER ?= "xserver-xorg \ | ||
22 | xserver-xorg-extension-extmod \ | ||
23 | xf86-input-evdev \ | ||
24 | xf86-video-fbdev" | ||
25 | |||
26 | PREFERRED_VERSION_u-boot ?= "v2012.04%" | ||
27 | UBOOT_ENTRYPOINT = "0x00000000" | ||
28 | |||
29 | KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/mpc8315erdb.dts" | ||
30 | |||
31 | MACHINE_EXTRA_RRECOMMENDS = " kernel-modules" | ||
diff --git a/meta-yocto-bsp/conf/machine/routerstationpro.conf b/meta-yocto-bsp/conf/machine/routerstationpro.conf new file mode 100644 index 0000000000..707392d0c8 --- /dev/null +++ b/meta-yocto-bsp/conf/machine/routerstationpro.conf | |||
@@ -0,0 +1,26 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: mti_malta32_be MIPS | ||
3 | #@DESCRIPTION: mti_malta32_be | ||
4 | |||
5 | require conf/machine/include/tune-mips32.inc | ||
6 | |||
7 | MACHINE_FEATURES = "screen keyboard pci usbhost ext2 ext3 serial" | ||
8 | |||
9 | KERNEL_IMAGETYPE = "vmlinux" | ||
10 | KERNEL_ALT_IMAGETYPE = "vmlinux.bin" | ||
11 | |||
12 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | ||
13 | PREFERRED_VERSION_linux-yocto ?= "3.4%" | ||
14 | |||
15 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" | ||
16 | XSERVER ?= "xserver-xorg \ | ||
17 | xserver-xorg-extension-extmod \ | ||
18 | xf86-input-evdev \ | ||
19 | xf86-video-fbdev" | ||
20 | |||
21 | SERIAL_CONSOLE = "115200 ttyS0" | ||
22 | |||
23 | MACHINE_EXTRA_RRECOMMENDS = " kernel-modules" | ||
24 | |||
25 | IMAGE_FSTYPES ?= "jffs2 tar.bz2" | ||
26 | |||