summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-21 15:50:00 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-25 05:58:19 -0800
commit7c57659ccf68e2aa6151b6fddd640a46e52d81dd (patch)
treebd8bcd8a242a1bfa9acc22af71d78c597f55e55f /meta-skeleton
parent8918247ead32d1f2423c6b419a19801ad1e8173d (diff)
downloadpoky-7c57659ccf68e2aa6151b6fddd640a46e52d81dd.tar.gz
meta-skeleton: Add example multilib usages
(From OE-Core rev: 514b0ab066bebd52980467e935c0e5df9e480db4) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/conf/multilib-example.conf13
-rw-r--r--meta-skeleton/conf/multilib-example2.conf13
-rw-r--r--meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb13
3 files changed, 39 insertions, 0 deletions
diff --git a/meta-skeleton/conf/multilib-example.conf b/meta-skeleton/conf/multilib-example.conf
new file mode 100644
index 0000000000..da6da7f1f6
--- /dev/null
+++ b/meta-skeleton/conf/multilib-example.conf
@@ -0,0 +1,13 @@
1#
2# Sample multilib configuration which the user can either add in local.conf
3# or specific in an configuration file like this, then require it.
4#
5# This configuration specifies an x86 64 bit machine as the main machine
6# type and then adds a multilib in the "lib32" directory where those
7# libraries are compiled with the "x86" tune.
8#
9
10MACHINE = "qemux86-64"
11require conf/multilib.conf
12MULTILIBS = "multilib:lib32"
13DEFAULTTUNE_virtclass-multilib-lib32 = "x86"
diff --git a/meta-skeleton/conf/multilib-example2.conf b/meta-skeleton/conf/multilib-example2.conf
new file mode 100644
index 0000000000..2596f61d9f
--- /dev/null
+++ b/meta-skeleton/conf/multilib-example2.conf
@@ -0,0 +1,13 @@
1#
2# Sample multilib configuration which the user can either add in local.conf
3# or specific in an configuration file like this, then require it.
4#
5# This configuration specifies an x86 64 bit machine as the main machine
6# type and then adds a multilib in the "libx32" directory where those
7# libraries are compiled with the "x86-64-x32" tune.
8#
9
10MACHINE = "qemux86-64"
11require conf/multilib.conf
12MULTILIBS = "multilib:libx32"
13DEFAULTTUNE_virtclass-multilib-libx32 = "x86-64-x32"
diff --git a/meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb b/meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb
new file mode 100644
index 0000000000..7703731750
--- /dev/null
+++ b/meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb
@@ -0,0 +1,13 @@
1#
2# An example of a multilib image
3#
4# This example includes a lib32 version of bash into an otherwise standard
5# sato image. It assumes a "lib32" multilib has been enabled in the user's
6# configuration (see the example conf files for examples of this.)
7#
8
9# First include a base image to base things off
10require recipes-core/images/core-image-sato.bb
11
12# Now add the multilib packages we want to install
13IMAGE_INSTALL += "lib32-bash"