summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-05-11 15:11:16 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-24 07:19:17 +0100
commit203eadfc04eca37b5e21c073e99ec19732ef6e9b (patch)
tree9ed92bdcbd6466e7be03183fa2ff881810e008e6 /meta-skeleton
parentf92f3369eea8dbea45513f80a22fc233ffe59156 (diff)
downloadpoky-203eadfc04eca37b5e21c073e99ec19732ef6e9b.tar.gz
linux-yocto-custom: clarify bbappend versus copy in comments
The kernel development manual recommends making a copy of linux-yocto-custom, while the comments in the recipe talk about bbappends. To synchronize the two, we remove the bbappend references from the recipe and instead indicate that a copy should be updated. [YOCTO: #6925] (From OE-Core rev: 121498714b03339d2e5090c2a8fe0618bbaa8610) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
index 05463c0263..cce44d9995 100644
--- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
+++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
@@ -11,8 +11,8 @@
11# 11#
12# You must also provide a Linux kernel configuration. The most direct 12# You must also provide a Linux kernel configuration. The most direct
13# method is to copy your .config to files/defconfig in your layer, 13# method is to copy your .config to files/defconfig in your layer,
14# in the same directory as the bbappend and add file://defconfig to 14# in the same directory as the copy (and rename) of this recipe and
15# your SRC_URI. 15# add file://defconfig to your SRC_URI.
16# 16#
17# To use the yocto kernel tooling to generate a BSP configuration 17# To use the yocto kernel tooling to generate a BSP configuration
18# using modular configuration fragments, see the yocto-bsp and 18# using modular configuration fragments, see the yocto-bsp and
@@ -52,14 +52,14 @@
52inherit kernel 52inherit kernel
53require recipes-kernel/linux/linux-yocto.inc 53require recipes-kernel/linux/linux-yocto.inc
54 54
55# Override SRC_URI in a bbappend file to point at a different source 55# Override SRC_URI in a copy of this recipe to point at a different source
56# tree if you do not want to build from Linus' tree. 56# tree if you do not want to build from Linus' tree.
57SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" 57SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine"
58 58
59LINUX_VERSION ?= "3.4" 59LINUX_VERSION ?= "3.4"
60LINUX_VERSION_EXTENSION ?= "-custom" 60LINUX_VERSION_EXTENSION ?= "-custom"
61 61
62# Override SRCREV to point to a different commit in a bbappend file to 62# Modify SRCREV to a different commit hash in a copy of this recipe to
63# build a different release of the Linux kernel. 63# build a different release of the Linux kernel.
64# tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc 64# tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc
65SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc" 65SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc"
@@ -67,6 +67,6 @@ SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc"
67PR = "r1" 67PR = "r1"
68PV = "${LINUX_VERSION}+git${SRCPV}" 68PV = "${LINUX_VERSION}+git${SRCPV}"
69 69
70# Override COMPATIBLE_MACHINE to include your machine in a bbappend 70# Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe
71# file. Leaving it empty here ensures an early explicit build failure. 71# file. Leaving it empty here ensures an early explicit build failure.
72COMPATIBLE_MACHINE = "(^$)" 72COMPATIBLE_MACHINE = "(^$)"