diff options
author | Chen Qi <Qi.Chen@windriver.com> | 2022-09-28 01:44:48 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-09-29 21:15:50 +0100 |
commit | d96f13c40343b99818dfc692e87351865d9c85ba (patch) | |
tree | 911477352f51789881b7efb47117c4c2497194d5 /meta-skeleton | |
parent | 569d4cd3257ec26c63489d2b016bfac83a5fa244 (diff) | |
download | poky-d96f13c40343b99818dfc692e87351865d9c85ba.tar.gz |
useradd-example: do not use unsupported clear text password
The clear text password support has been dropped. So let's just
use a normal ecrypted one. The password remains to be 'user3'.
(From OE-Core rev: cd8232f9c58980d95180ad320b7b0bb0fcfd9ff5)
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r-- | meta-skeleton/recipes-skeleton/useradd/useradd-example.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb index 3f4c42d714..cff624e2f9 100644 --- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb +++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb | |||
@@ -33,8 +33,8 @@ USERADD_PACKAGES = "${PN} ${PN}-user3" | |||
33 | USERADD_PARAM:${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2" | 33 | USERADD_PARAM:${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2" |
34 | 34 | ||
35 | # user3 will be managed in the useradd-example-user3 pacakge: | 35 | # user3 will be managed in the useradd-example-user3 pacakge: |
36 | # As an example, we use the -P option to set clear text password for user3 | 36 | # As an example, we use the -p option to set password ('user3') for user3 |
37 | USERADD_PARAM:${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3" | 37 | USERADD_PARAM:${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -p '\$6\$XAWr.8nc\$bUE4pYYaVb8n6BbnBitU0zeJMtfhTpFpiOBLL9zRl4e4YQo88UU4r/1kjRzmTimCy.BvDh4xoFwVqcO.pihLa1' user3" |
38 | 38 | ||
39 | # GROUPADD_PARAM works the same way, which you set to the options | 39 | # GROUPADD_PARAM works the same way, which you set to the options |
40 | # you'd normally pass to the groupadd command. This will create | 40 | # you'd normally pass to the groupadd command. This will create |