diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2012-06-11 16:21:12 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-06-18 13:24:56 +0100 |
commit | 21bd4552d63659ac68936bd18ed8013d6783d02c (patch) | |
tree | e74b2e64d670d72da451bbe898dbc504399fed59 /meta-skeleton | |
parent | eda6a522d1e0d9c8854d8d044035066c1eb08624 (diff) | |
download | poky-21bd4552d63659ac68936bd18ed8013d6783d02c.tar.gz |
meta-skeleton: add linux-yocto-custom reference recipe
Adding a skeleton/refrence recipe for using a subset of the yocto
kernel tools against kernel git repositories.
Sample/reference configuration fragments, features and a patch are
provided and documented in the recipe.
From the recipe itself:
Provides an example/minimal kernel recipe that uses the linux-yocto
and oe-core kernel classes to apply a subset of yocto kernel
management to git managed kernel repositories.
Notes:
kconfig(s): the kernel must be configured with a defconfig, or via
configuration fragment(s). Either of these can be added
via bbappend.
patches: patches can be merged into to the source git tree itself, added
using standard bbappend syntax or controlled via .scc feature
descriptions (also via bbappends)
example configuration addition:
SRC_URI += "file://smp.cfg"
example patch addition (for kernel v3.4 only):
SRC_URI += "file://0001-linux-version-tweak.patch
example feature addition (for kernel v3.4 only):
SRC_URI += "file://feature.scc"
Warning:
Building the sample kernel tree (kernel.org) without providing any
configuration will result in build or boot errors. This is not a bug
it is a required element for creating a valid kernel.
[YOCTO #2397]
(From OE-Core rev: 4b6f29ddb00480896f47d96ea376f3a6f6d8451e)
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
4 files changed, 74 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb new file mode 100644 index 0000000000..1438ad84d6 --- /dev/null +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | # linux-yocto-custom.bb: | ||
2 | # | ||
3 | # Provides an example/minimal kernel recipe that uses the linux-yocto | ||
4 | # and oe-core kernel classes to apply a subset of yocto kernel | ||
5 | # management to git managed kernel repositories. | ||
6 | # | ||
7 | # Notes: | ||
8 | # | ||
9 | # kconfig(s): the kernel must be configured with a defconfig, or via | ||
10 | # configuration fragment(s). Either of these can be added | ||
11 | # via bbappend. | ||
12 | # patches: patches can be merged into to the source git tree itself, added | ||
13 | # using standard bbappend syntax or controlled via .scc feature | ||
14 | # descriptions (also via bbappends) | ||
15 | # | ||
16 | # example configuration addition: | ||
17 | # SRC_URI += "file://smp.cfg" | ||
18 | # example patch addition (for kernel v3.4 only): | ||
19 | # SRC_URI += "file://0001-linux-version-tweak.patch | ||
20 | # example feature addition (for kernel v3.4 only): | ||
21 | # SRC_URI += "file://feature.scc" | ||
22 | # | ||
23 | # Warning: | ||
24 | # | ||
25 | # Building the sample kernel tree (kernel.org) without providing any | ||
26 | # configuration will result in build or boot errors. This is not a bug | ||
27 | # it is a required element for creating a valid kernel. | ||
28 | # | ||
29 | |||
30 | inherit kernel | ||
31 | require recipes-kernel/linux/linux-yocto.inc | ||
32 | |||
33 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1" | ||
34 | |||
35 | LINUX_VERSION ?= "3.4" | ||
36 | LINUX_VERSION_EXTENSION ?= "-custom" | ||
37 | |||
38 | # tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc | ||
39 | SRCREV="76e10d158efb6d4516018846f60c2ab5501900bc" | ||
40 | |||
41 | PR = "r0" | ||
42 | PV = "${LINUX_VERSION}+git${SRCPV}" | ||
43 | |||
44 | COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)" | ||
45 | |||
46 | require recipes-kernel/linux/linux-tools.inc | ||
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch new file mode 100644 index 0000000000..c9562da10d --- /dev/null +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 5a55943a6bbb10a79994a0b18071b2427dffb15f Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@windriver.com> | ||
3 | Date: Mon, 11 Jun 2012 15:31:42 -0400 | ||
4 | Subject: [PATCH] linux: version tweak | ||
5 | |||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> | ||
7 | --- | ||
8 | Makefile | 2 +- | ||
9 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index a687963..f5b1ac3 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -2,7 +2,7 @@ VERSION = 3 | ||
16 | PATCHLEVEL = 4 | ||
17 | SUBLEVEL = 0 | ||
18 | EXTRAVERSION = | ||
19 | -NAME = Saber-toothed Squirrel | ||
20 | +NAME = Saber-toothed Squirrel-custom | ||
21 | |||
22 | # *DOCUMENTATION* | ||
23 | # To see a list of typical targets execute "make help" | ||
24 | -- | ||
25 | 1.7.5.4 | ||
26 | |||
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/feature.scc b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/feature.scc new file mode 100644 index 0000000000..aad5af49f1 --- /dev/null +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/feature.scc | |||
@@ -0,0 +1 @@ | |||
patch 0001-linux-version-tweak.patch | |||
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/smp.cfg b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/smp.cfg new file mode 100644 index 0000000000..0c26a86262 --- /dev/null +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/smp.cfg | |||
@@ -0,0 +1 @@ | |||
# CONFIG_SMP is not set | |||