summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro@enedino.org>2020-04-27 15:33:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-29 15:02:19 +0100
commit48a8eb0fc207d4e97f8d5d43bda4600767b5a07b (patch)
tree963fa5d2c13b31de30107078e5947c2bc41a2023 /meta-skeleton
parent87a2e7c43d463a0b2ecc48a8a45a1954cf68c0a8 (diff)
downloadpoky-48a8eb0fc207d4e97f8d5d43bda4600767b5a07b.tar.gz
baremetal-helloworld: Fix IMGDEPLOYDIR expansion
IMGDEPLOYDIR is not being expanded anymore, this causes do_rootfs to fail because it can't create the manifest file, we can set it to the default being set on image.bbclass since this is only a decoy function anyway to satisfy testimage, this makes do_rootfs happy and allows it to continue. (From OE-Core rev: 06ed491e30b47b8c5f89746e890519dd7de800fd) Signed-off-by: Alejandro Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Alejandro Hernandez Samaniego <alhe@linux.microsoft.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
index d8633702fc..e84a90f28c 100644
--- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
@@ -37,6 +37,7 @@ do_install(){
37# Borrowed from meta-freertos 37# Borrowed from meta-freertos
38inherit rootfs-postcommands 38inherit rootfs-postcommands
39inherit deploy 39inherit deploy
40IMGDEPLOYDIR ?= "${WORKDIR}/deploy-${PN}-image-complete"
40do_deploy[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}" 41do_deploy[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}"
41do_rootfs[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}" 42do_rootfs[dirs] = "${DEPLOYDIR} ${DEPLOY_DIR_IMAGE}"
42DEPLOYDIR = "${IMGDEPLOYDIR}" 43DEPLOYDIR = "${IMGDEPLOYDIR}"