summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2018-04-05 16:11:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-07 11:44:50 +0100
commit5264dbd39d082a2a2f68b5506cff6761fc936cdf (patch)
treec615c68532e7f2f777f335904a4644aa34da5240 /meta-skeleton
parent7a39dc3996dc445c83ac1665e9099e1244cf396d (diff)
downloadpoky-5264dbd39d082a2a2f68b5506cff6761fc936cdf.tar.gz
hello-mod_0.1.bb: add RPROVIDES
Although the package will get an automatic prefix "kernel-module", so the package kernel-module-hello does exist, populating rootfs can generate an error: - nothing provides kernel-module-hello ... This is quite unfortunate, as this recipe is used as a sample. Adding RPROVIDES_${PN} += "kernel-module-hello" to the recipe fixes the problem. [YOCTO #12641] (From OE-Core rev: ca17a7bbea5f5454da43545d544ff7772d83ac19) Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
index b140b0ac8e..3d33446500 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -13,3 +13,5 @@ S = "${WORKDIR}"
13 13
14# The inherit of module.bbclass will automatically name module packages with 14# The inherit of module.bbclass will automatically name module packages with
15# "kernel-module-" prefix as required by the oe-core build environment. 15# "kernel-module-" prefix as required by the oe-core build environment.
16
17RPROVIDES_${PN} += "kernel-module-hello"