summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-08-05 09:42:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:47:03 +0100
commit0f425669b716e7aaa7e5ebc675e7987df3accee6 (patch)
tree9cce10266ed8163df44cb4726d1c7a6f87ffe6cf /meta-skeleton
parentfde9969f0a406c093b5a56379e5703bb4934d4e1 (diff)
downloadpoky-0f425669b716e7aaa7e5ebc675e7987df3accee6.tar.gz
service: tweak example recipe
* Drop PR = "r0" * Reorder lines so that packaging definitions are at the end (From OE-Core rev: e6cf787871518119205c7d764f5478fd853e2576) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index a3ad6ccb2f..c5cd7a97bc 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -2,16 +2,12 @@ SUMMARY = "The canonical example of init scripts"
2SECTION = "base" 2SECTION = "base"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4" 4LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
5RDEPENDS_${PN} = "initscripts"
6PR = "r0"
7 5
8SRC_URI = "file://skeleton \ 6SRC_URI = "file://skeleton \
9 file://skeleton_test.c \ 7 file://skeleton_test.c \
10 file://COPYRIGHT \ 8 file://COPYRIGHT \
11 " 9 "
12 10
13CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"
14
15do_compile () { 11do_compile () {
16 ${CC} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test 12 ${CC} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
17} 13}
@@ -30,3 +26,6 @@ do_install () {
30 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ 26 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
31} 27}
32 28
29RDEPENDS_${PN} = "initscripts"
30
31CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"