diff options
author | Saul Wold <sgw@linux.intel.com> | 2015-09-28 10:12:57 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-10-01 07:43:34 +0100 |
commit | 34707c21a0ebe1d5b5563eb5f2d31ac985b8e902 (patch) | |
tree | 3dd3674449e95084b58eab86de5343fbd0fbe03e /meta-skeleton/recipes-kernel | |
parent | df09a6f4e30ae66db69a3d5e7ce2b5488b68e60b (diff) | |
download | poky-34707c21a0ebe1d5b5563eb5f2d31ac985b8e902.tar.gz |
linux-yocto-custom: Update for newer kernel
Update the NAME version tweak example patch for the
newer kernel. This moves the example to the 4.2 stable
kernel and appends -custom to the VERSION string.
(From OE-Core rev: dc26472661bdc0ed4248d7ab462a296f3c86c421)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton/recipes-kernel')
-rw-r--r-- | meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb | 15 | ||||
-rw-r--r-- | meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch | 21 |
2 files changed, 19 insertions, 17 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb index cce44d9995..6194d4f8da 100644 --- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb | |||
@@ -43,9 +43,9 @@ | |||
43 | # | 43 | # |
44 | # example configuration addition: | 44 | # example configuration addition: |
45 | # SRC_URI += "file://smp.cfg" | 45 | # SRC_URI += "file://smp.cfg" |
46 | # example patch addition (for kernel v3.4 only): | 46 | # example patch addition (for kernel v4.x only): |
47 | # SRC_URI += "file://0001-linux-version-tweak.patch | 47 | # SRC_URI += "file://0001-linux-version-tweak.patch" |
48 | # example feature addition (for kernel v3.4 only): | 48 | # example feature addition (for kernel v4.x only): |
49 | # SRC_URI += "file://feature.scc" | 49 | # SRC_URI += "file://feature.scc" |
50 | # | 50 | # |
51 | 51 | ||
@@ -56,15 +56,14 @@ require recipes-kernel/linux/linux-yocto.inc | |||
56 | # tree if you do not want to build from Linus' tree. | 56 | # tree if you do not want to build from Linus' tree. |
57 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" | 57 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" |
58 | 58 | ||
59 | LINUX_VERSION ?= "3.4" | 59 | LINUX_VERSION ?= "4.2" |
60 | LINUX_VERSION_EXTENSION ?= "-custom" | 60 | LINUX_VERSION_EXTENSION_append = "-custom" |
61 | 61 | ||
62 | # Modify SRCREV to a different commit hash in a copy of this recipe to | 62 | # Modify SRCREV to a different commit hash in a copy of this recipe to |
63 | # build a different release of the Linux kernel. | 63 | # build a different release of the Linux kernel. |
64 | # tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc | 64 | # tag: v4.2 64291f7db5bd8150a74ad2036f1037e6a0428df2 |
65 | SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc" | 65 | SRCREV_machine="64291f7db5bd8150a74ad2036f1037e6a0428df2" |
66 | 66 | ||
67 | PR = "r1" | ||
68 | PV = "${LINUX_VERSION}+git${SRCPV}" | 67 | PV = "${LINUX_VERSION}+git${SRCPV}" |
69 | 68 | ||
70 | # Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe | 69 | # Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe |
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch index c9562da10d..39c7ee8d2d 100644 --- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom/0001-linux-version-tweak.patch | |||
@@ -1,26 +1,29 @@ | |||
1 | From 5a55943a6bbb10a79994a0b18071b2427dffb15f Mon Sep 17 00:00:00 2001 | 1 | From fb2c401374d4efe89e8da795e21d96fac038639d Mon Sep 17 00:00:00 2001 |
2 | From: Bruce Ashfield <bruce.ashfield@windriver.com> | 2 | From: Bruce Ashfield <bruce.ashfield@windriver.com> |
3 | Date: Mon, 11 Jun 2012 15:31:42 -0400 | 3 | Date: Mon, 11 Jun 2012 15:31:42 -0400 |
4 | Subject: [PATCH] linux: version tweak | 4 | Subject: [PATCH] linux: version tweak |
5 | 5 | ||
6 | Upstream-Status: Inapproriate [example code] | ||
7 | |||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> | 8 | Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> |
9 | Signed-off-by: Saul Wold <sgw@linux.intel.com> | ||
7 | --- | 10 | --- |
8 | Makefile | 2 +- | 11 | Makefile | 2 +- |
9 | 1 files changed, 1 insertions(+), 1 deletions(-) | 12 | 1 file changed, 1 insertion(+), 1 deletion(-) |
10 | 13 | ||
11 | diff --git a/Makefile b/Makefile | 14 | diff --git a/Makefile b/Makefile |
12 | index a687963..f5b1ac3 100644 | 15 | index c361593..099e8ff 100644 |
13 | --- a/Makefile | 16 | --- a/Makefile |
14 | +++ b/Makefile | 17 | +++ b/Makefile |
15 | @@ -2,7 +2,7 @@ VERSION = 3 | 18 | @@ -2,7 +2,7 @@ VERSION = 4 |
16 | PATCHLEVEL = 4 | 19 | PATCHLEVEL = 2 |
17 | SUBLEVEL = 0 | 20 | SUBLEVEL = 0 |
18 | EXTRAVERSION = | 21 | EXTRAVERSION = |
19 | -NAME = Saber-toothed Squirrel | 22 | -NAME = Hurr durr I'ma sheep |
20 | +NAME = Saber-toothed Squirrel-custom | 23 | +NAME = Hurr durr I'ma customized sheep |
21 | 24 | ||
22 | # *DOCUMENTATION* | 25 | # *DOCUMENTATION* |
23 | # To see a list of typical targets execute "make help" | 26 | # To see a list of typical targets execute "make help" |
24 | -- | 27 | -- |
25 | 1.7.5.4 | 28 | 2.1.4 |
26 | 29 | ||