summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-04-09 15:19:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-10 13:32:02 +0100
commitadc13fc9254244be7d6be16623b0420b64ef7814 (patch)
tree596b866f1bcd8a414e4553ebaed1c5b9acf0457e /meta-skeleton/recipes-kernel/hello-mod/files/Makefile
parent13d62101f6880689ef79804bf1743ef15655d049 (diff)
downloadpoky-adc13fc9254244be7d6be16623b0420b64ef7814.tar.gz
hello-mod: Move hello-mod from meta to meta-skeleton
Fixes [YOCTO #1501] hello-mod is an example kernel module, and does not provide any real functionality. As such, it would be better placed under meta-skeleton than meta. (From OE-Core rev: bde1744018afd4616e114b20ffdc21b9abddcedc) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton/recipes-kernel/hello-mod/files/Makefile')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/files/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/files/Makefile b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
new file mode 100644
index 0000000000..4ded35fbc3
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
@@ -0,0 +1,14 @@
1obj-m := hello.o
2
3SRC := $(shell pwd)
4
5all:
6 $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
7
8modules_install:
9 $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
10
11clean:
12 rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
13 rm -f Module.markers Module.symvers modules.order
14 rm -rf .tmp_versions Modules.symvers