summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:38:32 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2013-12-12 13:50:20 +0100
commite2e6f6fe07049f33cb6348780fa975162752e421 (patch)
treeb1813295411235d1297a0ed642b1346b24fdfb12 /meta-skeleton/recipes-kernel/hello-mod/files/Makefile
downloadpoky-e2e6f6fe07049f33cb6348780fa975162752e421.tar.gz
initial commit of Enea Linux 3.1
Migrated from the internal git server on the dora-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta-skeleton/recipes-kernel/hello-mod/files/Makefile')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/files/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/files/Makefile b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
new file mode 100644
index 0000000000..4ded35fbc3
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
@@ -0,0 +1,14 @@
1obj-m := hello.o
2
3SRC := $(shell pwd)
4
5all:
6 $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
7
8modules_install:
9 $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
10
11clean:
12 rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
13 rm -f Module.markers Module.symvers modules.order
14 rm -rf .tmp_versions Modules.symvers