summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorFrancisco Pedraza <francisco.j.pedraza.gonzalez@intel.com>2016-11-24 15:54:53 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-16 10:23:23 +0000
commit23d1c4ffb7791e2f75f0eaa84dd6b936d3b861f7 (patch)
tree777f48bcbc93a5cae7b0e0ef0c47772f010545f0 /meta-selftest
parent3f6e6f4e69f644bd466774607f43b8f306376b42 (diff)
downloadpoky-23d1c4ffb7791e2f75f0eaa84dd6b936d3b861f7.tar.gz
selftest: Test needed to verify postinst order
It verifies the following: 1. Compile a minimal image. 2. The compiled image will add the layer with the recipe postinst, previously created at: "meta-selftest/recipes-test" 3. Run QEMU. 4. Validate the task execution order. [YOCTO #5319] (From OE-Core rev: a8ff789a3bfedcbc4358db7907a45270d8b1b76a) Signed-off-by: Francisco Pedraza <francisco.j.pedraza.gonzalez@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/postinst/postinst_1.0.bb124
1 files changed, 124 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/postinst/postinst_1.0.bb b/meta-selftest/recipes-test/postinst/postinst_1.0.bb
new file mode 100644
index 0000000000..97a1987305
--- /dev/null
+++ b/meta-selftest/recipes-test/postinst/postinst_1.0.bb
@@ -0,0 +1,124 @@
1LICENSE = "MIT"
2ALLOW_EMPTY_${PN}-at-rootfs = "1"
3ALLOW_EMPTY_${PN}-delayed-a = "1"
4ALLOW_EMPTY_${PN}-delayed-b = "1"
5ALLOW_EMPTY_${PN}-delayed-d = "1"
6ALLOW_EMPTY_${PN}-delayed-p = "1"
7ALLOW_EMPTY_${PN}-delayed-t = "1"
8
9PACKAGES += "${PN}-at-rootfs ${PN}-delayed-a ${PN}-delayed-b ${PN}-delayed-d ${PN}-delayed-p ${PN}-delayed-t"
10PROVIDES += "${PN}-at-rootfs ${PN}-delayed-a ${PN}-delayed-b ${PN}-delayed-d ${PN}-delayed-p ${PN}-delayed-t"
11FILES_${PN}-delayed-a = ""
12FILES_${PN}-delayed-b = ""
13FILES_${PN}-delayed-d = ""
14FILES_${PN}-delayed-p = ""
15FILES_${PN}-delayed-t = ""
16
17# Runtime dependencies
18RDEPENDS_${PN}-delayed-a = "${PN}-at-rootfs"
19RDEPENDS_${PN}-delayed-b = "${PN}-delayed-a"
20RDEPENDS_${PN}-delayed-d = "${PN}-delayed-b"
21RDEPENDS_${PN}-delayed-p = "${PN}-delayed-d"
22RDEPENDS_${PN}-delayed-t = "${PN}-delayed-p"
23
24# Main recipe post-install
25pkg_postinst_${PN}-at-rootfs () {
26 tfile="/etc/postinsta-test"
27 if test "x$D" != "x" then
28 # Need to run on first boot
29 exit 1
30 else
31 echo "lets write postinst" > $tfile
32 fi
33}
34
35# Dependency recipes post-installs
36pkg_postinst_${PN}-delayed-a () {
37 efile="/etc/postinst-test"
38 tfile="/etc/postinsta-test"
39 rdeps="postinst"
40
41 if test "x$D" != "x"; then
42 # Need to run on first boot
43 exit 1
44 else
45 if test -e $efile ; then
46 echo 'success' > $tfile
47 else
48 echo 'fail to install $rdeps first!' >&2
49 exit 1
50 fi
51 fi
52}
53
54pkg_postinst_${PN}-delayed-b () {
55 efile="/etc/postinsta-test"
56 tfile="/etc/postinstb-test"
57 rdeps="postinsta"
58
59 if test "x$D" != "x"; then
60 # Need to run on first boot
61 exit 1
62 else
63 if test -e $efile ; then
64 echo 'success' > $tfile
65 else
66 echo 'fail to install $rdeps first!' >&2
67 exit 1
68 fi
69 fi
70}
71
72pkg_postinst_${PN}-delayed-d () {
73 efile="/etc/postinstb-test"
74 tfile="/etc/postinstd-test"
75 rdeps="postinstb"
76
77 if test "x$D" != "x"; then
78 # Need to run on first boot
79 exit 1
80 else
81 if test -e $efile ; then
82 echo 'success' > $tfile
83 else
84 echo 'fail to install $rdeps first!' >&2
85 exit 1
86 fi
87 fi
88}
89
90pkg_postinst_${PN}-delayed-p () {
91 efile="/etc/postinstd-test"
92 tfile="/etc/postinstp-test"
93 rdeps="postinstd"
94
95 if test "x$D" != "x"; then
96 # Need to run on first boot
97 exit 1
98 else
99 if test -e $efile ; then
100 echo 'success' > $tfile
101 else
102 echo 'fail to install $rdeps first!' >&2
103 exit 1
104 fi
105 fi
106}
107
108pkg_postinst_${PN}-delayed-t () {
109 efile="/etc/postinstp-test"
110 tfile="/etc/postinstt-test"
111 rdeps="postinstp"
112
113 if test "x$D" != "x"; then
114 # Need to run on first boot
115 exit 1
116 else
117 if test -e $efile ; then
118 echo 'success' > $tfile
119 else
120 echo 'fail to install $rdeps first!' >&2
121 exit 1
122 fi
123 fi
124}