diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2018-11-30 12:38:28 +1300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-12-03 12:20:00 +0000 |
commit | 5cd79e81471ca392bb697c2161526423b5a5dc07 (patch) | |
tree | 6f5b7dd880e6fb96876ba56303d746f9929052cc /meta-selftest | |
parent | 1c0a6cdf428f8a7378ac739ff5193bf8fb372264 (diff) | |
download | poky-5cd79e81471ca392bb697c2161526423b5a5dc07.tar.gz |
oe-selftest: add some tests for recipeutils module
Add some tests for functions in meta/lib/oe/recipeutils.py, in
particular for a few issues I've just fixed. I haven't added tests for
all of the functions - some of them are already being tested via devtool
in any case.
(From OE-Core rev: 72d0cb3f8f1e69aeef93ea0bc90db3e8b8d6f94c)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
6 files changed, 36 insertions, 0 deletions
diff --git a/meta-selftest/recipes-devtools/python/python-async-test.inc b/meta-selftest/recipes-devtools/python/python-async-test.inc new file mode 100644 index 0000000000..c9602e8e52 --- /dev/null +++ b/meta-selftest/recipes-devtools/python/python-async-test.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Python framework to process interdependent tasks in a pool of workers" | ||
2 | HOMEPAGE = "http://github.com/gitpython-developers/async" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e" | ||
6 | |||
7 | inherit pypi | ||
8 | |||
9 | PYPI_PACKAGE = "async" | ||
10 | |||
11 | SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b" | ||
12 | SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051" | ||
13 | |||
14 | RDEPENDS_${PN} += "${PYTHON_PN}-threading" | ||
15 | |||
16 | BBCLASSEXTEND = "nativesdk" | ||
diff --git a/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb b/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb new file mode 100644 index 0000000000..22e241afb3 --- /dev/null +++ b/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-async-test.inc | ||
diff --git a/meta-selftest/recipes-test/recipeutils/recipeutils-test.inc b/meta-selftest/recipes-test/recipeutils/recipeutils-test.inc new file mode 100644 index 0000000000..8490b902d7 --- /dev/null +++ b/meta-selftest/recipes-test/recipeutils/recipeutils-test.inc | |||
@@ -0,0 +1,5 @@ | |||
1 | SRC_URI = "http://xorg.freedesktop.org/releases/individual/lib/libxshmfence-${PV}.tar.bz2" | ||
2 | |||
3 | SRC_URI[md5sum] = "66662e76899112c0f99e22f2fc775a7e" | ||
4 | SRC_URI[sha256sum] = "d21b2d1fd78c1efbe1f2c16dae1cb23f8fd231dcf891465b8debe636a9054b0c" | ||
5 | |||
diff --git a/meta-selftest/recipes-test/recipeutils/recipeutils-test/anotherfile b/meta-selftest/recipes-test/recipeutils/recipeutils-test/anotherfile new file mode 100644 index 0000000000..e69de29bb2 --- /dev/null +++ b/meta-selftest/recipes-test/recipeutils/recipeutils-test/anotherfile | |||
diff --git a/meta-selftest/recipes-test/recipeutils/recipeutils-test/somefile b/meta-selftest/recipes-test/recipeutils/recipeutils-test/somefile new file mode 100644 index 0000000000..e69de29bb2 --- /dev/null +++ b/meta-selftest/recipes-test/recipeutils/recipeutils-test/somefile | |||
diff --git a/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb b/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb new file mode 100644 index 0000000000..f6da97b2d4 --- /dev/null +++ b/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | SUMMARY = "Test recipe for recipeutils.patch_recipe()" | ||
2 | |||
3 | require recipeutils-test.inc | ||
4 | |||
5 | LICENSE = "Proprietary" | ||
6 | |||
7 | DEPENDS += "virtual/libx11" | ||
8 | |||
9 | BBCLASSEXTEND = "native nativesdk" | ||
10 | |||
11 | SRC_URI += "file://somefile" | ||
12 | |||
13 | SRC_URI_append = " file://anotherfile" | ||