summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-01-29 14:01:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-30 11:50:12 +0000
commit6ca669105ff7f405e85142d1aa5375a8430c9606 (patch)
tree6b63559fee22c94da95c81043d42a519245bbd98 /meta-selftest
parent32c500b8ea2c8c76edf35a860477be34af72c499 (diff)
downloadpoky-6ca669105ff7f405e85142d1aa5375a8430c9606.tar.gz
package.bbclass: add support for pkg_postinst_ontarget()
This function is a convenient and more readable shortcut for situations when the postinst code always needs to run on target. All commands that cannot be executed during cross-install and can only be run on target should go into this function. They will only be executed on first boot (if package was cross-installed) or immediately during package installation on target. Plain pkg_postinst() works as before: it is run during cross-install time, it can contain a request to defer to first boot, and it is also run during package installation on target. Also fix the oeqa test for this functionality to use the new function where appropriate. (From OE-Core rev: 229f4e975fb6957f44b5c56735fd6d58564098d7) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/postinst/postinst_1.0.bb14
1 files changed, 2 insertions, 12 deletions
diff --git a/meta-selftest/recipes-test/postinst/postinst_1.0.bb b/meta-selftest/recipes-test/postinst/postinst_1.0.bb
index 112aa08c80..d4bab6dcc2 100644
--- a/meta-selftest/recipes-test/postinst/postinst_1.0.bb
+++ b/meta-selftest/recipes-test/postinst/postinst_1.0.bb
@@ -35,14 +35,9 @@ pkg_postinst_${PN}-rootfs () {
35 35
36# Depends on rootfs, delays until first boot, verifies that the rootfs file was 36# Depends on rootfs, delays until first boot, verifies that the rootfs file was
37# written. 37# written.
38pkg_postinst_${PN}-delayed-a () { 38pkg_postinst_ontarget_${PN}-delayed-a () {
39 set -e 39 set -e
40 40
41 if [ -n "$D" ]; then
42 echo "Delaying ${PN}-delayed-a until first boot"
43 exit 1
44 fi
45
46 if [ ! -e ${TESTDIR}/rootfs ]; then 41 if [ ! -e ${TESTDIR}/rootfs ]; then
47 echo "${PN}-delayed-a: ${TESTDIR}/rootfs not found" 42 echo "${PN}-delayed-a: ${TESTDIR}/rootfs not found"
48 exit 1 43 exit 1
@@ -53,14 +48,9 @@ pkg_postinst_${PN}-delayed-a () {
53 48
54# Depends on delayed-a, delays until first boot, verifies that the delayed-a file was 49# Depends on delayed-a, delays until first boot, verifies that the delayed-a file was
55# written. This verifies the ordering between delayed postinsts. 50# written. This verifies the ordering between delayed postinsts.
56pkg_postinst_${PN}-delayed-b () { 51pkg_postinst_ontarget_${PN}-delayed-b () {
57 set -e 52 set -e
58 53
59 if [ -n "$D" ]; then
60 echo "Delaying ${PN}-delayed-b until first boot"
61 exit 1
62 fi
63
64 if [ ! -e ${TESTDIR}/delayed-a ]; then 54 if [ ! -e ${TESTDIR}/delayed-a ]; then
65 echo "${PN}-delayed-b: ${TESTDIR}/delayed-a not found" 55 echo "${PN}-delayed-b: ${TESTDIR}/delayed-a not found"
66 exit 1 56 exit 1