diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2016-02-24 17:30:17 +1300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-02-28 11:33:01 +0000 |
commit | bf4d380b978c253f3244dbacbee7d2dd8f381599 (patch) | |
tree | 9721c077aa72b27f6336e809c3789d3614e172bd /meta-selftest | |
parent | 4bae2f25b8a55c80c3ca48b63d093c5a7594c636 (diff) | |
download | poky-bf4d380b978c253f3244dbacbee7d2dd8f381599.tar.gz |
oe-selftest: devtool: add an additional test for devtool upgrade
Add a test for devtool upgrade with a recipe pointing to a git
repository, since this uses several different code paths.
(From OE-Core rev: d3ec74ff4db248ea11a568d5214708d6a1757012)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r-- | meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb | 18 | ||||
-rw-r--r-- | meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb.upgraded | 17 |
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb b/meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb new file mode 100644 index 0000000000..9bfce0afee --- /dev/null +++ b/meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "A simple tool to wait for a specific signal over DBus" | ||
2 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/dbus-wait" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
6 | |||
7 | DEPENDS = "dbus" | ||
8 | |||
9 | # Note: this is intentionally not the latest version in the original .bb | ||
10 | SRCREV = "1a3e1343761b30750bed70e0fd688f6d3c7b3717" | ||
11 | PV = "0.1+git${SRCPV}" | ||
12 | PR = "r2" | ||
13 | |||
14 | SRC_URI = "git://git.yoctoproject.org/dbus-wait" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
diff --git a/meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb.upgraded b/meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb.upgraded new file mode 100644 index 0000000000..9b947ed9ea --- /dev/null +++ b/meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb.upgraded | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "A simple tool to wait for a specific signal over DBus" | ||
2 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/dbus-wait" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
6 | |||
7 | DEPENDS = "dbus" | ||
8 | |||
9 | # Note: this is intentionally not the latest version in the original .bb | ||
10 | SRCREV = "6cc6077a36fe2648a5f993fe7c16c9632f946517" | ||
11 | PV = "0.1+git${SRCPV}" | ||
12 | |||
13 | SRC_URI = "git://git.yoctoproject.org/dbus-wait" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit autotools pkgconfig | ||