summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-01 22:52:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-21 12:08:04 +0100
commitd6ae8d2004f8ac3aab4571e0077d406b2d19b542 (patch)
tree6fee0cb55968ea21155c7556bcfb56af956eda2c /meta-selftest
parent71c6db8e65ced98db74fd18b726fa4b4c0346f05 (diff)
downloadpoky-d6ae8d2004f8ac3aab4571e0077d406b2d19b542.tar.gz
recipes: Switch away from S = WORKDIR
Where recipes use S = ${WORKDIR}, change them to set UNPACKDIR to a subdir of WORKDIR and make S point at this instead. I've chosen not to force S into any standard UNPACKDIR we may pick in future just so the S = UNPACKDIR case is clearly visible by the directory naming under WORKDIR as that should aid usability. (From OE-Core rev: d9328e3b0b062f0621de3d114584b44f384a1c02) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/cpp/cpp-example.inc3
-rw-r--r--meta-selftest/recipes-test/selftest-chown/selftest-chown.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb5
-rw-r--r--meta-selftest/recipes-test/selftest-users/acreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/bcreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/ccreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/creategroup1.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/creategroup2.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/dcreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/useraddbadtask.bb3
11 files changed, 23 insertions, 12 deletions
diff --git a/meta-selftest/recipes-test/cpp/cpp-example.inc b/meta-selftest/recipes-test/cpp/cpp-example.inc
index ad374be9d0..41aaa7219a 100644
--- a/meta-selftest/recipes-test/cpp/cpp-example.inc
+++ b/meta-selftest/recipes-test/cpp/cpp-example.inc
@@ -19,6 +19,7 @@ SRC_URI = "\
19 file://run-ptest \ 19 file://run-ptest \
20" 20"
21 21
22S = "${WORKDIR}" 22S = "${WORKDIR}/sources"
23UNPACKDIR = "${S}"
23 24
24inherit ptest 25inherit ptest
diff --git a/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb b/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb
index aa6ce0c2a0..a0eeb4f223 100644
--- a/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb
+++ b/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6DEPENDS += "coreutils-native" 6DEPENDS += "coreutils-native"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10inherit useradd allarch 11inherit useradd allarch
11 12
diff --git a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
index 49c3fe827a..5632bdac7a 100644
--- a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
+++ b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
@@ -6,7 +6,8 @@ SRC_URI = "file://hello.c \
6 file://gdb.sh \ 6 file://gdb.sh \
7" 7"
8 8
9S = "${WORKDIR}" 9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
10 11
11do_compile () { 12do_compile () {
12 ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS} 13 ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS}
diff --git a/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb b/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
index 547587bef4..2dc352d479 100644
--- a/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
+++ b/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
5 5
6SRC_URI = "file://helloworld.c" 6SRC_URI = "file://helloworld.c"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10do_compile() { 11do_compile() {
11 ${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld 12 ${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld
@@ -16,4 +17,4 @@ do_install() {
16 install -m 0755 helloworld ${D}${bindir} 17 install -m 0755 helloworld ${D}${bindir}
17} 18}
18 19
19BBCLASSEXTEND = "native nativesdk" \ No newline at end of file 20BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-selftest/recipes-test/selftest-users/acreategroup.bb b/meta-selftest/recipes-test/selftest-users/acreategroup.bb
index 66ed5695a2..7805182d48 100644
--- a/meta-selftest/recipes-test/selftest-users/acreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/acreategroup.bb
@@ -3,7 +3,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
3 3
4LICENSE = "MIT" 4LICENSE = "MIT"
5 5
6S = "${WORKDIR}" 6S = "${WORKDIR}/sources"
7UNPACKDIR = "${S}"
7 8
8EXCLUDE_FROM_WORLD="1" 9EXCLUDE_FROM_WORLD="1"
9 10
diff --git a/meta-selftest/recipes-test/selftest-users/bcreategroup.bb b/meta-selftest/recipes-test/selftest-users/bcreategroup.bb
index c4844dd0da..b15c07d7b2 100644
--- a/meta-selftest/recipes-test/selftest-users/bcreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/bcreategroup.bb
@@ -7,7 +7,8 @@ LICENSE = "MIT"
7 7
8USERADD_DEPENDS = "acreategroup ccreategroup" 8USERADD_DEPENDS = "acreategroup ccreategroup"
9 9
10S = "${WORKDIR}" 10S = "${WORKDIR}/sources"
11UNPACKDIR = "${S}"
11 12
12EXCLUDE_FROM_WORLD="1" 13EXCLUDE_FROM_WORLD="1"
13 14
diff --git a/meta-selftest/recipes-test/selftest-users/ccreategroup.bb b/meta-selftest/recipes-test/selftest-users/ccreategroup.bb
index 021b1ebbf7..ff2da1c039 100644
--- a/meta-selftest/recipes-test/selftest-users/ccreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/ccreategroup.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6USERADD_DEPENDS = "acreategroup" 6USERADD_DEPENDS = "acreategroup"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10EXCLUDE_FROM_WORLD="1" 11EXCLUDE_FROM_WORLD="1"
11 12
diff --git a/meta-selftest/recipes-test/selftest-users/creategroup1.bb b/meta-selftest/recipes-test/selftest-users/creategroup1.bb
index afd23ed1ee..4ab278f589 100644
--- a/meta-selftest/recipes-test/selftest-users/creategroup1.bb
+++ b/meta-selftest/recipes-test/selftest-users/creategroup1.bb
@@ -3,7 +3,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
3 3
4LICENSE = "MIT" 4LICENSE = "MIT"
5 5
6S = "${WORKDIR}" 6S = "${WORKDIR}/sources"
7UNPACKDIR = "${S}"
7 8
8inherit useradd allarch 9inherit useradd allarch
9 10
diff --git a/meta-selftest/recipes-test/selftest-users/creategroup2.bb b/meta-selftest/recipes-test/selftest-users/creategroup2.bb
index f776f43aed..179aba9bfc 100644
--- a/meta-selftest/recipes-test/selftest-users/creategroup2.bb
+++ b/meta-selftest/recipes-test/selftest-users/creategroup2.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6USERADD_DEPENDS = "creategroup1" 6USERADD_DEPENDS = "creategroup1"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10inherit useradd allarch 11inherit useradd allarch
11 12
diff --git a/meta-selftest/recipes-test/selftest-users/dcreategroup.bb b/meta-selftest/recipes-test/selftest-users/dcreategroup.bb
index b96ca92a16..ab0a529669 100644
--- a/meta-selftest/recipes-test/selftest-users/dcreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/dcreategroup.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6USERADD_DEPENDS = "bcreategroup" 6USERADD_DEPENDS = "bcreategroup"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10EXCLUDE_FROM_WORLD="1" 11EXCLUDE_FROM_WORLD="1"
11 12
diff --git a/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb b/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
index 99e04a80b3..2863541010 100644
--- a/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
+++ b/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6DEPENDS:append = "coreutils-native" 6DEPENDS:append = "coreutils-native"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10inherit useradd allarch 11inherit useradd allarch
11 12