summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-20 17:19:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-26 14:00:50 +0100
commitf135cb36596d9cc8996277f49b296b9f73b76b73 (patch)
treeb50117e2cc4115cdc0c62c0b7137e2edf72a2bce /meta-selftest
parentd645fe38d38a9fe499c2c79b1b2dced3bed01a89 (diff)
downloadpoky-f135cb36596d9cc8996277f49b296b9f73b76b73.tar.gz
oeqa/selftest: Add test for conflicting sysroot provider
sysroot-test depends on virtual/sysroot-test which we build for one machine, switch machine, switch provider of virtual/sysroot-test and check that the sysroot is correctly cleaned up. The files in the two providers overlap so can cause errors if the sysroot code doesn't function correctly. Yes, sysroot-test should be machine specific really to avoid this, however the sysroot cleanup should also work. This adds a test for bug: [YOCTO #13702] (From OE-Core rev: 24ca62b3c1fd404b67d549b29aeeacf913e6dc86) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb14
-rw-r--r--meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb14
-rw-r--r--meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb6
3 files changed, 34 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb
new file mode 100644
index 0000000000..36a682c53d
--- /dev/null
+++ b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb
@@ -0,0 +1,14 @@
1LICENSE = "CLOSED"
2
3PROVIDES = "virtual/sysroot-test"
4INHIBIT_DEFAULT_DEPS = "1"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7TESTSTRING ?= "1"
8
9do_install() {
10 install -d ${D}${includedir}
11 echo "# test ${TESTSTRING}" > ${D}${includedir}/sysroot-test.h
12}
13
14EXCLUDE_FROM_WORLD = "1"
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb
new file mode 100644
index 0000000000..67172f3cab
--- /dev/null
+++ b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb
@@ -0,0 +1,14 @@
1LICENSE = "CLOSED"
2
3PROVIDES = "virtual/sysroot-test"
4INHIBIT_DEFAULT_DEPS = "1"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7TESTSTRING ?= "2"
8
9do_install() {
10 install -d ${D}${includedir}
11 echo "# test ${TESTSTRING}" > ${D}${includedir}/sysroot-test.h
12}
13
14EXCLUDE_FROM_WORLD = "1"
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb
new file mode 100644
index 0000000000..560487c159
--- /dev/null
+++ b/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb
@@ -0,0 +1,6 @@
1SUMMARY = "Virtual provider sysroot test"
2LICENSE = "CLOSED"
3INHIBIT_DEFAULT_DEPS = "1"
4DEPENDS = "virtual/sysroot-test"
5
6EXCLUDE_FROM_WORLD = "1"