summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@linux.intel.com>2017-01-30 13:16:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-19 06:49:00 -0800
commit23bd7e100adb6dc06c4992ff5863f01d0b39e75b (patch)
tree67b6f295aa249b9ff6801d519bc09b2e1e2598f8 /meta-selftest
parent5da9c1c38b31c5edb957ad22fd093c9bc3a2ecd7 (diff)
downloadpoky-23bd7e100adb6dc06c4992ff5863f01d0b39e75b.tar.gz
selftest/containerimage.py: Add container IMAGE_FSTYPES test
This test checks to make sure only the files expected exist in a container image. Currently only ROOTFS_BOOTSTRAP_INSTALL, gets added to all images without the user specifying it. But this test should help if a developer in the future ever silently adds more than just ROOTFS_BOOTSTRAP_INSTALL, and that the developer can make sure it also gets removed from a container image. [YOCTO #9502] (From OE-Core rev: 4f5e5321fafe491f91d78a35d11afc0dc0527d4b) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/container-image/container-image-testpkg.bb8
-rw-r--r--meta-selftest/recipes-test/container-image/container-test-image.bb8
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/container-image/container-image-testpkg.bb b/meta-selftest/recipes-test/container-image/container-image-testpkg.bb
new file mode 100644
index 0000000000..f8dd2290b3
--- /dev/null
+++ b/meta-selftest/recipes-test/container-image/container-image-testpkg.bb
@@ -0,0 +1,8 @@
1LICENSE = "MIT"
2
3INHIBIT_DEFAULT_DEPS = "1"
4
5do_install_append() {
6 install -d ${D}${bindir}
7 touch ${D}${bindir}/theapp
8}
diff --git a/meta-selftest/recipes-test/container-image/container-test-image.bb b/meta-selftest/recipes-test/container-image/container-test-image.bb
new file mode 100644
index 0000000000..d5f939c6e9
--- /dev/null
+++ b/meta-selftest/recipes-test/container-image/container-test-image.bb
@@ -0,0 +1,8 @@
1IMAGE_INSTALL += "container-image-testpkg"
2
3LICENSE = "MIT"
4
5IMAGE_FSTYPES = "container"
6IMAGE_LINGUAS = ""
7
8inherit core-image