summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-07-31 12:53:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-31 23:03:01 +0100
commita4bb53437ee277f3587767574a29cf45939dcea7 (patch)
tree4c27bdd5ba55742745f39bf11ab54d47aed8acbf /meta-selftest
parent1ea5b2f0745c359223b4df7559e915ee677ea876 (diff)
downloadpoky-a4bb53437ee277f3587767574a29cf45939dcea7.tar.gz
fortran-helloworld: neaten recipe
Use ${FC} instead of constructing the fortran name/arguments explictly, and clean up installation. (From OE-Core rev: a0d85e117fb636ffa12253b19f0ab2b5055e6380) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/fortran/fortran-helloworld.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
index 97313d7e24..3a46404477 100644
--- a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
+++ b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
@@ -11,15 +11,14 @@ SECURITY_CFLAGS = ""
11SECURITY_LDFLAGS = "" 11SECURITY_LDFLAGS = ""
12 12
13do_compile() { 13do_compile() {
14 ${HOST_PREFIX}gfortran ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello 14 ${FC} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello
15} 15}
16 16
17do_install() { 17do_install() {
18 install -d ${D}${bindir} 18 install -D ${B}/fortran-hello ${D}${bindir}/fortran-hello
19 install ${B}/fortran-hello ${D}${bindir}
20} 19}
21 20
22python () { 21python () {
23 if not d.getVar("FORTRAN"): 22 if not d.getVar("FORTRAN"):
24 raise bb.parse.SkipRecipe("Fortran isn't enabled") 23 raise bb.parse.SkipRecipe("Fortran isn't enabled")
25} \ No newline at end of file 24}