summaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-20 17:19:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-07 13:03:30 +0100
commit21684e6c836fc3a85b19b44d1a1cd04889711f09 (patch)
tree6ca36243c0f3617308f3e60110f4ec4875ed6053 /meta-selftest
parent1246049541633a89e34657657792eb72dab9b6b9 (diff)
downloadpoky-21684e6c836fc3a85b19b44d1a1cd04889711f09.tar.gz
oeqa/selftest: Add test for conflicting sysroot provider
sysroot-test depends on virtual/sysroot-test which we build for one machine, switch machine, switch provider of virtual/sysroot-test and check that the sysroot is correctly cleaned up. The files in the two providers overlap so can cause errors if the sysroot code doesn't function correctly. Yes, sysroot-test should be machine specific really to avoid this, however the sysroot cleanup should also work. This adds a test for bug: [YOCTO #13702] (From OE-Core rev: 31a8b4935e673aba8a1147c4a2fb510b1a8bc3ce) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb14
-rw-r--r--meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb14
-rw-r--r--meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb6
3 files changed, 34 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb
new file mode 100644
index 0000000000..36a682c53d
--- /dev/null
+++ b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch1_1.0.bb
@@ -0,0 +1,14 @@
1LICENSE = "CLOSED"
2
3PROVIDES = "virtual/sysroot-test"
4INHIBIT_DEFAULT_DEPS = "1"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7TESTSTRING ?= "1"
8
9do_install() {
10 install -d ${D}${includedir}
11 echo "# test ${TESTSTRING}" > ${D}${includedir}/sysroot-test.h
12}
13
14EXCLUDE_FROM_WORLD = "1"
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb
new file mode 100644
index 0000000000..67172f3cab
--- /dev/null
+++ b/meta-selftest/recipes-test/sysroot-test/sysroot-test-arch2_1.0.bb
@@ -0,0 +1,14 @@
1LICENSE = "CLOSED"
2
3PROVIDES = "virtual/sysroot-test"
4INHIBIT_DEFAULT_DEPS = "1"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7TESTSTRING ?= "2"
8
9do_install() {
10 install -d ${D}${includedir}
11 echo "# test ${TESTSTRING}" > ${D}${includedir}/sysroot-test.h
12}
13
14EXCLUDE_FROM_WORLD = "1"
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb
new file mode 100644
index 0000000000..560487c159
--- /dev/null
+++ b/meta-selftest/recipes-test/sysroot-test/sysroot-test_1.0.bb
@@ -0,0 +1,6 @@
1SUMMARY = "Virtual provider sysroot test"
2LICENSE = "CLOSED"
3INHIBIT_DEFAULT_DEPS = "1"
4DEPENDS = "virtual/sysroot-test"
5
6EXCLUDE_FROM_WORLD = "1"