diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2023-03-13 13:15:33 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2023-06-29 11:28:32 +0100 |
commit | 92f8d99fe01734ddd81b0ddc145b0b18c7e00185 (patch) | |
tree | 4e7f016f1e35e2e31ba1a523d3f60daec19aaeb5 /meta-selftest/recipes-test | |
parent | 186f1ee88d6981e9f4a4a48ff1ee0bd0b719b18b (diff) | |
download | poky-92f8d99fe01734ddd81b0ddc145b0b18c7e00185.tar.gz |
selftest: multiconfig-image-packager: try to respect IMAGE_LINK_NAME
* this still assumes that IMAGE_LINK_NAME will contain IMAGE_BASENAME
which will be BPN 'multiconfig-image-packager' and that replacing
it with 'core-image-minimal' will match with the actual IMAGE_LINK_NAME
from core-image-minimal recipe - there is no good way to query
core-image-minimal's context, but this is still closer than assuming:
core-image-minimal-${MCMACHINE}.${MCIMGTYPE}
which works only with the current default:
IMAGE_LINK_NAME ?= "${IMAGE_BASENAME}-${MACHINE}"
[YOCTO #12937]
(From OE-Core rev: d4403365af6a5b9aa3b87ef8fd689d3bbcd23318)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r-- | meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb | 18 |
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb b/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb index daf2834958..d7785cee2e 100644 --- a/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb +++ b/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb | |||
@@ -7,15 +7,19 @@ MCIMGTYPE:virtclass-mcextend-musl = "ext4" | |||
7 | MCIMGTYPE:virtclass-mcextend-tiny = "cpio.gz" | 7 | MCIMGTYPE:virtclass-mcextend-tiny = "cpio.gz" |
8 | 8 | ||
9 | MC_DEPLOY_DIR_IMAGE = "${TOPDIR}/tmp-mc-${MCNAME}/deploy/images/${MCMACHINE}" | 9 | MC_DEPLOY_DIR_IMAGE = "${TOPDIR}/tmp-mc-${MCNAME}/deploy/images/${MCMACHINE}" |
10 | MC_DEPLOY_IMAGE_BASENAME = "core-image-minimal" | ||
10 | 11 | ||
11 | do_install[mcdepends] += "mc::${MCNAME}:core-image-minimal:do_image_complete mc::${MCNAME}:virtual/kernel:do_deploy" | 12 | do_install[mcdepends] += "mc::${MCNAME}:core-image-minimal:do_image_complete mc::${MCNAME}:virtual/kernel:do_deploy" |
12 | 13 | ||
13 | do_install () { | 14 | do_install () { |
14 | install -d ${D}/var/lib/machines/${MCNAME} | 15 | install -d ${D}/var/lib/machines/${MCNAME} |
15 | install ${MC_DEPLOY_DIR_IMAGE}/core-image-minimal-${MCMACHINE}.${MCIMGTYPE} ${D}/var/lib/machines/${MCNAME}/core-image-minimal.${MCIMGTYPE} | 16 | install ${MC_DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME_CORE_IMAGE_MINIMAL}.${MCIMGTYPE} ${D}/var/lib/machines/${MCNAME}/${MC_DEPLOY_IMAGE_BASENAME}.${MCIMGTYPE} |
16 | install ${MC_DEPLOY_DIR_IMAGE}/bzImage ${D}/var/lib/machines/${MCNAME} | 17 | install ${MC_DEPLOY_DIR_IMAGE}/bzImage ${D}/var/lib/machines/${MCNAME} |
17 | } | 18 | } |
18 | 19 | ||
20 | # for IMAGE_LINK_NAME, IMAGE_BASENAME | ||
21 | inherit image-artifact-names | ||
22 | |||
19 | python () { | 23 | python () { |
20 | mcname = d.getVar('MCNAME') | 24 | mcname = d.getVar('MCNAME') |
21 | if not mcname: | 25 | if not mcname: |
@@ -23,6 +27,18 @@ python () { | |||
23 | multiconfigs = d.getVar('BBMULTICONFIG') or "" | 27 | multiconfigs = d.getVar('BBMULTICONFIG') or "" |
24 | if mcname not in multiconfigs: | 28 | if mcname not in multiconfigs: |
25 | raise bb.parse.SkipRecipe("multiconfig target %s not enabled" % mcname) | 29 | raise bb.parse.SkipRecipe("multiconfig target %s not enabled" % mcname) |
30 | |||
31 | # these will most likely start with my BPN multiconfig-image-packager, but I want them from core-image-minimal | ||
32 | # as there is no good way to query core-image-minimal's context lets assume that there are no overrides | ||
33 | # and that we can just replace IMAGE_BASENAME | ||
34 | image_link_name = d.getVar('IMAGE_LINK_NAME') | ||
35 | image_basename = d.getVar('IMAGE_BASENAME') | ||
36 | machine = d.getVar('MACHINE') | ||
37 | mcmachine = d.getVar('MCMACHINE') | ||
38 | image_to_deploy = d.getVar('MC_DEPLOY_IMAGE_BASENAME') | ||
39 | image_link_name_to_deploy = image_link_name.replace(image_basename, image_to_deploy).replace(machine, mcmachine) | ||
40 | bb.warn('%s: assuming that "%s" built for "%s" has IMAGE_LINK_NAME "%s"' % (d.getVar('PN'), mcmachine, image_to_deploy, image_link_name_to_deploy)) | ||
41 | d.setVar('IMAGE_LINK_NAME_CORE_IMAGE_MINIMAL', image_link_name_to_deploy) | ||
26 | } | 42 | } |
27 | 43 | ||
28 | BBCLASSEXTEND = "mcextend:tiny mcextend:musl" | 44 | BBCLASSEXTEND = "mcextend:tiny mcextend:musl" |