diff options
author | Paulo Neves <ptsneves@gmail.com> | 2022-06-14 17:11:03 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-07-01 12:37:52 +0100 |
commit | 00458ee0f8c0619707b53b7a72450fbd8cbc3e02 (patch) | |
tree | ac8eda9c7327fc686dd491d3ce7aa67ead7ecd5f /meta-selftest/recipes-test | |
parent | 53f0ee8d420008efa7408b1a83c42f7d5438f06a (diff) | |
download | poky-00458ee0f8c0619707b53b7a72450fbd8cbc3e02.tar.gz |
oeqa/selftest: Test staged .la and .pc files
These files are checked by qa_check_staged but there was no
test cases for whether the tests actually worked. Now there
are.
(From OE-Core rev: 2a96719a201cb7b8db774718adec89dbd7e1aec3)
Signed-off-by: Paulo Neves <ptsneves@gmail.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r-- | meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb | 16 | ||||
-rw-r--r-- | meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb | 12 |
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb new file mode 100644 index 0000000000..21f06782fb --- /dev/null +++ b/meta-selftest/recipes-test/sysroot-test/sysroot-la-test_1.0.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Produce a broken la file" | ||
2 | LICENSE = "CLOSED" | ||
3 | INHIBIT_DEFAULT_DEPS = "1" | ||
4 | |||
5 | EXCLUDE_FROM_WORLD = "1" | ||
6 | |||
7 | # remove-libtool.bbclass is inherited by default and removes all | ||
8 | # .la files which for this test we specifically do not want. | ||
9 | REMOVE_LIBTOOL_LA = "0" | ||
10 | |||
11 | do_install() { | ||
12 | install -d ${D}${libdir}/test/ | ||
13 | echo '${WORKDIR}' > ${D}${libdir}/test/la-test.la | ||
14 | } | ||
15 | |||
16 | BBCLASSEXTEND += "native" | ||
diff --git a/meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb b/meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb new file mode 100644 index 0000000000..e748310fc4 --- /dev/null +++ b/meta-selftest/recipes-test/sysroot-test/sysroot-pc-test_1.0.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | SUMMARY = "Produce a broken pc file" | ||
2 | LICENSE = "CLOSED" | ||
3 | INHIBIT_DEFAULT_DEPS = "1" | ||
4 | |||
5 | EXCLUDE_FROM_WORLD = "1" | ||
6 | |||
7 | do_install() { | ||
8 | install -d ${D}${libdir}/test/ | ||
9 | echo '${WORKDIR}' > ${D}${libdir}/test/test.pc | ||
10 | } | ||
11 | |||
12 | BBCLASSEXTEND += "native" | ||