summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-25 17:01:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-26 15:43:43 +0100
commitc5312dd92bd9fd88948567938a0f3b66782ae869 (patch)
tree6fafaa4c430beb023cb75344ec9a3293a2f90392 /meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
parent39b85616adc434fc12aaa260268cebf3b4d9395f (diff)
downloadpoky-c5312dd92bd9fd88948567938a0f3b66782ae869.tar.gz
recipes: Avoid S = WORKDIR
Where recipes use S = ${WORKDIR}, change them to set UNPACKDIR to a subdir of WORKDIR and make S point at this instead. Where WORKDIR is referenced in do_compile/do_install and similar, switch to using ${S} which conceptually makes more sense. (From OE-Core rev: d0c1ae3ffacacc762f957b9b306dfb0a912c4859) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb')
-rw-r--r--meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
index be346b8a0e..5632bdac7a 100644
--- a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
+++ b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
@@ -6,7 +6,8 @@ SRC_URI = "file://hello.c \
6 file://gdb.sh \ 6 file://gdb.sh \
7" 7"
8 8
9S = "${WORKDIR}" 9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
10 11
11do_compile () { 12do_compile () {
12 ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS} 13 ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS}
@@ -14,7 +15,7 @@ do_compile () {
14 15
15do_install () { 16do_install () {
16 install -d ${D}${bindir} 17 install -d ${D}${bindir}
17 install -m 755 ${WORKDIR}/gdb.sh ${D}${bindir}/ 18 install -m 755 ${S}/gdb.sh ${D}${bindir}/
18 install -m 755 hello1 ${D}${bindir}/hello1 19 install -m 755 hello1 ${D}${bindir}/hello1
19 ln ${D}${bindir}/hello1 ${D}${bindir}/hello2 20 ln ${D}${bindir}/hello1 ${D}${bindir}/hello2
20 21