diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-07-28 23:28:15 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-08-02 15:44:10 +0100 |
commit | bb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch) | |
tree | 76e376b01253c3aace1a98a5021bcaad3c92e861 /meta-selftest/recipes-test/postinst | |
parent | fcc456ee4b8f619134abb4649db53c638074082c (diff) | |
download | poky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz |
Convert to new override syntax
This is the result of automated script conversion:
scripts/contrib/convert-overrides.py <oe-core directory>
converting the metadata to use ":" as the override character instead of "_".
(From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test/postinst')
-rw-r--r-- | meta-selftest/recipes-test/postinst/postinst_1.0.bb | 20 |
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-selftest/recipes-test/postinst/postinst_1.0.bb b/meta-selftest/recipes-test/postinst/postinst_1.0.bb index 913bfabf89..b936c4f44b 100644 --- a/meta-selftest/recipes-test/postinst/postinst_1.0.bb +++ b/meta-selftest/recipes-test/postinst/postinst_1.0.bb | |||
@@ -5,19 +5,19 @@ inherit allarch | |||
5 | 5 | ||
6 | PACKAGES = "${PN}-rootfs ${PN}-delayed-a ${PN}-delayed-b ${PN}-rootfs-failing" | 6 | PACKAGES = "${PN}-rootfs ${PN}-delayed-a ${PN}-delayed-b ${PN}-rootfs-failing" |
7 | 7 | ||
8 | ALLOW_EMPTY_${PN}-rootfs = "1" | 8 | ALLOW_EMPTY:${PN}-rootfs = "1" |
9 | ALLOW_EMPTY_${PN}-delayed-a = "1" | 9 | ALLOW_EMPTY:${PN}-delayed-a = "1" |
10 | ALLOW_EMPTY_${PN}-delayed-b = "1" | 10 | ALLOW_EMPTY:${PN}-delayed-b = "1" |
11 | ALLOW_EMPTY_${PN}-rootfs-failing = "1" | 11 | ALLOW_EMPTY:${PN}-rootfs-failing = "1" |
12 | 12 | ||
13 | RDEPENDS_${PN}-delayed-a = "${PN}-rootfs" | 13 | RDEPENDS:${PN}-delayed-a = "${PN}-rootfs" |
14 | RDEPENDS_${PN}-delayed-b = "${PN}-delayed-a" | 14 | RDEPENDS:${PN}-delayed-b = "${PN}-delayed-a" |
15 | 15 | ||
16 | TESTDIR = "${sysconfdir}/postinst-test" | 16 | TESTDIR = "${sysconfdir}/postinst-test" |
17 | 17 | ||
18 | # At rootfs time touch $TESTDIR/rootfs. Errors if the file already exists, or | 18 | # At rootfs time touch $TESTDIR/rootfs. Errors if the file already exists, or |
19 | # if the function runs on first boot. | 19 | # if the function runs on first boot. |
20 | pkg_postinst_${PN}-rootfs () { | 20 | pkg_postinst:${PN}-rootfs () { |
21 | set -e | 21 | set -e |
22 | 22 | ||
23 | if [ -z "$D" ]; then | 23 | if [ -z "$D" ]; then |
@@ -36,7 +36,7 @@ pkg_postinst_${PN}-rootfs () { | |||
36 | 36 | ||
37 | # Depends on rootfs, delays until first boot, verifies that the rootfs file was | 37 | # Depends on rootfs, delays until first boot, verifies that the rootfs file was |
38 | # written. | 38 | # written. |
39 | pkg_postinst_ontarget_${PN}-delayed-a () { | 39 | pkg_postinst_ontarget:${PN}-delayed-a () { |
40 | set -e | 40 | set -e |
41 | 41 | ||
42 | if [ ! -e ${TESTDIR}/rootfs ]; then | 42 | if [ ! -e ${TESTDIR}/rootfs ]; then |
@@ -49,7 +49,7 @@ pkg_postinst_ontarget_${PN}-delayed-a () { | |||
49 | 49 | ||
50 | # Depends on delayed-a, delays until first boot, verifies that the delayed-a file was | 50 | # Depends on delayed-a, delays until first boot, verifies that the delayed-a file was |
51 | # written. This verifies the ordering between delayed postinsts. | 51 | # written. This verifies the ordering between delayed postinsts. |
52 | pkg_postinst_ontarget_${PN}-delayed-b () { | 52 | pkg_postinst_ontarget:${PN}-delayed-b () { |
53 | set -e | 53 | set -e |
54 | 54 | ||
55 | if [ ! -e ${TESTDIR}/delayed-a ]; then | 55 | if [ ! -e ${TESTDIR}/delayed-a ]; then |
@@ -62,7 +62,7 @@ pkg_postinst_ontarget_${PN}-delayed-b () { | |||
62 | 62 | ||
63 | # This scriptlet intentionally includes a bogus command in the middle to test | 63 | # This scriptlet intentionally includes a bogus command in the middle to test |
64 | # that we catch and report such errors properly. | 64 | # that we catch and report such errors properly. |
65 | pkg_postinst_${PN}-rootfs-failing () { | 65 | pkg_postinst:${PN}-rootfs-failing () { |
66 | mkdir -p $D${TESTDIR} | 66 | mkdir -p $D${TESTDIR} |
67 | touch $D${TESTDIR}/rootfs-before-failure | 67 | touch $D${TESTDIR}/rootfs-before-failure |
68 | run_a_really_broken_command | 68 | run_a_really_broken_command |