diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2017-02-17 18:47:22 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-14 14:42:17 +0000 |
commit | 529244ee212fe14019e35a5f163fab705ddbf141 (patch) | |
tree | 494399073efc89e3515294578b87cddd953cf3fd /meta-selftest/recipes-test/images | |
parent | 55928d1237ad4026e8db3cc5424127523543b424 (diff) | |
download | poky-529244ee212fe14019e35a5f163fab705ddbf141.tar.gz |
run-postinsts: simplify the logic of whether to install it to images
The logic is scattered all over the place, but amounts to
"install, unless the rootfs is read only". Let's express that directly.
(From OE-Core rev: 697804229a172125ce7d3bfc9b343812d6fe3240)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test/images')
-rw-r--r-- | meta-selftest/recipes-test/images/oe-selftest-image.bb | 2 | ||||
-rw-r--r-- | meta-selftest/recipes-test/images/wic-image-minimal.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-selftest/recipes-test/images/oe-selftest-image.bb b/meta-selftest/recipes-test/images/oe-selftest-image.bb index f17094c5d0..5d4d10eef6 100644 --- a/meta-selftest/recipes-test/images/oe-selftest-image.bb +++ b/meta-selftest/recipes-test/images/oe-selftest-image.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | SUMMARY = "An image used during oe-selftest tests" | 1 | SUMMARY = "An image used during oe-selftest tests" |
2 | 2 | ||
3 | IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} dropbear" | 3 | IMAGE_INSTALL = "packagegroup-core-boot dropbear" |
4 | IMAGE_FEATURES = "debug-tweaks" | 4 | IMAGE_FEATURES = "debug-tweaks" |
5 | 5 | ||
6 | IMAGE_LINGUAS = " " | 6 | IMAGE_LINGUAS = " " |
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.bb b/meta-selftest/recipes-test/images/wic-image-minimal.bb index b687935c49..95946971c2 100644 --- a/meta-selftest/recipes-test/images/wic-image-minimal.bb +++ b/meta-selftest/recipes-test/images/wic-image-minimal.bb | |||
@@ -2,7 +2,7 @@ SUMMARY = "An example of partitioned image." | |||
2 | 2 | ||
3 | SRC_URI = "file://${FILE_DIRNAME}/${BPN}.wks" | 3 | SRC_URI = "file://${FILE_DIRNAME}/${BPN}.wks" |
4 | 4 | ||
5 | IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}" | 5 | IMAGE_INSTALL = "packagegroup-core-boot" |
6 | 6 | ||
7 | IMAGE_FSTYPES = "wic" | 7 | IMAGE_FSTYPES = "wic" |
8 | 8 | ||