summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/images/wic-image-minimal.bb
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2015-08-31 00:14:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 23:26:25 +0100
commit7c0940196cf6c0cf83729d339da461e5aba670de (patch)
tree5228b8dbbcd44ab17e753c14b4754a16df475a03 /meta-selftest/recipes-test/images/wic-image-minimal.bb
parent70534141e7df610335798fec54895a74664fc822 (diff)
downloadpoky-7c0940196cf6c0cf83729d339da461e5aba670de.tar.gz
wic-image-minimal: add wic image recipe and .wks
Added example of recipe and .wks file to create partitioned image. This image is using quite complex partitioning scheme. It uses its own rootfs to populate two partitions in two different ways. It also uses core-image-minimal rootfs to populate another partition. This is how wic reports about artifacts used to create this image: ROOTFS_DIR: tmp/work/qemux86_64-poky-linux/wic-image-minimal/1.0-r0/rootfs ROOTFS_DIR["/core"]: tmp/work/qemux86_64-poky-linux/core-image-minimal/1.0-r0/rootfs ROOTFS_DIR["/backup"]: tmp/work/qemux86_64-poky-linux/wic-image-minimal/1.0-r0/rootfs BOOTIMG_DIR: tmp/sysroots/qemux86-64/usr/share KERNEL_DIR: tmp/deploy/images/qemux86-64 NATIVE_SYSROOT: tmp/sysroots/x86_64-linux (From OE-Core rev: f7069cbfb8f1e8273584221999d0739f1ae173c4) Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test/images/wic-image-minimal.bb')
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.bb b/meta-selftest/recipes-test/images/wic-image-minimal.bb
new file mode 100644
index 0000000000..073c569fe2
--- /dev/null
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.bb
@@ -0,0 +1,14 @@
1SUMMARY = "An example of partitioned image."
2
3IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}"
4
5IMAGE_FSTYPES = "wic.bz2"
6RM_OLD_IMAGE = "1"
7
8# core-image-minimal is referenced in .wks, so we need its rootfs
9# to be ready before our rootfs
10do_rootfs[depends] += "core-image-minimal:do_rootfs"
11
12IMAGE_ROOTFS_EXTRA_SPACE = "2000"
13
14inherit image